Jump to content

Snippets don't work until Accessibility is re-granted in macOS Permissions [Solved]


Recommended Posts

@tvil @Jezper Could you please both open System Preferences > Security & Privacy > Privacy > Accessibility? Unlock the padlock, then remove Alfred completely (using the minus symbol, not just by unchecking the box) then re-add Alfred 4 to have Accessibility permissions.

 

This will re-set Alfred's permissions and ensure that macOS remembers that Alfred is allowed to perform actions such as auto-expansion. 

 

Could you both let me know how you get on? :) 

 

Cheers,
Vero

Link to comment
  • Vero changed the title to Snippets don't work until Accessibility is re-granted in macOS Permissions [Solved]

Thanks to you both for confirming that's all it was - looks like macOS is losing resolution of permissions, so I've updated the title so that this thread can be useful to anyone who finds it in the future :)

 

Cheers,
Vero

Link to comment
  • 3 weeks later...

This did not work for me. Tried booting my Mac without permission and re-adding it after, still does not work.

 

Anywhere I can look? I am a developer, so logs etc would be fine. Snippets are essential for my everyday workflow, so important for me to get fixed.

 

Cheers,

Alf

 

EDIT:

Alfred 4.3.4 on macOS 11.4 if that is any help at all.

 

Edited by stoyle
Added versions
Link to comment

@stoyle Could you please make sure that Alfred is fully removed from Accessibility using the minus symbol (not just unchecked), then re-added?

 

Next, please take a look at the troubleshooting steps for snippets here, ensuring that you test using TextEdit, as it's the simplest most native app:

https://www.alfredapp.com/help/troubleshooting/snippets/#no-expansion

 

Please provide more details if your issue persists so that I can help you further (e.g. what are your settings in all the locations highlighted by the Troubleshooting, whether this worked previously and what has changed on your Mac since, etc) :)

 

Cheers,
Vero

Link to comment

Sure done all this!

 

Removed:

image.png.c9294a474e34c4f0e639b4a19718c1da.png

 

Added:

image.png.bbcb44dc9f3e6f1341aedf9a827e6c68.png

 

Also did a boot, between these.

 

I am pretty sure these stopped working after the latest macOS update. As far as the troubleshooting.

image.png.4b2b9f185c7ee61aed8a8c3fd6570e9b.png

 

And my expansions are example:

image.png.1c18cae328fa3e87587625d6f1daddc9.png

 

These used to work perfectly. Trying in "simple application" like sublime text and iterm, and many other places. But at least these should not interfere.

 

Are there any logs or anything like that I can check? I can of course try unistalling and re-installing alfred, but seems a bit drastic.

 

Cheers,

Alf

 

 

 

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...