Jump to content

Quickly add data to a Notion [official api] database


Recommended Posts

On 6/3/2021 at 11:41 AM, pigpigfour said:

Setup ok

Notion Database and Token setup ok

But not sync to the Notion~~

 

I dont know why~~

 

Have you installed the workflow using npm or directly on Alfred with .workflow file? If it was the latest you might have to open the workflow folder on terminal and run `npm install`  

 

Let me know if that helps, so then I can update the instructions on github - otherwise we might need some more details.

 

 

Screenshot 2021-06-04 at 13.07.39.png

Link to comment

I was able to make it work. Check that you have renamed the "name" property in your database to "Task" to make it work. If that is not working, check the "Debug" log in the workflow details.

Link to comment
  • 2 weeks later...

Hello,
Thank you so much for this workflow, it's a game changer for me ! 

I currently can't make it work though. I followed the information I found in this thread but I still have the same error message : 

1239573743_Screenshot2021-06-17at20_48_50.thumb.png.d8aa495cb726f0a136eea327f423be9f.png

 

Does anyone know how to fix this ? 

Thank you ! 

Pete

Link to comment
On 6/17/2021 at 8:50 PM, Pete Bastille said:

Hello,
Thank you so much for this workflow, it's a game changer for me ! 

I currently can't make it work though. I followed the information I found in this thread but I still have the same error message : 

1239573743_Screenshot2021-06-17at20_48_50.thumb.png.d8aa495cb726f0a136eea327f423be9f.png

 

Does anyone know how to fix this ? 

Thank you ! 

Pete

I think you didn't put the right token on the variables 

Link to comment
On 6/17/2021 at 8:50 PM, Pete Bastille said:

Hello,
Thank you so much for this workflow, it's a game changer for me ! 

I currently can't make it work though. I followed the information I found in this thread but I still have the same error message : 

1239573743_Screenshot2021-06-17at20_48_50.thumb.png.d8aa495cb726f0a136eea327f423be9f.png

 

Does anyone know how to fix this ? 

Thank you ! 

Pete

 

Thank you for looking into this. 

 

Can you tell me how you find de two variables please ? Maybe I didn't do the correct manipulation. 

Thanks !
 

Link to comment

Hi Paulo,

 

This seemed like just what I was looking for, but the NPM package doesn't exist, and the workflow bundle doesn't work (env vars are correct, and it reports 'Entry added to Inbox' but no new content is added to the relevant DB.

 

Have you pulled this to work on it?

 

TIA!

Link to comment
  • 2 months later...
  • 2 weeks later...

@itsdustme or anyone else that needs help... I just got this running as follows (m1 mac air)

 

  1. installed flow via download from github
  2. installed npm:`brew install npm`
  3. ran this in the flow directory (as mentioned above): `npm install`
  4. retrieved api key and DB id from notion.so as required and added them to the flow vars
  5. this was the part  that hung me up for a while... you have to specifically share the DB with the api integration you just created. as so: https://developers.notion.com/docs/getting-started#step-2-share-a-database-with-your-integration

Once I did step 5 everything worked :)))))

good luck, and thanks to the creator of this workflow!!  @Paulo

Edited by alf
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...