Jump to content

Parallels Client

Recommended Posts

Hi. Anyone managed to have a workflow to run a connection? Searched but couldn't find any.


Basically only have 1 application within Parallels Client and looking for Alfred workflow to open and run this app. Tried to launch Apps (Parallels Client), delay (tried with and without, different seconds) then launch app but doesn't work.

Link to comment
Posted (edited)

There's couple ways to do it.


Easy one: 

1. Rclick your app in the Parallels Client > Create shortcut on desktop.

2. You might need to set up your shortcuts folder to do this - see second screenshot (you can put them somewhere else, if you prefer not to clutter your desktop).

3. Set Alfred hotkey to launch the shortcut - that will start the connection and launch your app when you hotkey.


Harder way would require adding a bash script/terminal command step to run after launching the Client. Can't tell you off the top of my head how to do it, but can try to look into that too.

Screenshot 2021-06-06 at 06.10.57.png

Screenshot 2021-06-06 at 06.12.05.png

Screenshot 2021-06-06 at 06.14.36.png

Edited by NikG
Link to comment

@NikG, that's what I did in my workflow above. I'm actually calling the shortcut when mentioned launch "app". I tried directly launching the app via shortcut (similar to your suggestion) which didn't work, and also tried to first launch parallels client before launching app shortcut which also didn't work. I've tried workflow with other non parallels client app and it work.


Does your workflow work on your parallels client? 


Everything works if I just double click on parallels client shortcut on finder but somehow won't work via Alfred. Gave up and stick to double clicking app shortcut on desktop. 

Link to comment

Yup, it works just fine for me. One thing that comes to mind - do you have the "save password" ticked in the client connection? Otherwise it would probably launch the client and prompt you for password. 

Link to comment

@iApple Yep, won't work without password saved.


Here's how it's set up on my end. So from a state where client is not even launched - "ctrl+a" will launch the client, log me into connection and launch the app.



Screenshot 2021-06-06 at 14.06.12.png

Link to comment

@NikG @deanishe, mine's setup like NikG's screenshot above but didn't work. Strange that when typed app shortcut on Alfred and it didn't show up.  As if Alfred can't see the file. Don't worry, will stick to double clicking file on finder to launch. Strange issue.

Link to comment
Posted (edited)
35 minutes ago, iApple said:

Strange that when typed app shortcut on Alfred and it didn't show up.


Is it actually an application? From the screenshot, it looks to have the file extension .2xshortcut, not .app?


If it is an app, make sure the directory it's in is in Alfred's search scope, and perhaps type "reload" into Alfred and select "Reload Alfred Cache". That tells Alfred to update its list of applications on your system.


If it isn't an app, you'll need to tell Alfred to also find that filetype (Alfred Preferences > Features > Default Results > Extras > Advanced…), and make sure the directory it's in is in Alfred search scope.

Edited by deanishe
Link to comment

Hi. It's a shortcut and directory is in advanced.


Attached is what I've also tried also didn't work; tried few more variations including open in Parallels and without "open in", etc. Parallels Clients is launched but not subsequent shortcut. Only works if I click on shortcut on desktop. Will stick to launching is via clicking icons - extra steps but at least that works.


Link to comment
5 hours ago, iApple said:

directory is in advanced


The directory doesn't go in there, the filetype does.


If double-clicking in Finder is the only thing that works, perhaps telling Alfred to open the files with Finder would also work?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...