Jump to content

Another Nest thermostat workflow


Recommended Posts

  • Replies 88
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

"jason0x43" is my company name in my Nest developer profile, and the message you posted is just saying "<company> would like to do the following:". It's a bit misleading since it's really the wo

This still seems to not work.  I type in "nest status" and hit enter and the message "communicating with nest" comes up and then it will switch to the default "Search with google".  I downloaded the latest from the link on the first page.

 

I don't have alleeyoop installed and can't even find a version to download so not sure if when you said "published" you meant there or on the main page.  

Link to post

This still seems to not work.  I type in "nest status" and hit enter and the message "communicating with nest" comes up and then it will switch to the default "Search with google".  I downloaded the latest from the link on the first page.

 

I don't have alleeyoop installed and can't even find a version to download so not sure if when you said "published" you meant there or on the main page.  

 

The download link is always for the current version, so you should be good as long as you downloaded after Oct 6. (That was the last update; I forgot to update the messages on the first post.)

 

Try the "log" command ("nest log") to open up the debug log. Then run "nest status" and see if an error/exception message shows up in the log. If so, send me the exception and I can try to see what's wrong.

Link to post
  • 3 months later...

Hello, I just installed this workflow a couple of days ago and it worked fine.  Now it does not.  I have deleted it and tried to reinstall.  Deleted the Keychain entry, and a few other things to try to get it to work again.  Is there a way to reset it back to pre-install state to get it working again?

 

Thanks in advance!  I really love this workflow and thank you very much for creating it.

Link to post

Hello, I just installed this workflow a couple of days ago and it worked fine.  Now it does not.  I have deleted it and tried to reinstall.  Deleted the Keychain entry, and a few other things to try to get it to work again.  Is there a way to reset it back to pre-install state to get it working again?

 

Thanks in advance!  I really love this workflow and thank you very much for creating it.

Are you seeing any sort of error message?

Workflow data is stored in two places: configuration is in ~/Library/Application Support/Alfred 2/Workflow Data/jc-nest, and the cache is in ~/Library/Caches/com.runningwithcrayons.Alfred-2/Workflow Data/jc-nest. Clearing out or removing those directories will completely reset the workflow.

Link to post

False alarm. Clearing your session file (basically like logging out) and having the workflow create a new one seems to fix the problem. I just posted an updated version of the workflow with a "clear" command that will clear your session file. The next time you run a command the workflow will log back in to home.nest.com and create a new session file. This should fix the problem you're seeing.

Link to post

Odd. Well, let's try a more extensive reset:

  1. Delete session.json from ~/Library/Caches/com.runningwithcrayons.Alfred-2/Workflow Data/jc-nest (this is what the 'clear' command should be doing)
  2. Delete config.json from ~/Library/Application Support/Alfred 2/Workflow Data/jc-nest
  3. Delete your stored Nest credentials from your keychain -- open Keychain Access and delete the "jc-nest.nest" entry

Once you've deleted everything, try using the workflow again. It should ask you for your Nest login information the first time you try to do anything. After that you should be back to normal.

Link to post
  • 1 month later...

Has 2.2 broken this for anybody else? Here's the error log that pops up when I debug it:

Starting debug for 'Nest'

[ERROR: alfred.workflow.input.scriptfilter] Code 1: Traceback (most recent call last):
  File "<string>", line 2, in <module>
  File "alfred_nest.py", line 32, in __init__
    LOG.debug('nests: %s', self.account.nests)
  File "nest.py", line 251, in nests
    for struct in self.structures.values():
  File "nest.py", line 240, in structures
    self.status['user'][self.user_id]['structures'])
  File "nest.py", line 231, in status
    r = self.request('GET', 'mobile/user.{}'.format(self.user_id))
  File "nest.py", line 334, in request
    r = self._requestor.get(url)
  File "requests/sessions.py", line 347, in get
    return self.request('GET', url, **kwargs)
  File "requests/sessions.py", line 335, in request
    resp = self.send(prep, **send_kwargs)
  File "requests/sessions.py", line 438, in send
    r = adapter.send(request, **kwargs)
  File "requests/adapters.py", line 331, in send
    raise SSLError(e)
requests.exceptions.SSLError: [Errno 8] _ssl.c:504: EOF occurred in violation of protocol

Any thoughts?

Link to post

Hi Jason, thanks for this plugin!

 

I'm also having the same problem, and it is because Nest has changed their site to require SSL TLSv1 now. This is breaking other apps that scrape their website. I wish they'd just release their damn 3rd party API.

 

So if you look into using TLSv1 it should start working again.

 

Pulled from another forum for example;

# will fail
openssl s_client -connect transport03-rts03-iad01.transport.home.nest.com:443

# will succeed
openssl s_client -connect transport03-rts03-iad01.transport.home.nest.com:443 -tls1

Link to post
  • 7 months later...

I just bought a second Nest as I'm in the process of moving to a place with two zones.

 

Will this workflow work with two different Nests on the same account? Or will I have to duplicate the workflow and change the triggers to nest-2 or something to have it talk to the second unit?

Link to post
  • 2 weeks later...

I just bought a second Nest as I'm in the process of moving to a place with two zones.

 

Will this workflow work with two different Nests on the same account? Or will I have to duplicate the workflow and change the triggers to nest-2 or something to have it talk to the second unit?

 

At the moment, you'll need to duplicate the workflow. You can choose between Nests to control, but the workflow can only control one at a time.

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...