Jump to content

Files not indexed because of very similar filenames?

Recommended Posts



I'm using Alfred 4.3.4 [1229] on macOS 10.14.6.


I believe I've found an indexing bug, let me walk you through how I identified it.

(I can reproduce it every time)


I was trying to find a file (by using "in <word in my file>"), but Alfred didn't find it.

After spending quite some time using other tools to find back my file (let's say it's in the ~/Documents/Notes folder), I was puzzled as it indeed contained the word I was looking for.

I tried again, with the file opened, to find it using Alfred and "in <word>". Still wasn't working.


I copy and pasted the file on my Desktop. I tried "in <word>" again with Alfred, which did find my file on the Desktop, but not the one in ~/Documents/Notes.


So Alfred can't find a file in ~/Documents/Notes, but it can find it if I put it in ~/Desktop.

I ran the diagnostic tool on the file in ~/Documents/Notes, but it seemed alright: Troubleshooting passed


I deleted the file I copied on my Desktop, and dug a bit more.


My ~/Documents/Notes folder contains 3 files:





The file I was trying to locate, but Alfred couldn't find, was sante.rtf.


If I do "in <word>" in Alfred, with:

- a word that's in Travail.rtf → Alfred finds it

- a word that's in sante.rtf → Alfred can't find it

- a word that's in Santé.rtf → Alfred can't find it


So it seems that sante.rtf and Santé.rtf, both in the same folder, can't be found by Alfred.

My guess is that it is due to the fact that both filenames are very close to each other, which Alfred might not like.





Edited by ggggg
Link to comment

Alfred uses the macOS metadata index for internal file search, so I'd be interested in knowing what Spotlight's behaviour is for you. Does Spotlight find the files by content in these scenarios?

Link to comment

@ggggg I know that Big Sur is having issues indexing RTF files, but you're using 10.14:




Could you please try the same test with plain text (.txt) files.


Again, Alfred isn't in control of these file results, so if we can identify the underlying issue on your Mac, it should give us a solution. Also, next time, could you post the full output of Alfred's troubleshooting, as this can also give additional context which can help identify issues.




Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...