Jump to content

File Search issue in MacOS Monterey 12.1 after clean install


Koen_73

Recommended Posts

Hi,

 

I am having search issues on my new Macbook Pro 14 inch (Apple M1 Pro) with 4TB running macOS Monterey version 12.1

 

I read on this forum that the issues could have been caused by the use of the Migration Assistant.

I did use the Migration Assistant, but one of the folders that gives me search issues was not migrated from my old laptop; I copied it from an external drive to the my user folder on my new laptop. Isn't it weird that this still causes issues?

 

I follow the steps as described by @Vero here:

Quote

ven if you believe you've already reindexed, please follow the steps below specifically (as it involves deleting a cache first and ensuring Terminal has suitable permissions).

  • First, please pop open System Preferences > Security & Privacy > Privacy > Full Disk Access and add Terminal
  • Once you've done this, go to Alfred's Advanced preferences, choose "Rebuild macOS Metadata"
  • Ensure that you check "Delete .Spotlight-V100 before reindex"
  • Follow the steps in Terminal, and keep a close eye for any error messages relating to your index.

 

These steps helped resolving the issue, but _without knowing why_ the issue spontaneously returned within the same or next day. 

 

For that reason, I backed up my data and did a clean install of my new laptop via 'Erase all contents and settings' (yesterday). Then copied my data to my users folder and was very happy to experience no search issues whatsoever! 

 

Until... just now... again,  _without knowing why_ the issue spontaneously returned!!

 

I redid the steps described by @Vero above, but without any effect.

 

Spotlight is able to find the files or folders I am looking for. Alfred is not. 

 

Via File Search Troubleshooting (when I drop my user folder for analysis) I do find 1 warning: File isn't within Alfred's default search scope. I find this very weird, because the folder is listed in my Search Scope (see screenshot).

 

Any help is appreciated!!!

 

 

search issue 2.jpg

Edited by Koen_73
Link to comment

Update: I went to System Preferences > Spotlight > Privacy tab and the added my user folder to the list of locations Spotlight should prevent from searching and then removed it from that list again. I noticed in Spotlight that indexing started again.

 

After indexing Alfred does not appear to have any search issues anymore! 

 

I repeated analysis via File Search Troubleshooting (dropping some folders from my user folder for analysis) no warning is found anymore!

 

Happy for now, but will update this thread when the issue again,  _without knowing why_ will spontaneously return!

Link to comment

Ok, I am going slightly mad... just seconds after my previous post... search issue returned...

 

I have a folder 'Mijn bibliotheek' in my user folder with over 2600 folders in it, see diagnostics below. Spotlight has no trouble searching it. But again,  _without knowing why_ the issue in Alfred spontaneously returned, just seconds after it worked...

 

Any help is appreciated!!

 

 

Starting Diagnostics...

File: 'Mijn bibliotheek'
Path: '/Users/koenbunders'

-----------------------------------------------------------

Check file cache database...

File cache integrity is ok

-----------------------------------------------------------

Check if file is readable...

Alfred has permissions to read this file.

-----------------------------------------------------------

Check if volume '/' is indexed by macOS...

Indexing is enabled on this drive

-----------------------------------------------------------

Check direct file metadata...

Direct metadata available

Display Name: Mijn bibliotheek
 Other Names: 
Content Type: public.folder
   Last Used: 2021-12-29 14:42:49 +0000

-----------------------------------------------------------

Check mdls file metadata...

Metadata contains required items

_kMDItemDisplayNameWithExtensions      = "Mijn bibliotheek"
kMDItemContentCreationDate             = 2021-12-28 15:24:06 +0000
kMDItemContentCreationDate_Ranking     = 2021-12-28 00:00:00 +0000
kMDItemContentModificationDate         = 2021-12-28 15:27:50 +0000
kMDItemContentModificationDate_Ranking = 2021-12-28 00:00:00 +0000
kMDItemContentType                     = "public.folder"
kMDItemContentTypeTree                 = (
    "public.folder",
    "public.directory",
    "public.item"
)
kMDItemDateAdded                       = 2021-12-28 15:24:06 +0000
kMDItemDateAdded_Ranking               = 2021-12-28 00:00:00 +0000
kMDItemDisplayName                     = "Mijn bibliotheek"
kMDItemDocumentIdentifier              = 0
kMDItemFSContentChangeDate             = 2021-12-28 15:27:50 +0000
kMDItemFSCreationDate                  = 2021-12-28 15:24:06 +0000
kMDItemFSCreatorCode                   = ""
kMDItemFSFinderFlags                   = 0
kMDItemFSHasCustomIcon                 = 0
kMDItemFSInvisible                     = 0
kMDItemFSIsExtensionHidden             = 0
kMDItemFSIsStationery                  = 0
kMDItemFSLabel                         = 0
kMDItemFSName                          = "Mijn bibliotheek"
kMDItemFSNodeCount                     = 2624
kMDItemFSOwnerGroupID                  = 20
kMDItemFSOwnerUserID                   = 501
kMDItemFSSize                          = 2624
kMDItemFSTypeCode                      = ""
kMDItemInterestingDate_Ranking         = 2021-12-29 00:00:00 +0000
kMDItemKind                            = "Folder"
kMDItemLastUsedDate                    = 2021-12-29 14:42:49 +0000
kMDItemLastUsedDate_Ranking            = 2021-12-29 00:00:00 +0000
kMDItemUseCount                        = 1
kMDItemUsedDates                       = (
    "2021-12-28 23:00:00 +0000"
)

-----------------------------------------------------------

Check file is in search scope...

File exists within Alfred's default search scope

-----------------------------------------------------------

Troubleshooting passed
 

Link to comment

Update: I placed some new files and folder in 'Mijn bibliotheek' folder and Alfred is able to find them, but still not the rest of the folder (2600+ folders).

 

Any help is appreciated!

Edited by Koen_73
emphasize the issue is not resolved
Link to comment
  • Koen_73 changed the title to File Search issue in MacOS Monterey 12.1 after clean install
2 hours ago, timotpe said:

Was experiencing  the same as Irvine and Koen_73, but received alert to upgrade MacOS to 12.1. That seems to have done the trick-Alfred is now back to normal, phew. 

....hope it lasts...

Thanks @timotpe. I am on MacOS 12.1, isn't that weird.

 

I've changed the subject of this thread to differentiate it from File Search issue in MacOS Monterey after Migration Assistant

Link to comment

@Koen_73 It's not normal for issues like these to come and go within such a short amount of time. Do you use any third-party tools that may be manipulating your index (e.g. Onyx) or some cache cleaning tool?

 

As there's likely underlying macOS issue with the search scope, try the following:

 

- Open Alfred's preferences to Features > Default Results

- untick the two options for macOS Applications Folder and Folders in Home, and remove all the folders from the list

- add in your Macintosh HD (or equivalent, which adds just / to your scope)

 

Your scope should then look like this:

 

unnamed.png

 

Type "reload" into Alfred to clear the cache, then try doing a file search.

 

If you still don't see the results, try prefixing your search with the spacebar, e.g. show Alfred and type:

[spacebar]Mijn

 

Let me know how you get on.

 

Cheers,
Vero

Link to comment

Hi @Vero
Thanks for responding.

I don't use any third-party tools that may be manipulating your index (e.g. Onyx) or some cache cleaning tool.

I followed the steps you described, but no new result: Some folders (that I recently visited or created) are found, others are not.

 

Weird: I am able to find a folder in 'Mijn bibliotheek' called 'David Allen - GTD Weekly Review (audio)' when I type:

[spacebar]Weekly

... but not when using a Simple Folder Search workflow:

b Weekly

 

 

20211231 search issue 1.jpg

20211231 search issue 2.jpg

Edited by Koen_73
Pointing out that I typed 'b<space>weekly'
Link to comment

After another reindexing by the steps described by @Vero, Alfred folder and file search worked for a while.

Today it broke again.

I have the impression it has something to do with external drives getting attached, I'll try to examine further.

Is this a known issue?

Link to comment

The same issue happened to me. I have the MacBook Pro (14-inch, 2021), Apple M1 Pro. Last night my computer updated from 12.0 to 12.1, and by default it decided to store my `Documents` and `Desktop` folder in iCloud, which it had never done before. I never had previous issues with Alfred4 search, but I could no longer find files. Alfred was about to find the folders `Documents` and `Desktop` but it was not able to find any of the contents stored inside the folder. I changed my search option to search root, and things are working, but I thought that I would add this to help debug. Specifically, there is now an issue searching for files located in the home directory.

 

I am just starting to poke around, but I see that my `Documents` and `Desktop` folders appear in `iCloud Drive` in finder, which has a path of `~/Library/Mobile Documents` which is included in the defaults. I will dig around more, but will attach photos to show you what's going on. In terminal the path to my `Desktop` and `Documents` is still `~/Desktop` and `~/Documents` which should be searched. I do not know what apple changed, but they didn't touch any inherent paths, I wonder if some apple scripts that used to run are no longer working... 

Screen Shot 2022-01-02 at 9.13.09 PM.png

query.jpg

query2.jpg

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...