Jump to content

Move To Folders not showing up [Solved by reindexing]


Recommended Posts

So I just had to do a 100% clean install on my Mac, and am pulling my hair out now on an Alfred anomalie. When I bring up Alfred, with files selected, and try to move them to a directory, Alfred is not finding the directory. The directory is located in ~/hazel/target-directory. Prior to the reinstall, it would include the hazel folder and subfolders as part of it's general search as it's under my home directory. I've even added ~/hazel to the list of search targets.


Currently the only way I can get target-directory to show up as the target of a move command is to start at ~/hazel/tar ... and about this point it shows up, but next time, it fails to show again. I'm sure it's a doh! setting that I forgot to set, but I can't for the life of me figure out what it is.  Thoughts?

Link to comment

@learned When choosing the "Move to..." action, to start off with, only a few default folders (Desktop, Documents and a couple of others, off the top of my head :) ). Typing a few characters from the name of the folder you want to move your files to should show more results for the relevant folders.

 

After this first move action, the recently used folders will be listed in the "Move To" list for next time.

 

Or were you saying that when typing "target" in the Move To action, your folder wasn't shown in the results?

Link to comment

the latter. When typing "target" in the move to action it was not showing in the results unless I started with ~ and typed the whole path to it's parent folder (~/hazel/) in which case "target" would show up. 

Link to comment

@learned Could you drag the folders in question into the File Troubleshooter to check they're correctly indexed?

 

https://www.alfredapp.com/help/troubleshooting/indexing/

 

I've created a test folder with the same hierarchy as yours and it's found immediately, so are there any rules or exclusions for the folders in question?

 

What happens if you create a new test folder in your user directory and search for a sub-folder of it?

 

Cheers,
Vero

Link to comment
  • Vero changed the title to Move To Folders not showing up [Solved by reindexing]

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...