Jump to content

Issues with the YouTube suggest workflow


Recommended Posts

Dear all,

 

I'm trying to add a workflow similar to the default Google suggest, but for YouTube. I found this one online, but it doesn't seem to work properly. I tried to toggle the debug mode and the error I get is the following:

[12:55:10.920] ERROR: YouTube Suggest[Script Filter] Code -1: Task '/usr/bin/php' failed with reason 'launch path not accessible'

 

I'm quite new to the powerpack and this is the first time that I encountered this problem, so I don't know how to fix it.

Link to comment

The Alfred 4.6 Released: Ready for macOS Monterey blog post has the answer:

 

Quote

One key difference with macOS Monterey is that PHP is no longer bundled by default.
If you install PHP (e.g. via homebrew), most PHP-based workflows will continue to work without an issue, as the workflow script objects in Alfred 4.6 have been updated to be aware of alternative bin paths. If the workflow developer has hard coded paths within their workflow, you'll need to seek out an updated version on our forum or the creator's site.

 

Essentially:

  1. Open a terminal.
  2. Install Homebrew.
  3. Run brew install php.
Link to comment

Thank you @vitor, that solved the error, but unfortunately the workflow is still giving me troubles. As soon as I start typing it shows the default search google/amazon/wikipedia options. The inline suggestions are not showing. With the debug toggle on I can see the suggestions, but they are not displayed in Alfred. This is the new error I get:

[20:22:59.360] ERROR: YouTube Suggest[Script Filter] JSON error: JSON text did not start with array or object and option to allow fragments not set. around line 1, column 0. in JSON:
Deprecated: SimpleXMLElement::addAttribute(): Passing null to parameter #2 ($value) of type string is deprecated in /Users/dominik/Library/Application Support/Alfred/Alfred.alfredpreferences/workflows/user.workflow.4CD220B7-D0EA-422E-85A9-00C62921C1C2/workflows.php on line 230

 


On a side note, I would also like to say thanks for the Google Drive workflow that you shared with the community. It's easily the main reason why I bought the powerpack.

Edit: I couldn't solve the issue, but while I was looking for a solution I found searchio. It didn't work at first but then I found this post and now everything seems to work fine. Thank you again!

On 10/3/2019 at 4:23 PM, deanishe said:

It doesn't work out of the box, I'm afraid. Enter searchio to view the settings and choose "Reload" (this will delete the non-working searches), then use the "All Engines …" item to add some searches.

Edited by Dominik
Link to comment

Yes, I tried it and now it works just fine... I tried to use Searchio and Youtube Suggest for a little while. It seems that the results are pretty much identical, but searchio offers some additional options (and it's easier/faster to set up) so I'll probably stick to it for now. I appreciate the time you spent helping me. Have a nice day!

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...