Jump to content

"Launch alfred at login" gets re-enabled after every upgrade [Fixed 4.6.6 b1302 pre-release]


mikedee
 Share

Recommended Posts

(Apologies if this is a duplicate, I wasn't able to find anything with a few quick searches)

 

What happens: I don't want Alfred to launch at login, so I leave the option unchecked. However, every time I upgrade Alfred, it re-checks the "Launch Alfred at login" option. This most recently happened while upgrading to version 4.6.4 [1294] (w/ powerpack).

 

Before upgrading:

image.png.9bb722a44f47f68c2f1008a1e56631ca.png

 

After upgrading:

image.png.52e993a35ac4e8c460ae6911039531a9.png

 

 

Expected behavior: this setting should not change, when upgrading the software.

 

OS version: 11.6.4

 

Thanks!

Mike

Link to comment
Share on other sites

@mikedee Welcome to the forum :)

 

Alfred won't re-enable this by himself, but it's possible that something's stopping your newly set preference from saving.

 

If you take a look at the macOS preferences for Users > Login items, is Alfred listed there as launching at startup? You should be able to remove him there.

 

Let know how you get on.

 

Link to comment
Share on other sites

@Vero - yes, Alfred is listed in login items - even though I've removed it repeatedly!image.png.20e956a26ba32f9676c07657b218fff5.png

 

So, I just removed it there, again. Next time there's an Alfred update, I'll check to see what happens ...

Link to comment
Share on other sites

@mikedee Apologies, I've discussed this with @Andrew, who confirmed that Alfred does re-add himself during updates.  This has been Alfred's behaviour for over a decade, hence my incorrect answer, again apologies for the confusion! 

 

It's unusual for anyone to want Alfred installed and to continue doing software updates, but not want it launching automatically, so I've raised it as a point of discussion internally.

Link to comment
Share on other sites

  • 3 weeks later...

Gotcha, thank you. And yeah, I just updated to 4.6.5 and it did indeed re-add itself to my login items.

 

In case it's helpful, here's _why_ I don't want Alfred to start right away:

 

 - I use dropbox to sync my Alfred preferences between several different machines.
 - My dropbox folder is quite large, so I sync it to an external drive.
 - Unfortunately, MacOS doesn't mount external drives until AFTER loading the login items.

 - SO: Alfred tries to launch *before* its preference folder is available.

 

This is obviously not going to be a very common issue :)

Link to comment
Share on other sites

  • Andrew changed the title to "Launch alfred at login" gets re-enabled after every upgrade [Fixed 4.6.6 b1302 pre-release]

@mikedee if you open Terminal and paste the following:

 

defaults write com.runningwithcrayons.Alfred-Preferences skipLoginItemCheck 1

 

Then update to Alfred 4.6.6 b1302 pre-release, Alfred should now skip the check causing Alfred to be re-added.

Link to comment
Share on other sites

  • 3 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...