Jump to content

Foreign/Swedish characters for web search not working after 5.0 update?


Recommended Posts

I have a ton of custom web searches for Swedish (and Polish) websites. For some reason, after the recent Alfred update, when I type in any country specific characters (such as å, ä, ö) as my search term, it returns the UTF-8 equivalents instead (obviously ruining my searches).

 

For example, if i search for the word "häst" ("horse"), on my custom Swedish Wikipedia search, it used to return häst, whereas after the update it returns h%C3%A4st.

 

Is there any way I can stop this from happening? Please help.

 

 

Link to comment

Welcome @Myslnik,

 

Those aren’t UTF-8 representations, they are URL encoded. Indeed %C3%A4 is the correct URL encoding for ä. I can’t reproduce an issue, setting up a Swedish Wikipedia search and searching for characters with diacritics is working fine.


Can you share your Custom Search (edit it and click Copy URL for sharing on the bottom left)? Also, what exact versions of Alfred and macOS are you on?

Link to comment

Thanks for this @vitor. i stand corrected, those are not UTF-8 versions (I guess I was looking at the letter ä and its hex. value in this chart?) You're also right about a custom Swedish Wikipedia search working (I gave it as a random example but tested it just now and Swedish letters did work).

 

But my custom Swedish Google page search does not. Here is the Custom Search url i use for this (it includes a double quotes/exact match) :

alfred://customsearch/Google%20Sverige/s/utf8/+/https://www.google.se/search?q=%22%7Bquery%7D%22&hl=sv&le=sv&btnG=Google+Search&num=20&start=0

 

This url used to work before the update to 5.0. What am I doing wrong?

Link to comment

The quotes themselves are special characters which have to be URL encoded. Instead of ", use %22:

 

alfred://customsearch/Google%20Sverige/s/utf8/+/https://www.google.se/search?q=%2522%7Bquery%7D%2522&hl=sv&le=sv&btnG=Google+Search&num=20&start=0

 

Link to comment
Posted (edited)

Thanks for the tip @vitor! I ended up with this simplified custom search and now it works:

 

alfred://customsearch/Google%20Sverige/s/utf8/+/https://www.google.se/search?q=%2522%7Bquery%7D%2522

 

It's odd though that when validating this search via the Alfred UI (by pressing the "Test" button) it returns the wrong result in Google ("%22häst%22" instead of "häst"). Whereas the opposite happened with the old custom search url (i.e. the validation worked with the Test button but not when using the Alfred search window).

image.thumb.jpeg.9e686cfe94ae68faf9291cbee123051c.jpegimage.thumb.jpeg.7df443c894fc3b8071144291e128b355.jpeg

Edited by Myslnik
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...