Jump to content

Cannot find file in Alfred - troubleshooting passed - it's found in spotlight


Recommended Posts

I set up my new MBA and suddenly cannot find files in my local onedrive folder.

  • The cloudstorage location is added in search scope. 
  • The file can be found in spotlight
  • The troubleshooting guide finds the file and returns green mark
  • When I try this on my older mac with similar setup, the file shows up.

793272731_02finderror.thumb.jpg.ba32514ec3c331416a4c8f77b60cbab0.jpg870870468_01finderror.thumb.jpg.75d2c8337b34274b03d41eaa91ae1700.jpg

What am I possibly missing?

 

thanks!

Link to comment

@maikfrank There are a few more things to check (and I'm having to take guesses as I can't see the metadata for the files - In the future, it would be best to copy the output of the File Search Troubleshooting rather than just provide a screenshot of the end of it, as the metadata itself is very useful)

  • Did you migrate your data to macOS Monterey from another Mac or a Time Machine backup? If so, take a look at the Monterey indexing page as there's a bug in the Monterey Migration Assistant that could cause this behaviour.
  • Could you try moving a file or two to your user directory in macOS instead of OneDrive to see if files are found then? This will help establish whether the issue is specific to files stored in OneDrive.

Let me know how you get on :)

 

Cheers,
Vero

Link to comment

Hi Vero! Great to hear from you..

 

I have copied the full output below.

To your questions: 

 

Yes, I migrated from and M1 to a M2 machine.

I followed the troubleshooting guide and widened the search scope is mentioned int the article. I can find the file!

Then I reset the search scope, and then file can't be found.

 

I then copied the file to my user directory (default downloads folder) and it still cannot be found. Troubleshooting checks out fine there, too. 

I did notice that it has a unique file type (itmz) and I added it to the search file types. Still cannot be found.

 

This is so strange, as It works fine with my intel mac that has virtually the same setup.

 

What else could i try? Thanks!

 

 

Starting Diagnostics...

File: '00 main mindmap sdfg.itmz'
Path: '/Users/maik/Library/CloudStorage/OneDrive-Intellicoach/00 Mindmaps'

-----------------------------------------------------------

Check file cache database...

File cache integrity is ok

-----------------------------------------------------------

Check if file is readable...

Alfred has permissions to read this file.

-----------------------------------------------------------

Check if volume '/' is indexed by macOS...

Indexing is enabled on this drive

-----------------------------------------------------------

Check direct file metadata...

Direct metadata available

Display Name: 00 main mindmap sdfg.itmz
 Other Names: 
Content Type: com.toketaware.uti.ithoughts.itmz
   Last Used: 

-----------------------------------------------------------

Check mdls file metadata...

Metadata contains required items

_kMDItemDisplayNameWithExtensions      = "00 main mindmap sdfg.itmz"
kMDItemContentCreationDate             = 2022-08-05 08:58:48 +0000
kMDItemContentCreationDate_Ranking     = 2022-08-05 00:00:00 +0000
kMDItemContentModificationDate         = 2022-08-05 08:47:01 +0000
kMDItemContentModificationDate_Ranking = 2022-08-05 00:00:00 +0000
kMDItemContentType                     = "com.toketaware.uti.ithoughts.itmz"
kMDItemContentTypeTree                 = (
    "com.toketaware.uti.ithoughts.itmz",
    "public.data",
    "public.item",
    "public.composite-content",
    "public.content"
)
kMDItemDateAdded                       = 2022-08-05 08:58:48 +0000
kMDItemDateAdded_Ranking               = 2022-08-05 00:00:00 +0000
kMDItemDisplayName                     = "00 main mindmap sdfg.itmz"
kMDItemDocumentIdentifier              = 64158
kMDItemFileItemID                      = "__fp/T25lRHJpdmUgLSBJbnRlbGxpY29hY2g=/__fp/fs/docID(64158)"
kMDItemFilename                        = "00 main mindmap sdfg.itmz"
kMDItemFileProviderID                  = "com.microsoft.OneDrive.FileProvider"
kMDItemFSContentChangeDate             = 2022-08-05 08:47:01 +0000
kMDItemFSCreationDate                  = 2022-08-05 08:58:48 +0000
kMDItemFSCreatorCode                   = (null)
kMDItemFSFinderFlags                   = 0
kMDItemFSHasCustomIcon                 = (null)
kMDItemFSInvisible                     = 0
kMDItemFSIsExtensionHidden             = 0
kMDItemFSIsStationery                  = (null)
kMDItemFSLabel                         = 0
kMDItemFSName                          = "00 main mindmap sdfg.itmz"
kMDItemFSNodeCount                     = (null)
kMDItemFSOwnerGroupID                  = 20
kMDItemFSOwnerUserID                   = 501
kMDItemFSSize                          = 157535905
kMDItemFSTypeCode                      = (null)
kMDItemInterestingDate_Ranking         = 2022-08-05 00:00:00 +0000
kMDItemIsDownloading                   = 0
kMDItemIsShared                        = 0
kMDItemIsUploaded                      = 1
kMDItemIsUploading                     = 0
kMDItemKind                            = "iThoughts Document"
kMDItemLogicalSize                     = 157535905
kMDItemPhysicalSize                    = 157536256
kMDItemUserOwned                       = 0

-----------------------------------------------------------

Check file is in search scope...

File exists within Alfred's default search scope

-----------------------------------------------------------

Troubleshooting passed
 

Link to comment
21 hours ago, maikfrank said:

Yes, I migrated from and M1 to a M2 machine.

I followed the troubleshooting guide and widened the search scope is mentioned int the article. I can find the file!

Then I reset the search scope, and then file can't be found.

 

@maikfrank You'll need to keep the wide search scope, as this is a workaround for a flaw in the macOS Monterey Migration Assistant. Resetting the search scope puts you back to square one.

 

Unfortunately, this isn't something we have control over as it's an Apple issue. Other ways of bypassing the issue include setting up a new user profile or setting up your Mac without using Migration Assistant. Hopefully this issue won't carry through to macOS Ventura, which is currently in beta.

 

Hope this helps :)

 

Link to comment

Hi Vero – I had the same problem and solved it by widening the search scope. If this does get solved in Ventura it would be nice to get a reminder (in-app or via email?) to change back to narrower scope (I guess). Cheers

Link to comment
  • 1 month later...

 

When I drag the home folder in (in addition to all the other scopes) that are already present, Alfred is able to find the files in ~/Library/CloudStorage. So at least we don't have to widen the scope all the way to "/"

Edited by afzalive
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...