Jump to content

Buffer icons upside down in certain situations [Fixed v.2.0.4 pre-release]


rafegoldberg
 Share

Recommended Posts

So I haven't experienced this before and I've been using the latest version of Alfred 2, but when I changed my theme this morning and then added some applications to Alfred's buffer, the icons were all upside down. This doesn't happen when adding icons from Alfred's file browser, and they get reset (so that they're upside up) if you toggle Alfred's visibility a couple of times. Not a big deal at all, but I'm miffed!

 

upsidedown_buffer.png

Link to comment
Share on other sites

So I haven't experienced this before and I've been using the latest version of Alfred 2, but when I changed my theme this morning and then added some applications to Alfred's buffer, the icons were all upside down. This doesn't happen when adding icons from Alfred's file browser, and they get reset (so that they're upside up) if you toggle Alfred's visibility a couple of times. Not a big deal at all, but I'm miffed!

 

Hi Rafe,

 

We've only come across this with one user before and his issue was fixed with one of the early v2 beta builds. As such, I'd love to get some more information from you, which might help us identify what could cause this in this instance:

 

- Are you using the latest version 2.0.2?

- What are your Mac's specs, including graphics card (from the About This Mac menu)

- Do you have any third-party background apps that may have an impact on graphics?

- If you create a second profile on your Mac, do you see the same behaviour?

 

Any other information you might think is relevant would be helpful :)

 

Thanks in advance,

Vero

Link to comment
Share on other sites

Hey Vera. To answer your questions: 

 

— I was using 2.0.2 as of an hour ago; I am using 2.0.3 since it was released today. 

— I'm running OS X 10.8.3 with a 2.5GHz processor, 4GB of memoryand Intel HD Graphics 3000 (384 MB)

— The only third party software I can think of that might impact/interact with graphics is TotalSpaces

 

Beyond that:

 

— I hadn't run into this issue until I made certain changes to Alfred's theme. Among these

• I remember adjusting the opacity and color of the border and the background.

 I also changed the border radius of Alfred from none to something higher right before this issue popped up.

— I'm not quite sure, but it seemed the issue only occurred when adding applications to the buffer.

— When adding items from Alfred's file browser I did not experience the same bug. (I remember testing a few PDFs from the file browser and everything worked okay.) 

— Some combination of toggling Alfred's visibility, adding files to the buffer from the file browser, and removing a file or two from the buffer would eventually reorient the icons.

— Also of note, I haven't run into this issue again since that day!

 

Thanks for getting in touch. Let me know if you figure out what was causing it; I'm kind of intrigued.

 

Hi Rafe,

 

We've only come across this with one user before and his issue was fixed with one of the early v2 beta builds. As such, I'd love to get some more information from you, which might help us identify what could cause this in this instance:

 

- Are you using the latest version 2.0.2?

- What are your Mac's specs, including graphics card (from the About This Mac menu)

- Do you have any third-party background apps that may have an impact on graphics?

- If you create a second profile on your Mac, do you see the same behaviour?

 

Any other information you might think is relevant would be helpful :)

 

Thanks in advance,

Vero

Link to comment
Share on other sites

I have this issue too. I think it might be related to the result padding.

 

If I duplicate the default theme (Light), and increase the result padding by 1, it shows the upside down icons in the file buffer (I've only seen it happen with applications and folders). If I change the result padding to anything else, the icons are fine.

Link to comment
Share on other sites

I have this issue too. I think it might be related to the result padding.

 

If I duplicate the default theme (Light), and increase the result padding by 1, it shows the upside down icons in the file buffer (I've only seen it happen with applications and folders). If I change the result padding to anything else, the icons are fine.

 

Whoa, nicely spotted! That's the first time I've been able to reproduce this issue! I should be able to fix this now (looks like I'll need to work around an OS X bug). Thanks! :)

 

Andrew

Link to comment
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...