Jump to content

Alfred refuses to see Adobe applications


Junebug

Recommended Posts

With a default config, Alfred 5 on anything more recent than Big Sur cannot find any applications which are not at the root level of /Applications, like every single Adobe app known to humanity. I have rebuilt my Spotlight indices and cleared Alfred's caches dozens upon dozens of times. When I run the "Troubleshooting" process Alfred informs me that *it* can find the app just fine, but Spotlight can't. This is plainly nonsense and whatever method "Troubleshooting" is using to make this determination seems to be flawed. 

 

If I tell Alfred to index the entire disk then it can magically find Adobe apps, but it also insists on including iOS simulator apps I can't actually run in my search results. I have excluded all of these folders from Spotlight via its "Privacy" settings yet somehow Alfred ignores *these* restrictions and continues finding them without Spotlight's help. Funny how it can't find a thing that Spotlight can, but can also find things Spotlight can't. 

 

All of this worked perfectly on Big Sur. Monterey and Ventura appear to be completely destroyed and it's intensely irritating that this basic functionality--indeed, the only functionality I care about as I don't want Alfred searching the web or looking words up in the dictionary or any of the other party tricks it performs--is this awful. 

 

Any suggestions other than "hold your breath and hope they catch up with the OS at some point in the next five years?"

alfredisbroken.jpg

Link to comment

@Junebug Welcome to the forum. 

 

First, to remove the apps you've dragged to Spotlight Privacy from Alfred, type "reload" to refresh the application cache.

 

Next, could you provide more tangible information:

  • Which version of Alfred you're using (please don't say latest, you can see the version number you're using in the Update tab)
  • Which version of macOS you're using exactly
  • Please paste the output of a few files you've dragged into the File Troubleshooter (copy and paste the output into your reply)

With this information, we should be able to help you further.

Link to comment

Seriously broken. 

 

% mdls /System/Applications/Utilities/Terminal.app                                                                                       (:)
_kMDItemDisplayNameWithExtensions  = "Terminal.app"
kMDItemAlternateNames              = (
    "Terminal.app"
)
kMDItemAppStoreCategory            = "Utilities"
kMDItemAppStoreCategoryType        = "public.app-category.utilities"
kMDItemAppStoreIsAppleSigned       = 1
kMDItemCFBundleIdentifier          = "com.apple.Terminal"
kMDItemContentCreationDate         = 2022-11-11 06:39:05 +0000
kMDItemContentCreationDate_Ranking = 2022-11-11 00:00:00 +0000
kMDItemContentModificationDate     = 2022-10-28 08:43:33 +0000
kMDItemContentType                 = "com.apple.application-bundle"
kMDItemContentTypeTree             = (
    "com.apple.application-bundle",
    "com.apple.application",
    "public.executable",
    "com.apple.localizable-name-bundle",
    "com.apple.bundle",
    "public.directory",
    "public.item",
    "com.apple.package"
)
kMDItemCopyright                   = "© 1991–2022 Apple Inc. All rights reserved."
kMDItemDateAdded                   = 2022-10-28 08:43:33 +0000
kMDItemDisplayName                 = "Terminal.app"
kMDItemDocumentIdentifier          = 0
kMDItemExecutableArchitectures     = (
    arm64,
    "x86_64"
)
kMDItemFSContentChangeDate         = 2022-10-28 08:43:33 +0000
kMDItemFSCreationDate              = 2022-10-28 08:43:33 +0000
kMDItemFSCreatorCode               = ""
kMDItemFSFinderFlags               = 0
kMDItemFSHasCustomIcon             = 0
kMDItemFSInvisible                 = 0
kMDItemFSIsExtensionHidden         = 0
kMDItemFSIsStationery              = 0
kMDItemFSLabel                     = 0
kMDItemFSName                      = "Terminal.app"
kMDItemFSNodeCount                 = 1
kMDItemFSOwnerGroupID              = 0
kMDItemFSOwnerUserID               = 0
kMDItemFSSize                      = 1
kMDItemFSTypeCode                  = ""
kMDItemInterestingDate_Ranking     = 2022-10-28 00:00:00 +0000
kMDItemKeywords                    = "ᄐᄆᄂ,ㅌㅁㄴ"
kMDItemKind                        = "Application"
kMDItemLogicalSize                 = 6927151
kMDItemPhysicalSize                = 3403776
kMDItemVersion                     = "2.13"

 

alfredisnowgarbage.jpg

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...