Jump to content

Weather workflow


Recommended Posts

I keep getting an error trying to run this workflow. I'm using a ClimaCell API and as far as the log goes everything works until the last minute:

 

[alfred] 2021/01/07 18:57:42 loaded cache
[alfred] 2021/01/07 18:57:42 Error: 403 Forbidden

 

I'm assuming this is an issue with ClimaCell - as it hasn't worked for three separate locations.

 

Has anyone else experienced problems with ClimaCell APIs?

Screen Shot 2021-01-07 at 7.15.06 PM.jpg

Screen Shot 2021-01-07 at 7.15.14 PM.jpg

Link to post
  • Replies 107
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I wrote a weather forecaster workflow that displays forecasts from Dark Sky or the Weather Underground. This is actually the second iteration; my first was loosely based on David Ferguson's weather wo

Yay, I finally got the update out the door. See https://github.com/jason0x43/alfred-weather.

The current version of the workflow didn't have support for apparent ("feels like") temperatures; I've added that to version 1.3.0.   Regarding the discrepancy between hourly and daily forec

Posted Images

I tested the workflow with ClimaCell this weekend, and I couldn't reproduce any issues (which doesn't mean there isn't a problem, just that it didn't show up for me).

 

One thing to do is run `wtr options` and verify that your ClimaCell key matches what's in your account at developer.climacell.co.

Link to post

@jason0x43 Is there a way to always show the temperatures like on the first image?

Because, I have to highlight each element to show weather status, temperature and so on.

It'd be a huge improvement.

And you could set it as an option inside the workflow, so that you can enable/disable it as long as you want.

Thank you for your hard work and it's a pleasure to use such useful workflows from the entire community.

Link to post

@pulgalipe Do you mean that the temperature, etc. values aren't visible until you highlight a particular item? If that's the case, it could mean that your color scheme is misconfigured (specifically, the "result subtext" color might be the same as the default background color).

Link to post
1 hour ago, jason0x43 said:

@pulgalipe Do you mean that the temperature, etc. values aren't visible until you highlight a particular item? If that's the case, it could mean that your color scheme is misconfigured (specifically, the "result subtext" color might be the same as the default background color).

I just did a clean installation of Big Sur.

And it does happens on my other Mac's as well.

I'm currently on latest Alfred and it does happens on each and every installation of mine.

Here's an Imgur album with some screenshots of a bunch of different themes: https://imgur.com/a/8PmuchM

And it does reports the information the same way in each of them, which is kinda odd.

 

EDIT: After some investigation I just found a hidden setting on my Alfred:
Appearance > Options > Show result subtext

Mine was set to "Only for Selected Result" instead of "Always".

After set it up it's working flawlessly.

Thank you!

Never though that was something messed up on my configuration.

But now it's working fine.

👍

Edited by pulgalipe
Link to post
On 1/12/2021 at 10:11 AM, jason0x43 said:

 

Interesting, I hadn't seen that setting before. You learn something new every day! 😄

Me either.

The good thing is that now everything's working fine!

Thanks for your good work and support, dude!

😊

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...