Jump to content

DownMedia — Download media from popular sources


Recommended Posts

Because I’m distributing the Workflow for free at the expense of my time and keep getting requests for help with no actionable information, I’m making this post so I can link to it.


If you have an issue with this Workflow, I need from you:

  • The terminal output from the command (paste it exactly; it’s a single line): brew upgrade youtube-dl || youtube-dl --update || "${HOME}/Library/Application Support/Alfred/Workflow Data/com.vitorgalvao.alfred._sharedresources/bin/youtube-dl" --update.
  • The Workflow version you’re on.
  • The Alfred version you’re on.
  • The macOS version you’re on.
  • At least one link that is failing.
  • The debugger output, set to All Information.

Requests for help that I can’t reproduce and fail to provide the requested information will not receive a follow up. Reports that do provide the required information are welcome and will be looked at as soon as possible. I thank in advance to those that make good bug reports.

Link to post
  • Replies 358
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Download media from a plethora of sources, even when embedded in other pages. The main commands are dv to download video and da to download audio (often extracted from a video source). Bot

Update. Added support to download audio. It also works with downloading a full playlist as audio, but it does not include and option to add to WatchList automatically due to a limitation in yo

It by default downloads the best quality version available, so it will download different formats for different videos.   That said, yes, it’s very easy to do what you want. On the workflow, double‐

Posted Images

3 hours ago, vitor said:

Because I’m distributing the Workflow for free at the expense of my time and keep getting requests for help with no actionable information, I’m making this post so I can link to it.


If you have an issue with this Workflow, I need from you:

  • The terminal output from the command (paste it exactly; it’s a single line): brew upgrade youtube-dl || youtube-dl --update || "${HOME}/Library/Application Support/Alfred/Workflow Data/com.vitorgalvao.alfred._sharedresources/bin/youtube-dl" --update.
  • The Workflow version you’re on.
  • The Alfred version you’re on.
  • The macOS version you’re on.
  • At least one link that is failing.
  • The debugger output, set to All Information.

Requests for help that I can’t reproduce and fail to provide the requested information will not receive a follow up. Reports that do provide the required information are welcome and will be looked at as soon as possible. I thank in advance to those that make good bug reports.

@vitor Thank you so much for this, and all of your help over the years. I will endeavor to follow your instructions!

Link to post

Hi Vitor,  

My apologies for the lack of details in my post below. 

There it is:  


Terminal outputyoutube-dl is up-to-date (2020.01.24)

Workflow Version: DownMedia v 2020.1
Alfred Version:  4.0.8

macOs: Mojave 10.14.6 (on Macbook Pro 15" 2018)
Failing link: https://youtu.be/fKrrRqkbYrI
Debugger output: [17:34:24.510] Logging Started...     (It stays like that, with no further output... )

Many thanks in advance, and even more so, in retrospect for all your work :-)  
Regards
Marc
 

Link to post
  • 2 weeks later...
On 2/7/2020 at 8:46 AM, vitor said:

Because I’m distributing the Workflow for free at the expense of my time and keep getting requests for help with no actionable information, I’m making this post so I can link to it.


If you have an issue with this Workflow, I need from you:

  • The terminal output from the command (paste it exactly; it’s a single line): brew upgrade youtube-dl || youtube-dl --update || "${HOME}/Library/Application Support/Alfred/Workflow Data/com.vitorgalvao.alfred._sharedresources/bin/youtube-dl" --update.
  • The Workflow version you’re on.
  • The Alfred version you’re on.
  • The macOS version you’re on.
  • At least one link that is failing.
  • The debugger output, set to All Information.

Requests for help that I can’t reproduce and fail to provide the requested information will not receive a follow up. Reports that do provide the required information are welcome and will be looked at as soon as possible. I thank in advance to those that make good bug reports.

 

still getting opuss

Warning: youtube-dl 2020.02.16 already installed

vs 2020.3

alfred vs 4.0.8

catelina

https://www.youtube.com/watch?v=mhsOy_jYcrM

 

[20:29:18.218] Logging Started...
[20:29:28.003] DownMedia[Script Filter] Queuing argument ''
[20:29:28.610] DownMedia[Script Filter] Script with argv '' finished
[20:29:28.613] STDERR: DownMedia[Script Filter] /Users/bangtan/Library/Application Support/Alfred/Alfred.alfredpreferences/workflows/user.workflow.D22AE455-36AE-4E49-B963-8418ADB01C04/get_title_and_url.js:657:728: execution error: Error on line 12: Error: You need a supported browser as your frontmost app (-2700)
[20:29:28.614] DownMedia[Script Filter] {"items":[{"subtitle":"Add to WatchList (⌥): true 𐄁 Full Playlist (⌘): false","valid":true,"variables":{"media_type":"audio","add_to_watchlist":true,"full_playlist":false},"mods":{"cmd":{"subtitle":"Add to WatchList (⌥): true 𐄁 Full Playlist (⌘): true","variables":{"media_type":"audio","Add_to_watchlist":true,"full_playlist":true}},"alt":{"subtitle":"Add to WatchList (⌥): false 𐄁 Full Playlist (⌘): false","variables":{"media_type":"audio","add_to_watchlist":false,"full_playlist":false}},"cmd+alt":{"subtitle":"Add to WatchList (⌥): false 𐄁 Full Playlist (⌘): true","variables":{"media_type":"audio","add_to_watchlist":false,"full_playlist":true}}},"title":"https://youtu.be/rJ_L2YayTdk","arg":"https://youtu.be/rJ_L2YayTdk"}]}
[20:29:32.456] DownMedia[Script Filter] Processing complete
[20:29:32.464] DownMedia[Script Filter] Passing output 'https://youtu.be/rJ_L2YayTdk' to Run Script
[20:29:45.270] STDERR: DownMedia[Run Script] xattr: No such file: /Users/bangtan/Desktop/Nell - Christmas in Nell's Room 2018 (Remastered) - 03 Boy X.webm
55:242: execution error: Alfred 4 got an error: Cannot find workflow with Id 'com.vitorgalvao.alfred.watchlist' (-2)
You do not have WatchList installed. Download it at https://github.com/vitorgalvao/alfred-workflows/tree/master/WatchList
[20:29:45.287] DownMedia[Run Script] Processing complete
[20:29:45.289] DownMedia[Run Script] Passing output '' to Run Script

 

Edited by eluxmaxel
Link to post
  • 2 weeks later...
2 hours ago, eluxmaxel said:

isn't the youtube-dl suppose to be in there that's why it wont update?

 

The workflow uses your existing copy of youtube-dl if you already have it installed, so not having a copy there doesn't necessarily mean something's wrong.

 

It even says in the log you posted "youtube-dl 2020.02.16 already installed".

 

Try running the update command that Vítor posted above. And be careful to run the whole command.

Link to post
13 hours ago, deanishe said:

 

The workflow uses your existing copy of youtube-dl if you already have it installed, so not having a copy there doesn't necessarily mean something's wrong.

 

It even says in the log you posted "youtube-dl 2020.02.16 already installed".

 

Try running the update command that Vítor posted above. And be careful to run the whole command.

i did and i got

image.thumb.png.2e56cb6a4d800a6807f675980b45755d.png

  and i updated the youtube-dl through brew image.thumb.png.ad406243c27ab0dba17f3c301fd1b481.png

Link to post
45 minutes ago, eluxmaxel said:

i did and i got

 

No, you didn't. You copied only the second half of the command. And the second time you copied an invalid part of the command. In fact, you did exactly the same thing as roccitman did on the previous page, and I explained exactly what he'd done wrong.

 

You might have fixed your issue with the Homebrew update (which was included in the full command you were supposed to run).

 

If not, please go back and read and follow Vítor's instructions carefully.

Link to post
7 minutes ago, deanishe said:

 

No, you didn't. You copied only the second half of the command. And the second time you copied an invalid part of the command. In fact, you did exactly the same thing as roccitman did on the previous page, and I explained exactly what he'd done wrong.

 

You might have fixed your issue with the Homebrew update (which was included in the full command you were supposed to run).

 

If not, please go back and read and follow Vítor's instructions carefully.

image.thumb.png.21a1ff346e973b76344c85a71cb0562f.png

did the full  command and still getting .opus for mp3 files :(

Link to post
3 minutes ago, deanishe said:

Try again in a few hours. The latest version was released 4 hours ago. It's likely it hasn't made it to Homebrew yet.

i made this snippet in the meantime

youtube-dl --extract-audio --audio-format mp3 --prefer-ffmpeg youtube-dl --extract-audio --audio-format mp3 --prefer-ffmpeg {clipboard}

 

Link to post
  • 4 weeks later...

Thank you for this awesome Workflow .

 

Can you please tell me how to set MP3 as default in youtube-dl as every file i'm downloading turns out to be in .OPUS format .

I'm Using the latest versions of Downmedia , youtube-dl and Homebrew.

 

I couldn't find any command that would set mp3 as default as of now.

Sorry , i'm new to this but i couldn't abort a download as well , the shortcut seems not to be working in my case

Edited by Aj Xkid
Link to post
2 hours ago, Aj Xkid said:

Thank you for this awesome Workflow .

 

Thank you for the words.

 

2 hours ago, Aj Xkid said:

Can you please tell me how to set MP3 as default in youtube-dl

 

That’s explained in the README. Use the audio_only_format Using Variables in Workflows.

 

2 hours ago, Aj Xkid said:

I'm Using the latest versions of Downmedia , youtube-dl and Homebrew.

 

Never say “latest” but always the exact version. With “latest” I don’t know if you mean the latest beta or stable version, nor do I know if you’re really on the newest version. You may think you’re up to date but be mistaken. “Latest” also makes it difficult for people who face the same issue later on and find the conversation, as they’ll have no idea if their version matches the one in the report.

 

2 hours ago, Aj Xkid said:

Sorry , i'm new to this but i couldn't abort a download as well , the shortcut seems not to be working in my case

 

I’ll need more details than that. The top post links you to another post in this thread with instructions on what I need.

Link to post
  • 2 weeks later...

This is one of most useful workflows I have ever seen. But for some reasons the workflow is not working for me.

Is this workflow still in use (2020 April) ?

 

I tried following:

- installed downvid workflow

- go to youtube and played the url  elephants dream trailer 

- typed `dv` in alfred

 

Error for elephants trailer in Chrome

======================

```

[11:25:45.071] ERROR: DownMedia[Run Script] WARNING: Unable to extract video title

ERROR: This video is unavailable.

```

 

 

Error  for elephants dream video in Chrome

===================================

```

[11:29:26.551] STDERR: DownMedia[Script Filter] /Users/poudel/Dropbox/Alfred.alfredpreferences/workflows/user.workflow.C7EBB14D-C50D-4512-B984-48E18E507967/get_title_and_url.js: execution error: Error: Error: You need a supported browser as your frontmost app (-2700)

[11:29:41.478] ERROR: DownMedia[Run Script] WARNING: Unable to extract video title

ERROR: This video is unavailable.

```

 

Error for safari elephants dream video

==================================

```

[11:36:27.797] Logging Started...

[11:36:43.649] ERROR: DownMedia[Run Script] WARNING: Unable to extract video title

ERROR: This video is unavailable.

```

 

Specification
============

Google chrome: Version 81.0.4044.92 (Official Build) (64-bit)

Macos:  catalina 10.15.4

Alfred:  4.0.9

Date: Apr 13, 2020

Edited by Bhishan
Link to post
  • 2 weeks later...
On 3/5/2020 at 5:00 PM, eluxmaxel said:

i made this snippet in the meantime


youtube-dl --extract-audio --audio-format mp3 --prefer-ffmpeg youtube-dl --extract-audio --audio-format mp3 --prefer-ffmpeg {clipboard}

 I tried that didnt work image.thumb.png.46f1a150bc8dbb869c3c65feb82d68ad.png 

and updated the downmedia now I have this

 image.png.b956a99bf2519220340aedb1f160ee5d.png

 

 

Link to post

@eluxmaxel You’ve edited my Workflow on your local setup, and now are making bug reports pertaining to your own changes. It’s unreasonable to expect me to support those, not the least of which because I have no idea where you made your changes.

 

Furthermore, despite being asked several times you continue to fail to follow the requested instructions and your bug reports remain mostly unintelligible. That consumes quite a bit of time for everyone, which takes away from our ability to help people that take the effort to make good reports. I firmly believe people who take the care to make good bug reports should be rewarded, not punished, so I want to dedicate more time to those. As such, I’m making the choice to not respond to your reports from now on (anyone else is welcome to—it’s their time).

 

I do genuinely hope you’re able to fix the issue you have, but it will have to be without my assistance.

Link to post
  • 3 weeks later...

Weird "Issue". I am running 3 computers with Alfred with this workflow. On 2 of the computers I can set up hotkey for this workflow in Alfred (works fine) but on 2 of the machine's I can also set up the hot key under 

Keyboard > Shortcuts > Services > Internet 


But one one of my machines, the Download Media Program does not appear, I can't figure out how to get it there! Small issue just strange. Def more of an OS thing., 

Link to post
5 hours ago, Bemawr said:

but on 2 of the machine's I can also set up the hot key under 

Keyboard > Shortcuts > Services > Internet 

 

Because you’ve installed the Services (:downmediaservices in Alfred).

 

5 hours ago, Bemawr said:

But one one of my machines, the Download Media Program does not appear

 

What program?

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...