Jump to content

Wrong result order after hitting ENTER on an invalid item


derfla
 Share

Recommended Posts

In a workflow I use an item with valid=no and an autocomplete value.

 

If I hit TAB on this item, everything is fine. But if I hit ENTER, Alfred ignores its knowledge for the results.

 

To demonstrate this, I've built an example workflow: https://dl.dropbox.com/u/13250089/alfred/test.alfredworkflow

 

1. type "test action ", select "test action b", hit ENTER

2. type "test ac", hit TAB -> "test action b" is now on top

3. type "test ac", hit ENTER -> "test action a" is on top, but I would expect "test action b" as in 2.

Link to comment
Share on other sites

  • 2 weeks later...

Another way to replicate the issue:

 

Download "Open Folders in TextMate" workflow from here: http://blog.alfredapp.com/2013/01/12/v2-beta-a-few-workflows-to-get-you-started/

 

1. type "fold", hit TAB on "Search folders only", type "a", hit ENTER on the second item

2. type "fold", hit TAB on "Search folders only", type "a" -> the selected item of 1. is now on top (because of "Top Result Keyword Latching")

3. type "fold", hit ENTER on "Search folders only", type "a" -> the selected item of 1. isn't on top any more

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...