Jump to content

Clipboard History Auto-paste


atsumori

Recommended Posts

I encountered aan odd bug. In previous versions of Alfred, when I selected something from the clipboard history viewer, it auto-pasted it. I upgraded to 5.5 a week or so ago, and it hasn't been auto-pasting what I select since I upgraded. It does move whatever I select to the top of the clipboard history, so I can then paste it in myself with a simple ⌘v, but that is an extra step. I preferred the auto-paste. Yes, "Auto-paste" on return is checked. I thought maybe something might have gotten corrupted when I upgraded, so I unchecked that, restarted the app, then checked it. But no, still isn't working. 

 

Is this a common bug? What else should I try for fixing it?

Link to comment

@atsumori Which app(s) are you trying to paste into? If you use TextEdit, do you see Alfred paste normally?

 

Have you checked that Accessibility is granted to Alfred? Have you tried removing and re-adding Alfred to ensure macOS is "nudged" into seeing that you've granted it.

 

More details on permissions:

https://www.alfredapp.com/help/getting-started/permissions/#integration

Link to comment

Hi Vero. It didn't work in any app. Unchecking, rebooting, and rechecking didn't help. But, you gave me an idea that did work, so I'll write it here for future reference. 

 

I quit Alfred, then opened the terminal and typed

 

tccutil reset All com.runningwithcrayons.Alfred;

 

This forces a reset of all permissions. Then I reloaded Alfred and granted permissions anew. And it worked! So for anyone else that runs into this problem, try the more drastic permissions reset in terminal. 

 

Edit: hah, I thought I was being clever by figuring this out myself, but I see this step is listed at the bottom of the page you linked. So, it worked! 😃 Thank you. 

Edited by atsumori
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...