Jump to content

Accessing File Buffer very slow (10 seconds to open)


sphardy
 Share

Recommended Posts

Hi

 

I noticed recently that it takes 10 seconds for the file buffer actions window to open when using the Opt+Cmd+\ hotkey on a finder selection. (Literally 10 seconds - I've timed it)

 

I am running the latest 2.0.3 release and have restarted Alfred after temporarily removing my sync'ed preferences to see if any custom workflow was the cause - the problem remains. I also downgraded to 2.0.2 but that didn't help either. Finally I cleared the caches - again no change.

 

(Edit: Removing ~/Library/Application Support/Alfred 2 doesn't fix the issue either - feels like I've effectively completely reinstalled Alfred and the problem remains)

 

The standard Alfred popup is instantaneous as always as is the file search window triggered with Opt+Cmd+/

 

Could someone please advise?

 

Thanks

 

MacBook Pro running OSX 10.8.3

Edited by sphardy
Link to comment
Share on other sites

Hi

 

I noticed recently that it takes 10 seconds for the file buffer actions window to open when using the Opt+Cmd+\ hotkey on a finder selection. (Literally 10 seconds - I've timed it)

 

I am running the latest 2.0.3 release and have restarted Alfred after temporarily removing my sync'ed preferences to see if any custom workflow was the cause - the problem remains. I also downgraded to 2.0.2 but that didn't help either. Finally I cleared the caches - again no change.

 

(Edit: Removing ~/Library/Application Support/Alfred 2 doesn't fix the issue either - feels like I've effectively completely reinstalled Alfred and the problem remains)

 

The standard Alfred popup is instantaneous as always as is the file search window triggered with Opt+Cmd+/

 

Could someone please advise?

 

Thanks

 

MacBook Pro running OSX 10.8.3

 

Just to clarify, in your post you said the "file buffer actions" and said your hotkey was cmd+opt+\, that isn't the hotkey for the file buffer actions. By default, cmd+opt+\ is the hotkey to action a file(s) selected in Finder. With files in the file buffer, the hotkey to action them is opt+right arrow.

 

So, with that being said, can you verify if things are working the way that I described or are you still having issues? If you are still having issues, can you clarify a little in the post exactly what's going on?

Link to comment
Share on other sites

I used the incorrect term - this is to action files selected in Finder. When files are selected and I press cmd+opt+\ then it takes 10s for the Alfred window to appear

Same is true if I use cmd+opt+/ to navigate to a file (which works instantly) and then press Fn to open the same action window

Link to comment
Share on other sites

I used the incorrect term - this is to action files selected in Finder. When files are selected and I press cmd+opt+\ then it takes 10s for the Alfred window to appear

Same is true if I use cmd+opt+/ to navigate to a file (which works instantly) and then press Fn to open the same action window

 

Unfortunately, this may be outside of Alfred's control. Could you please try creating a new user in OS X, switching to that user and trying Alfred from there?

 

[moving to investigating to keep bugs thread clear]

Link to comment
Share on other sites

Think I've found the issue.

 

I use the Finder extension TotalFinder - I tried disabling that and Alfred started to respond immediately again . It also responds immediately after restarting TotalFinder, so something odd appears to have happened, perhaps after a recent update to TotalFinder, which a restart has cured.

 

Note that I've run TotalFinder for as long as I've run Alfred - all without issue - so I'm hoping this was a spurious issue and not some new general incompatibility with TotalFinder

Link to comment
Share on other sites

 Share

×
×
  • Create New...