Jump to content

growl notification appears in Chinese or kanji symbols


Recommended Posts

Just set up workflow with Growl notification but the notification displays as Chinese characters (I think). I have reproduced it several times. I am pretty new to workflows.
 
I've Not attached a screenshot since I don't see how i'm supposed to add an attachment. Let me know and I'll post it.
 
Growl works fine for other apps.
 
I'm on Lion 10.7.5 and latest Alfred 2.04
 
 

Edited by mt5
Link to post

Just set up workflow with Growl notification but the notification displays as Chinese characters (I think). I have reproduced it several times. I am pretty new to workflows.

 

I've Not attached a screenshot since I don't see how i'm supposed to add an attachment. Let me know and I'll post it.

 

Growl works fine for other apps.

 

I'm on Lion 10.7.5 and latest Alfred 2.04

 

 

 

Before we continue, could you try a REALLY simply workflow to ensure that it's not something from your workflow or script causing it? Create a workflow, add a keyword, add a run script item, leave the language set to bash, and in the script area add the code:

echo "This is a sample notification"

Then add a notification output, set it to use growl, and connect everything up. Does that work correctly?

Link to post
  • 2 weeks later...

Ok. I tried your suggestion and it works ok. The Growl notification says "This is a sample notification". So that's good.

In my Applescript, the last line before the end is:

 

display dialog theResult buttons {"Done"} default button 1

end alfred_script

 

This displays "theResult", which is just a filename as a string, in a button so I can see the filename on my screen.

So, if I add the {query} placeholder in the Notification object and run my script in Alfred, I get a Chinese character output. If I then comment out the line that displays the button with "theResult" then the output appears in English. 

 

So, for now since all I wanted was to display the Growl notification instead of the button dialog, I'm ok. Although it bothers me that I can not understand why adding a button causes Chinese output to Growl.

 

Thank you for suggesting the simplification since that led to at least an acceptable solution.

 

I wish I could attach a screenshot but I still can't see how in this edit tool.

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...