Jump to content
Wildcard

"Browse in Alfred" shows Finder Info window instead

Recommended Posts

Hello,

I love the navigation and file actions features in Alfred and would like to be able to access them immediately, from the Finder.  However, the built in option for this isn't working for me.

 

Under Features->File Search->Actions->File Selection, the text states "Use this hotkey to show the actions panel for the currently selected files in OS X."  However, although I've tried setting this hotkey to many various keyboard combinations, all it ever does is open the Info window in the Finder for the currently selected files.  (It's equivalent to pressing ⌘I.)

 

I've also tried creating a workflow with the output action "Browse in Alfred" with identical results (the Info window in Finder).  Even when using the template "File System Navigation for Specified Path" and just setting the hotkey (changing nothing else), the workflow just opens the Finder Info panel rather than browsing in Alfred.

 

Both of these things (file actions menu, and browsing in Alfred) are things I would LOVE to have a single keystroke to access from the Finder for any selected files or folder.  Right now I can't do it.  Since I don't see anyone else complaining, maybe it's something wrong with my configuration, but I don't see what it could be that's wrong....

 

I'm using v2.0.5 on a 2011 MBP running Mac OS Lion 10.7.4.  "About Finder" shows Finder Version 10.7.3.  Any help, please?

Share this post


Link to post

Hello,

I love the navigation and file actions features in Alfred and would like to be able to access them immediately, from the Finder.  However, the built in option for this isn't working for me.

 

Under Features->File Search->Actions->File Selection, the text states "Use this hotkey to show the actions panel for the currently selected files in OS X."  However, although I've tried setting this hotkey to many various keyboard combinations, all it ever does is open the Info window in the Finder for the currently selected files.  (It's equivalent to pressing ⌘I.)

 

I've also tried creating a workflow with the output action "Browse in Alfred" with identical results (the Info window in Finder).  Even when using the template "File System Navigation for Specified Path" and just setting the hotkey (changing nothing else), the workflow just opens the Finder Info panel rather than browsing in Alfred.

 

Both of these things (file actions menu, and browsing in Alfred) are things I would LOVE to have a single keystroke to access from the Finder for any selected files or folder.  Right now I can't do it.  Since I don't see anyone else complaining, maybe it's something wrong with my configuration, but I don't see what it could be that's wrong....

 

I'm using v2.0.5 on a 2011 MBP running Mac OS Lion 10.7.4.  "About Finder" shows Finder Version 10.7.3.  Any help, please?

 

Could you try creating a new user profile on your Mac, switching to that user, activating your Powerpack and trying from there? There may be an issue on your main profile.

 

Cheers,

Andrew

 

[Moving to the Help subforum]

Share this post


Link to post

Could you try creating a new user profile on your Mac, switching to that user, activating your Powerpack and trying from there? There may be an issue on your main profile.

 

Cheers,

Andrew

 

[Moving to the Help subforum]

 

Spot on.  (I just used my wife's login and activated the PowerPack there.)  No trouble there, works as it should..  So how can I tell what's messing it up on my login?

 

I run BetterTouchTool and Keyboard Pilot—the two apps I think would be most likely to interfere with Alfred—but I quit both and got the same result with Alfred.  Also, I almost always use the keyboard layout "Dvorak — Qwerty ⌘", but it works fine with Alfred and everywhere else.  Just in case, I tried switching to standard US QWERTY layout and got the same result.

 

Is there a preference file somewhere that I would have to trash?  :/

Share this post


Link to post

Spot on.  (I just used my wife's login and activated the PowerPack there.)  No trouble there, works as it should..  So how can I tell what's messing it up on my login?

 

I run BetterTouchTool and Keyboard Pilot—the two apps I think would be most likely to interfere with Alfred—but I quit both and got the same result with Alfred.  Also, I almost always use the keyboard layout "Dvorak — Qwerty ⌘", but it works fine with Alfred and everywhere else.  Just in case, I tried switching to standard US QWERTY layout and got the same result.

 

Is there a preference file somewhere that I would have to trash?  :/

 

Do you use any other tools which use the accessibility API which could be interfering, such as text expander? You could try fully resetting Alfred using this guide:

 

http://support.alfredapp.com/kb:reset-alfred

 

Cheers,

Andrew

Share this post


Link to post

Hmmm....

 

Okay, well, that's a mystery.  Here's what I did: I followed those instructions exactly.  After deleting the first three files, the same problem occurred. After deleting all four files (well, one is a folder, but whatever) and therefore needing to re-register my Powerpack, the same problem STILL occurred.  So, not wishing to have to redo all of my workflows, custom searches, et. al., I went in the trash and "put back" the deleted files.  The same problem still occurred.

 

Then, although I could have sworn I had tried this before, I checked, on an off-chance, switching back to US QWERTY layout and pressing ⌥\ (which is the "file actions" hotkey).  It worked!!!!  (Note that Keyboard Pilot was off while I did this.)  Then—and the really weird part—I switched back to my usual layout of "Dvorak—Qwerty ⌘" and the hotkey STILL worked!  And I turned on Keyboard Pilot, and the hotkey is still working.

 

I don't know WHAT the hell made it suddenly start working.  But I'm happy.  And hopefully if anyone else has this problem, these mystical steps will handle it for them also.   :)

 

EDIT: Sorry, it appears I wrote too soon.  Something to do with a cache not being cleared or something.  Anyways, it stopped working, and I found that deleting the first three files specified in your support link PLUS the two files in preferences with identical names but ending in ".lockfile", was sufficient to handle the problem.  Cheers!

Edited by Wildcard

Share this post


Link to post

Okay, this is still a bug for me.  No idea what's going on.  One thing that might shed some light on it, though:

 

Using US QWERTY layout, I go to Alfred Preferences to set the keyboard shortcut for the file actions option.  WHATEVER keyboard shortcut I choose, if I then tap it again, the little box that shows what keyboard shortcut I'm selecting changes to ⌘I (which is of course the Get Info command in Finder!)  Apparently all Alfred is doing is mapping whatever keyboard shortcut I set there, to ⌘I.

 

Any suggestions?  Can you see this on your machine?

Share this post


Link to post

Do you use any other tools which use the accessibility API which could be interfering, such as text expander? You could try fully resetting Alfred using this guide:

 

http://support.alfredapp.com/kb:reset-alfred

 

Cheers,

Andrew

 

Andrew:

 

AHA!  I have found it.

 

The bug is: this odd behavior happens if the keyboard layout is set to "Dvorak" or "Dvorak - Qwerty ⌘" when Alfred is STARTED!!!  It doesn't matter what the layout is changed to later, and it doesn't produce the bug if the layout is switched to "Dvorak" or "Dvorak - Qwerty ⌘" AFTER Alfred is started—only if one of those is the setting during Alfred's startup.  Very tricky.

 

Before I figured this out, I made a new topic here: http://www.alfredforum.com/topic/2779-file-actions-hotkey-just-remapping-to-⌘i/

...wherein I more fully described the odd things that happen when this bug shows up.  (Read my last post in that topic; it's much clearer than the first post.)

 

Hopefully you can work in a fix for this at some point, but in the meantime I'll just restart Alfred manually with the QWERTY layout any time I restart my computer....  (I leave my keyboard layout on "Dvorak - Qwerty ⌘" nearly all the time, so I am one of the few people who would have seen this bug :) )

 

Possibly this should be moved back to the bug reports section?   :)

Share this post


Link to post

Hopefully you can work in a fix for this at some point, but in the meantime I'll just restart Alfred manually with the QWERTY layout any time I restart my computer....  (I leave my keyboard layout on "Dvorak - Qwerty ⌘" nearly all the time, so I am one of the few people who would have seen this bug :) )

 

Possibly this should be moved back to the bug reports section?   :)

 

Hm, this is an awkward one as Alfred is actually very likely working as intended, as he discovers which is the keycode to register for the hotkey, and if the keyboard layout is different to the literal keyboard layout you will be using, then OS X will be returning different codes.

 

You could try setting the hotkey combinations in Alfred while you have your dvorak keyboard set, then the actual combinations used will match. It's also worth noting that when switching between keyboard setups, the hotkey field may show misleading characters... once a key is registered, it will be registered to the actual key on the keyboard, not the character.

Share this post


Link to post

Hm, this is an awkward one as Alfred is actually very likely working as intended, as he discovers which is the keycode to register for the hotkey, and if the keyboard layout is different to the literal keyboard layout you will be using, then OS X will be returning different codes.

 

You could try setting the hotkey combinations in Alfred while you have your dvorak keyboard set, then the actual combinations used will match. It's also worth noting that when switching between keyboard setups, the hotkey field may show misleading characters... once a key is registered, it will be registered to the actual key on the keyboard, not the character.

 

I'll agree it's an awkward one, although I think it should at least be noted as a known issue.

 

For now I'm happy with my workaround of starting Alfred with the standard QWERTY layout active and then switching to my usual layout.  When I do this the file actions menu can be correctly activated from Finder.  I had some odd trouble with Alfred's text copy/paste functionality afterwards, but after a reboot that doesn't seem to be reproducing...I'll let you know if anything else odd happens as a result.

 

Also, I'm familiar with the oddity when setting hotkeys in alternate layouts.  In actual fact, I always switch layouts to US (standard Qwerty) when setting hotkeys in Alfred or any app, just because it's confusing otherwise (and, like you say, it shows misleading feedback).

 

In case you weren't familiar with it, "Dvorak - Qwerty ⌘" is possibly the oddest keyboard layout of them all because it types in Dvorak but lets you run keyboard shortcuts with the standard, normal keys.  E.g., I use ⌘C as usual for copy even though the "C" key on the keyboard types a J when using the Dvorak layout.  Because of this, when I set ⌥/ as the hotkey in Alfred, those keys will work regardless of which layout I'm using later, even though just the / key by itself will type a Z on Dvorak.  (I think I made that as clear as I can...if it still doesn't make sense you might need to play around with the "Dvorak - Qwerty ⌘" layout for a few minutes to get it.)

 

Anyone using alternate keyboard layouts like me has now and then run into odd responses to them from everyday apps.  Heck, even LibreOffice and Adobe Reader don't get it quite right when it comes to "Dvorak - Qwerty ⌘"!  But it would be nice to have the fact noted, especially since this oddity of Alfred shows up even with just straight Dvorak layout.

 

And I should mention that I use Alfred an average of 60 times a day, and it's my favorite app on my Mac.   :)

Share this post


Link to post

Going to bump this ancient bug report:

 

I have been running consistently on 2.3 because once my software works I leave it alone.  The other day I accidentally upgraded to 2.8.3.  :)

 

2.8.3 fixes half of the issue described above, because it no longer matters what the current keyboard layout is while Alfred is running—but it breaks the more important half.  Using 2.8.3, with Dvorak as the keyboard layout while using Finder, there is simply no way to activate the File Action menu, regardless of the keyboard layout that was set when Alfred started up.  I'll just get the "File Info" window unless I switch to QWERTY layout before activating the file action hotkey.

 

This is more logical in a sense; it's not exactly an intended feature to behave differently depending on the keyboard layout that was set during app startup.  Nevertheless, this breaks the workaround I had worked out above.

 

Is there another workaround possible (or better yet, a permanent fix?)

Share this post


Link to post

Using 2.8.3, with Dvorak as the keyboard layout while using Finder, there is simply no way to activate the File Action menu, regardless of the keyboard layout that was set when Alfred started up.  I'll just get the "File Info" window unless I switch to QWERTY layout before activating the file action hotkey.

 

 Works perfectly for me.

 

The problem very much appears to be with your user account (probably some crufty old preferences left over from an old version of OS X). You say yourself, it works fine on a different account.

 

I'm not sure how much help the Alfred community can be with a problem that doesn't appear to be caused by Alfred and that nobody else is having.

 

It might be time to think about creating yourself a new user account and carefully moving only the files you need over to it.

 

Heck, even LibreOffice and Adobe Reader don't get it quite right when it comes to "Dvorak - Qwerty ⌘"!

 

:) When I think of Mac software that gets things right, those two are right at the top of the other list. LibreOffice is an especially turd: For years it couldn't even open files with non-ASCII characters in the filepath and still doesn't support default Mac navigation shortcuts or render the cursor in the right place.

Share this post


Link to post

I foolishly upgraded to 2.8.6. :(

 

Is this fixed in Alfred 3?  If so I would bite for the paid upgrade.

 

Not really thrilled with the "oh well" response.

 

Succinct statement of bug: "file action" trigger does not work on alternate keyboard layouts—period.

 

That seems like a bug worthy of fixing.

Share this post


Link to post
8 minutes ago, Wildcard said:

Not really thrilled with the "oh well" response.

[...]

That seems like a bug worthy of fixing.

 

You said yourself, Alfred works fine under a different account. And for other people.

 

The problem appears to lie with your user account.

 

Unless you can provide a reliable way for other people to replicate the issue, it's almost impossible to diagnose.

Share this post


Link to post

I just used a FRESH install of Alfred 2.8.6 on a FRESH install of Mac OS 10.11.6 and reproduced the problem with no trouble at all.  Please don't blame the user before you've at least made an attempt to reproduce the reported bug.  (This reminds me of https://xkcd.com/806/)

 

Steps to reproduce:

 

1. Set keyboard layout to "Dvorak - Qwerty ⌘".

2. Attempt to launch the "File Actions" menu in Finder using the keyboard shortcut defined in Alfred.

 

Results: The "Get Info" window appears for the selected file.

 

Now, I have made a VERY few other adjustments to my preferences on this particular computer, but (a) none of them should be relevant (b) nothing was imported from my previous Alfred install where I first had this difficulty and (c) this is a different computer, not just a new OS on the same hardware.

 

If you can successfully trigger the "File Actions" menu from Finder with the "Dvorak - Qwerty" keyboard layout set, using any key combination, I will be impressed.

 

I really love the context menu (a.k.a. File Actions menu) in Alfred.  "Open with..." and "Move to..." as well as "Email to..." are in constant use, so it is really a great irritation in my workflow to have to switch keyboard layouts before the context menu will work.

Share this post


Link to post

If you can't reproduce it using the steps above, tell me how to completely wipe and reinstall Alfred on my El Capitan computer and I will attempt to reproduce it with NO adjustments to settings from the default.  But I think the above two steps would be enough.

Share this post


Link to post

I shut down Alfred, switched to QWERTY layout, removed both Alfred-related directories from ~/Library/Caches/, removed both relevant files from ~/Library/Preferences/, removed ~/Library/Application Support/Alfred 2/ (after saving the license file), started up Alfred with factory settings, loaded in the license so I could access PowerPack features again, and tried using the default keyboard shortcut for File Actions: ⌥⌘\   It worked successfully.  I made no other changes except switching layouts to "Dvorak - Qwerty ⌘" and tried activating the File Actions menu again.  I got the "Info" pane instead.

 

Whatever I said in 2013 about it working for other people or other accounts was using version 2.0.5, not version 2.8.6.

 

As my later testing revealed (and as is described earlier in this thread), in version 2.0.5 through at least version 2.3, if Alfred is started while the Qwerty keyboard is active, and the File Actions hotkey is triggered while the Qwerty layout is still the active layout, then the File Actions hotkey will work correctly regardless of later keyboard layout changes.  In those same versions, if Alfred is started while the Dvorak - Qwerty ⌘ layout is active, and if the File Actions hotkey is first triggered with that keyboard layout active, then the File Actions hotkey will only open the File Info pane of Finder (what you get with the OS keyboard shortcut ⌘I), even after further keyboard layout changes—even if it's changed to Qwerty.

 

This behavior changed between 2.3 and 2.8.6.  In version 2.8.6, regardless of what keyboard layout is active when Alfred is started up, if the Dvorak - Qwerty ⌘ layout is active when you trigger the File Actions hotkey, the "Get Info" window is what will appear.  And in version 2.8.6, regardless of what keyboard layout is active when Alfred is started up, if the Qwerty layout is active when you trigger the File Actions hotkey, the hotkey will work correctly.

 

(In my earlier test from another user account using version 2.0.5, I had started Alfred with the Qwerty layout active before switching it to Dvorak - Qwerty ⌘.  Therefore my conclusion at the time that it "worked from another user account, just not from mine" was actually invalid and based on insufficient testing.)

 

So no, the problem doesn't lie with my user account.  The above can be reliably reproduced on the latest build of Alfred on a brand new computer with no prior Alfred installation (and no lingering preferences).  This is purely an Application-level bug in Alfred.

 

I hope that info is more helpful for diagnosis?  I wouldn't be writing all this at all if I didn't really care about Alfred's functionality, and rely on it constantly.

 

Do you think the developers could please have a look at this?

Share this post


Link to post

I don't understand what you're doing exactly.

 

If you activate Dvorak, Alfred still uses QWERTY layout. That is to say, ⌘⌥+/ means ⌘⌥+button next to right SHIFT button.

 

If you want a Dvorak ⌘⌥+/ (i.e. ⌘⌥+[ in QWERTY terms), you need to set the hotkeys again in Alfred Preferences.

 

As far as I can tell, the only issue is that when you switch keyboard layout, Alfred doesn't update what it's showing in its hotkey boxes to match what the key now does.

 

That is to say, Alfred's hotkeys don't move to different physical keys when you change keyboard layout (which I think is good). But the key combination it's displaying also doesn't change to reflect the character the key now produces under the different layout.

 

For example, when I switch to a German layout, ⌘⌥+button next to right SHIFT button remains the file buffer hotkey, but Alfred still says it's ⌘⌥+/ although that key is now the - key. To get Alfred to show the right character for the current layout, you have to set the hotkeys again using that layout. So if I delete the hotkey and enter ⌘⌥+button next to right SHIFT button, Alfred then correct says ⌘⌥+-, as that's now the minus key under a German layout.

 

Edited by deanishe

Share this post


Link to post

Alfred 3 has awareness / support for Dvorak-QWERTY, and overall improved keyboard handling / layout caching. This fixes the fundamental issue you are seeing in which Alfred uses cmd+c to obtain the selected Finder item.

 

Essentially, what's happening is Alfred is simulating cmd+c and depending on how Alfred 2 was started and which keyboard layout you were using at that point, the simulated keypress may relate to the Dvorak cmd+i (i.e. switched locations).

 

I've tested with Alfred 3 and my Finder Selection hotkey alt+F and always get Alfred's actions panel regardless of keyboard.

 

Cheers,

Andrew

Share this post


Link to post

Awesome, thanks Andrew!  In that case I will probably upgrade soon.... :)

 

In the meantime, I actually made a workaround using BetterTouchTool—which is the only application that I install before I install Alfred on a new computer. ;)  I set Alfred's File Actions key to something complicated (that I won't need to use with anything else), and then I use BTT with (option /) to (a) switch keyboard layouts (b) wait 0.1 seconds so the layout actually switches (c) trigger Alfred's File Actions hotkey (the complicated one) and (d) switch layouts back.

 

But yeah, it would be nice not to need that.  :D  After I'm done migrating to this new computer I'll make the plunge for Alfred 3. 

 

Thanks for your constant work to improve the product.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...