Jump to content
Wildcard

File Actions Hotkey just Remapping to ⌘I

Recommended Posts

I had earlier posted about this here: http://www.alfredforum.com/topic/2719-browse-in-alfred-shows-finder-info-window-instead/

 

I'm making a new topic because I better isolated the trouble (as described in my final post in that topic).

 

What's happening is that the hotkey to activate the File Actions menu from the Finder just gets remapped to "⌘I".  So when I try to use that hotkey, I just see the Finder "Info" panel for the selected files instead of the list of Alfred actions.

 

The hotkey setting I am talking about is under Features -> File Search -> Actions, and it's at the very bottom of the window, labeled "File Selection" with a note: "Use this hotkey to show the actions panel for the currently selected files in OS X."

 

The reason I know it's getting remapped is if I go into settings and set the hotkey to any key combination (it doesn't matter what) and then press that key combination again, the little box shows ⌘I as the new hotkey.  If I press the shortcut again, it will toggle back and display what the key combination actually is that I pushed.  (I know this sounds confusing without screenshots, but I don't see an easy way to post those....)

 

Why on earth is this happening and how can I stop it?

Share this post


Link to post

I had earlier posted about this here: http://www.alfredforum.com/topic/2719-browse-in-alfred-shows-finder-info-window-instead/

 

I'm making a new topic because I better isolated the trouble (as described in my final post in that topic).

 

What's happening is that the hotkey to activate the File Actions menu from the Finder just gets remapped to "⌘I".  So when I try to use that hotkey, I just see the Finder "Info" panel for the selected files instead of the list of Alfred actions.

 

The hotkey setting I am talking about is under Features -> File Search -> Actions, and it's at the very bottom of the window, labeled "File Selection" with a note: "Use this hotkey to show the actions panel for the currently selected files in OS X."

 

The reason I know it's getting remapped is if I go into settings and set the hotkey to any key combination (it doesn't matter what) and then press that key combination again, the little box shows ⌘I as the new hotkey.  If I press the shortcut again, it will toggle back and display what the key combination actually is that I pushed.  (I know this sounds confusing without screenshots, but I don't see an easy way to post those....)

 

Why on earth is this happening and how can I stop it?

 

I helped another user to post screenshots; maybe that will help? I know I'm having trouble following what's going on ;)

 

Here's the link: http://www.alfredforum.com/topic/2529-need-to-be-able-to-put-screenshots-in-questionsanswers/?p=14644

 

Cheers :)

Share this post


Link to post

I had earlier posted about this here: http://www.alfredforum.com/topic/2719-browse-in-alfred-shows-finder-info-window-instead/

 

I'm making a new topic because I better isolated the trouble (as described in my final post in that topic).

 

What's happening is that the hotkey to activate the File Actions menu from the Finder just gets remapped to "⌘I".  So when I try to use that hotkey, I just see the Finder "Info" panel for the selected files instead of the list of Alfred actions.

 

The hotkey setting I am talking about is under Features -> File Search -> Actions, and it's at the very bottom of the window, labeled "File Selection" with a note: "Use this hotkey to show the actions panel for the currently selected files in OS X."

 

The reason I know it's getting remapped is if I go into settings and set the hotkey to any key combination (it doesn't matter what) and then press that key combination again, the little box shows ⌘I as the new hotkey.  If I press the shortcut again, it will toggle back and display what the key combination actually is that I pushed.  (I know this sounds confusing without screenshots, but I don't see an easy way to post those....)

 

Why on earth is this happening and how can I stop it?

 

So, just to make sure that I am understanding correctly... If you set that hotkey, then close the preferences window and go back to the preferences, the hotkey has always been changed to ⌘I ?

Share this post


Link to post

So, just to make sure that I am understanding correctly... If you set that hotkey, then close the preferences window and go back to the preferences, the hotkey has always been changed to ⌘I ?

 

Not quite.  If I set that hotkey (we'll say ⌥/ since that's the hotkey I'm trying to use—but I've tested with other hotkeys, too), then anywhere I use that hotkey, the resulting action will be as though I typed ⌘I instead.

 

For example, using InDesign, ⌥/ is a null shortcut—it shouldn't do anything.  But if ⌥/ is set in Alfred as the "File Actions" hotkey, then when I press ⌥/ in InDesign, I'll get the "Check Spelling" window, because the shortcut for check spelling is ⌘I in InDesign.  Similarly in Preview, ⌥/ will give me the Inspector pane, which is supposed to only be activated by ⌘I.  This also (sort of) explains why I get the "Info" panel in Finder: the standard shortcut to view that is ⌘I.

 

My example with the Alfred Preferences setting as a proof was a bad one, since it's so unclear, but with the above illustrations it should make more sense.  Basically, while a certain hotkey is set in that window and displayed there, that hotkey is remapped to ⌘I—including for purposes of setting hotkeys in Alfred.  So if the same hotkey that is displayed in the box is typed in again, it will be received by Alfred as a ⌘I and then that will be displayed instead of the old hotkey.  It's worth noting that this mis-mapping does not affect the System Preferences pane for keyboard shortcuts; ⌥/ is still received there as ⌥/ and not ⌘I.

 

(Thanks for the link on screenshots, Tyler!  I think I made the situation clear with this post, but if I need to post screenshots later I will use that.)

 

So the issue then is the mis-mapping, not just the File Actions hotkey not working, as I thought previously (when I had only tried it in Finder).

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...