Jump to content

Recommended Posts

Just wanted to say thanks, @mannieschumpert, for putting together such a solid little workflow.

 

Stumbled across this when looking for a quick Alfred extension to allow me to trigger a search in Asana, but this is so much better. Fantastic work!

Share this post


Link to post

Want to say THANK YOU @mannieschumpert. Excited about the potential for Asana Quick Task.

 

I'm an Asana power user, and Alfred newbie.

 

PROBLEM/ERROR: "workspace: Not an ID:"

 

I've set aproject target — using aproject and selecting the desired project from the pick list. See snapshot… http://jkorn.com/RIvw The system responds with Growl message: "Project-Name \(1234\) set as task target." Note: Project name has a parentheses, and the parentheses are escaped in the Growl message. But when I attempt to add a new task, targeted to the selected project, I receive a Growl message with an error: "workspace: Not an ID:" See snapshot…  

http://jkorn.com/m54f

 

I've tried: Setting aproject target to a project name with no parentheses. No problems creating new tasks, no error messages.

 

Possible there's a bug affecting project names that include parentheses?

 

Thanks again for making Alfred so useful! I look forward to hearing your advice on this.

Edited by jk02478

Share this post


Link to post

Thanks for this. It works great!

Unfortunately my work with asana mostly revolves around tagging tasks, adding comments, and viewing task details. That kind of functionality isn't available with this workflow right?

I'll keep eye on it to see if it will fit my needs in the future.

 

Share this post


Link to post

@rjfrizz,

This is just my perception, but I think I'm right: there's no way an Alfred workflow can do those things more efficiently than using the Asana web interface.

 

It would be exceedingly difficult to program, and I believe the results would absolutely not increase productivity. So, I can say with almost 100% certainty that I won't ever even try to add those features. Sorry to disappoint.

Share this post


Link to post

I had some revelations, and probably will add the ability to add tags and description, but only at time of task creation.

 

Management of existing tasks still will likely never be considered for addition.

Share this post


Link to post

@mannieshumpert,

 

I continue to get great value from Asana Quick Task. THANKS.

 

BUG: An apostrophe in the title of a task returns an error: "Parse error: parse error in Command line code on line 3". See snapshot: http://jkorn.com/sljm

 

Example: Task title = "asdf's asdf"

 

Am I doing anything wrong?

 

Thanks in advance for any advice.

Share this post


Link to post

@mannieschumpert, thanks again for a speedy reply. Too bad about having to escape the apostrophe. I'll do that for now. Cheers!  Jeff

Share this post


Link to post

@mannieschumpert, thanks for building this great workflow! I am new to alfred powerpack and but I am a Asana power user and this is just making my life much easier! 

 

Congrats on becoming THE official workflow Alfred + Asana, you deserve it!

Share this post


Link to post

As I said, I am a newbie at Alfred and still trying to learn how to use more advanced features. I went through aspaces and choose the one I want it to send the tasks but when i enter a task it shows "Workspace: NOT AN ID"... what am I doing wrong?

 

Sorry to come with such a dumb question :/

Edited by V.A.

Share this post


Link to post

Hey V.A.,

 

That is rather odd, and definitely shouldn't be happening.

 

Do you get this result no matter which workspace you choose?

What happens if you set the task target to a project with aproject? Will adding a task work then?

Share this post


Link to post

@mannieschumpert, you were right on the dollar! It is only happening when I choose a specific workspace. If I choose a project within that workspace, it works just fine as well as choosing another workspace. 

 

Could that be because I am using names that are not commonly used in English, i.e., Comunicação e Mídia? 

 

Thanks, 

V.A.

Share this post


Link to post

That is definitely the reason!

 

I didn't test for Portuguese when I built it. ;)

 

I see what is happening now, and probably can figure out a workaround. I'll keep you posted.

 

That would be great!  I am promoting the use of Alfred and Quick Tasks as much as I can among my friends (that have a mac :) ) and they all speak portuguese :D That is what happens when you leave in Brazil :P 

 

Thanks for putting so much effort on this!!!

Share this post


Link to post

I just downloaded this workflow yesterday and it was working fantastic until this morning? When I noticed my tasks were not showing up, I tried re-entering my API key and gave me this warning...

 

Warning: Invalid argument supplied for foreach() in /Users/xxx/Library/Application Support/Alfred 2/Alfred.alfredpreferences/workflows/user.workflow.xxx/asana.php on line 438

 

Any ideas for how to correct this or start over -- which BTW I have already tried?

Share this post


Link to post

@Jonathan

 

What does "tasks not showing up" mean? Were you adding tasks with QuickTask, and they weren't showing up in the Asana app?

 

Also, that error is occurring because the Asana API is not returning any workspaces, which means either you don't have workspaces or there is a problem with your API key. The "tasks not showing up" problem would also support the possibility that there is a problem with your key.

Share this post


Link to post

@mannieschumpert, do you think you will be able to get the portuguese working on the workflow?  No pressure :D

 

Just checking... 

 

Thanks,

-VA

Share this post


Link to post

@Jonathan Ray:

After hearing a similar report via Twitter, it was revealed that the Asana API was temporarily out of service.

 

@V.A.:

I worked on it a bit weekend before last, but there's some real peculiarities to the way Alfred was encoding/decoding JSON, which is why special characters get busted. I haven't found a solution, but Alfred has some new debugging features. Once I find time to explore those, I might be able to find a solution.

Share this post


Link to post

I've played with this some more and finally gave up and reinstalled both Alfred and your workflow. No luck unfortunately. I get this same warning when trying to set my api key "Warning: Invalid argument supplied for foreach() in /Users/xxx/Library/Application Support/Alfred 2/Alfred.alfredpreferences/workflows/user.workflow.xxx/asana.php on line 438."

 

FWIW, I'm on OSX 10.9.2, 2.7 GHz Intel Core i7

Share this post


Link to post

This is a very useful workflow and is working very well.

 

It would be perfect if it worked that way:

 

"[asana] [name of the project target] [name of the task] [Due date (optional)]" then hit enter.

 

But it is already awesome  :)

Thank you.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×