Jump to content

Applescript-based Workflows Don't Run

Recommended Posts

I'm sure I'm overlooking something here but none of the Applescript-based Workflows run.  Nothing happens.  The Alfred window disappears and that's it.


I'm running Alfred V2 with Powerpack on a MacBook Pro running OSX 10.8.4.


I can copy the script into the Applescript editor and comment out the "on alfred_script(q)" and the "end alfred_script" and it runs.  Here is a script from Aaron B. Hockley's Create OmniFocus Tasks Workflow as an example.  


on alfred_script(q)

  tell application "OmniFocus"
    set theDoc to default document
    set theTask to q
-- comment out the whole tell quick entry block if you want tasks to go straight to inbox
    tell quick entry
      set NewTask to make new inbox task with properties {name:theTask}
    end tell
  end tell
end alfred_script
What am I missing?  Thanks.



Link to comment

Problem solved.  Applescript wasn't handling 'on alfred_script' and 'end alfred_script correctly.  Reinstalling Alfred V2 fixed the problem. 


Glad you got it solved but Alfred hasn't had any issues with AppleScript in the past so I doubt it was just that he wasn't handling it correctly

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...