Jump to content

Forced comma for thousands not working correctly


raguay.customct
 Share

Recommended Posts

Hi,

 

I set the preference to force use of a comma for a separator, but it is showing a period. When I set to use the system preferences, it shows the comma okay. I have a screenshot of it:

 

https://www.dropbox.com/s/p04w1pjsenrico1/AlfredSeparator.jpg

 

The Output preference you're referring to is for setting the decimal separator, not the thousand separator. If you're looking to use the period as thousand separator, choose the comma as decimal separator. :)

 

Moving this to closed as it isn't a bug.

Link to comment
Share on other sites

The Output preference you're referring to is for setting the decimal separator, not the thousand separator. If you're looking to use the period as thousand separator, choose the comma as decimal separator. :)

 

Moving this to closed as it isn't a bug.

 

Your miss understanding me. If either of those options on that page is set to non-system default, I only get a decimal as the thousands separator. But, when my system is set to using a decimal for the thousand separator, I want to force the thousands to be a comma. But, no matter how these settings are set, I can not achieve that. Does that make better sense?

Link to comment
Share on other sites

Your miss understanding me. If either of those options on that page is set to non-system default, I only get a decimal as the thousands separator. But, when my system is set to using a decimal for the thousand separator, I want to force the thousands to be a comma. But, no matter how these settings are set, I can not achieve that. Does that make better sense?

 

Are you referring to the input (what you type) or the output (what is shown below your text box)? Here are a few output examples that should help you out.

 

To force the output to 100,000.00, set the Output to "Use decimal point as separator" and check the box for "Show delimiter for thousands"

To force the output to 100.000,00, set the Output to "Use comma as separator" and check the box for "Show delimiter for thousands"

 

With these options, your results will show as you want them, regardless of your system defaults.

Link to comment
Share on other sites

That is what I would expect, but what I get is 1.234.33! Both of them being decimal. But, if I set to System Defaults for both input and output, then I get 1,234.33 for US, and my Thai system settings get the appropriate for Thailand. But, if I try to force it to be commas on the output, I get only decimals. Sorry, I am losy at describing thing.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...