Jump to content

Hotkeys use QWERTY regardless of user's keyboard layout


hynkle
 Share

Recommended Posts

OS X 10.8.5

Alfred v2.0.8 (212)

 

I use the Dvorak keyboard layout.

 

Alfred's preferences show that my clipboard viewer hotkey is ⌘C, the default.  If I press these keys, nothing happens.  If, however, I press ⌘J, the clipboard viewer opens.  This isn't completely bizarre, as Dvorak's J is located where QWERTY's C is.  This leads me to believe that Alfred simply ignores the user's keyboard layout with regards to hotkeys, using QWERTY for everyone.

 

The issue is easily replicated.  Any time I press ⌘C absolutely nothing will happen; any time I press ⌘J Alfred's clipboard viewer will open.

 

Further notes:

• The issue occurs both on my Macbook Pro's using its built-in keyboard and on iMac using an Apple wireless keyboard.

• OS X does have a "Dvorak - QWERTY ⌘" layout that uses QWERTY for any key combination involving ⌘ but standard Dvorak for typing, which would cause this behavior if it were the current keyboard layout. I've verified that I am not using this layout, and that ⌘C for copy works as expected.

• The computer has been in the Dvorak layout since boot, so switching between keyboard layouts while Alfred is running is not the issue.

• Closing and restarting Alfred causes no change in behavior.

• Switching to QWERTY and back while Alfred is running causes no change in behavior.

 

Let me know if there's anything else you need from me in order to replicate the bug.

Link to comment
Share on other sites

Further discovery: If, using the Dvorak keyboard layout, I change the clipboard viewer hotkey to something else and then back to ⌥⌘C, my C key will work instead of J.

 

The OS X Hotkey API is such that you register the physical keycode, not character. As such, you are seeing behaviour which has been around for quite some time. As long as you set your keyboard layout to the correct one before setting the hotkey, the hotkey will display correctly in Alfred's preferences.

 

I'm moving this to 'noted' as this is something I'm aware of and already have a ticket for, so I may try to make this behaviour more dynamic in the future assuming this is possible without making Alfred more heavy weight at idle (having to watch keyboard layout changes etc).

 

Cheers,

Andrew

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...