Jump to content
thebitguru

Copying file paths to clipboard appends an extra slash even to files [Fixed 2.1.1 b222]

Recommended Posts

What you were doing when the issue happened

Copying a file path.  Select a file (not folder) in finder, press Cmd+option+\, and choose Copy Path to Clipboard.  The copied path will contain a slash after the end of the filename (which signifies a directory).
 
e.g. '/Users/thebitguru/Downloads/Alfred/Alfred_2.1_218.zip/'
 
* Whether you were able to replicate it a second time by performing the same action
Yes, appends the slash in all cases.
 
* Include any screenshots that might help us
Not necessary.
 
* Include the Alfred version & build number you are using
v2.1 (218)
 
* Include your OS X version
10.9

Share this post


Link to post
Share on other sites

 

What you were doing when the issue happened

Copying a file path.  Select a file (not folder) in finder, press Cmd+option+\, and choose Copy Path to Clipboard.  The copied path will contain a slash after the end of the filename (which signifies a directory).
 
e.g. '/Users/thebitguru/Downloads/Alfred/Alfred_2.1_218.zip/'
 
* Whether you were able to replicate it a second time by performing the same action
Yes, appends the slash in all cases.
 
* Include any screenshots that might help us
Not necessary.
 
* Include the Alfred version & build number you are using
v2.1 (218)
 
* Include your OS X version
10.9

 

 

I haven't been able to reproduce this issue on 10.8 or 10.9 with either files or folders. Do you have something in particular installed which could be affecting OS X's flle system APIs?

 

I'm going to move this to the help forum to see if others can reproduce it or shed some light on the issue.

Share this post


Link to post
Share on other sites

The only one that I can think of is Path Finder, but I doubt that's the cause.  It's interesting that the main Alfred window shows the correct path (i.e. without slash), but I get the slash when I use the copy the function.  See the screenshot below.

 

Screen_Shot_2013_11_12_at_9_27_44_PM.png

Share this post


Link to post
Share on other sites

 

The only one that I can think of is Path Finder, but I doubt that's the cause.  It's interesting that the main Alfred window shows the correct path (i.e. without slash), but I get the slash when I use the copy the function.  See the screenshot below.

 

Screen_Shot_2013_11_12_at_9_27_44_PM.png

 

 

I have had another play with this and I think I've got it... it looks like 'Escape copied path' is to blame in Alfred's Features > File Search > Advanced prefs.

 

I'm going to move this back to bugs and get it fixed for 2.1.1, but for now, untick this option and things should work better :)

Share this post


Link to post
Share on other sites

×
×
  • Create New...