Jump to content
huckncatch

Unpredictable behavior when Merging Clipboard Contents

Recommended Posts

I have Clipboard Merging turned on and am running into erratic/unpredictable behavior. Many times when selecting text, typing cmd-c, selecting additional text, typing cmd-c-c, produces merged content from the previous-previous copied text and the current selection. For example, say I've been working in Xcode and have done a bit of copy-paste coding (I know, I know) and then switch to Safari to copy an issue number and want to append the description for pasting into the commit. I select the issue number and type cmd-c (the Edit menu briefly highlights) then select the description and type cmd-c-c (receiving the notification sound), go to paste and end up with the description appended to the last item I had copied in Xcode (at least I assume it's the last one).

 

This doesn't happen every time and I'm leery of viewing the clipboard history (observer effect) prior to cmd-c-c. I've only noticed in Safari but that may be because that's where I do most of this type of copying.

 

Running 10.9 (though this occurred in 10.8 as well), the latest Alfred release (v2.1 (218)), and have all the checkboxes active in the Merging options with 'Separate appended item with space' selected. I'd be happy to perform anything that would help diagnose the problem... I rely on this feature and want to trust it.

 

Thanks!

Edited by huckncatch

Share this post


Link to post
Share on other sites

I have Clipboard Merging turned on and am running into erratic/unpredictable behavior. 

 

I've been testing this and attempting to replicate the issue on a couple of our test Macs on Mavericks, but haven't seen the behaviour you describe no matter what combination of apps I try.

 

Is there any chance you have another application, or even a workflow, installed that responds to Cmd + C or Cmd + C + C and might be doing something else at the same time with your clipboard contents?

 

I'll keep an eye out for anyone else who might report this behaviour, but in the meantime, if you could perhaps try setting up a new profile on your Mac and seeing whether you encounter the same behaviour at any point, it'd be useful as it would help narrow down whether an external factor is playing a part in this.

Share this post


Link to post
Share on other sites

×
×
  • Create New...