Jump to content

MarkdownTransform — Convert Markdown to other formats


vitor

Recommended Posts

  • Replies 125
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Each Hotkey Trigger in the workflow corresponds to a different type of Markdown conversion: Markdown → BBCode Markdown → HTML Markdown → RTF Supported in conversion to RTF:

Ah, yes, I forgot to mention that just before that comment I updated the Workflow’s dependencies. Though I was expecting it to still need further fixing for Catalina, but great that it’s working for y

Headers were removing the line below, which in turn was messing up lists, which was causing your problem.   The new version fixes this, it should now work correctly for your case. I’ve also removed 

Posted Images

I'm getting this with the latest version:

 

[2018-02-26 22:14:57][ERROR: action.script] /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require': dlopen(/Users/****/Library/Application Support/Alfred 3/Alfred.alfredpreferences/workflows/user.workflow.A1917321-BE3A-4788-9739-881D004B077D/_licensed/Redcarpet/gems/redcarpet-3.4.0/lib/redcarpet.bundle, 0x0009): required dylib '/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/libruby.2.0.0.dylib' not found, needed by '/Users/****/Library/Application Support/Alfred 3/Alfred.alfredpreferences/workflows/user.workflow.A1917321-BE3A-4788-9739-881D004B077D/_licensed/Redcarpet/gems/redcarpet-3.4.0/lib/redcarpet.bundle'.  Did try: file not found '/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/libruby.2.0.0.dylib', file not found '/usr/lib/libruby.2.0.0.dylib', file not found '/usr/local/lib/libruby.2.0.0.dylib' - /Users/****/Library/Application Support/Alfred 3/Alfred.alfredpreferences/workflows/user.workflow.A1917321-BE3A-4788-9739-881D004B077D/_licensed/Redcarpet/gems/redcarpet-3.4.0/lib/redcarpet.bundle (LoadError)
	from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
	from /Users/****/Library/Application Support/Alfred 3/Alfred.alfredpreferences/workflows/user.workflow.A1917321-BE3A-4788-9739-881D004B077D/_licensed/Redcarpet/gems/redcarpet-3.4.0/lib/redcarpet.rb:1:in `<top (required)>'
	from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
	from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
	from ./html:4:in `<main>'

 

Tried to upgrade Homebrew Ruby with no success.

Link to post
On 03/01/2018 at 4:42 PM, vitor said:

 

Just as a note, I think the commands need to be modified with a / after ${HOME} to work properly:


mv "${HOME}/Desktop/Dropbox/Alfred3_Sync_Folder/Alfred.alfredpreferences/workflows/user.workflow.1A72E7E5-AF98-4BB3-9C50-2E1BE8F769F2/_licensed/Redcarpet" "${HOME}/.Trash"

/usr/bin/gem install --install-dir "${HOME}/Desktop/Dropbox/Alfred3_Sync_Folder/Alfred.alfredpreferences/workflows/user.workflow.1A72E7E5-AF98-4BB3-9C50-2E1BE8F769F2/_licensed/Redcarpet" --no-document redcarpet

 

 

Link to post
  • 2 months later...
  • 5 months later...
1 hour ago, jacoblo said:

Might be a stupid question but when I do the the mk > rtf I lose all my line breaks. Probably some poor handling on my site but any way around it and fix it?

 

Unfortunately that somewhat depends on the target application. But try the newest version (jus updated) as it may work for you.

Link to post
  • 7 months later...
  • 3 weeks later...
  • 6 months later...

Hey Vitor, I'm getting this:

 

[03:47:25.544] MarkdownTransform[Hotkey] Processing complete
[03:47:25.547] MarkdownTransform[Hotkey] Passing output 'ksfklsdjfklsdjfl[ksd]jfl' to Run Script
[03:47:32.491] STDERR: MarkdownTransform[Run Script] /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require': cannot load such file -- redcarpet (LoadError)
	from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require'
	from /Users/***/Library/Application Support/Alfred/Alfred.alfredpreferences/workflows/user.workflow.87D997CD-0A30-4355-96DB-A45BBAE573A6/ipboard_bbcode_renderer.rb:1:in `<top (required)>'
	from ./bbcode:4:in `require_relative'
	from ./bbcode:4:in `<main>'
[03:47:32.498] MarkdownTransform[Run Script] Processing complete
[03:47:32.499] MarkdownTransform[Run Script] Passing output '' to Copy to Clipboard
[03:47:32.500] MarkdownTransform[Copy to Clipboard] Processing complete
[03:47:32.502] MarkdownTransform[Copy to Clipboard] Passing output '' to Run Script

 

Link to post

I should add that I followed this procedure with no success.

 

On 1/11/2018 at 8:43 PM, vitor said:

@_atanas Try this in a terminal:


mv '/Users/atanasjanackovski/Library/Application Support/Alfred 3/Alfred.alfredpreferences/workflows/user.workflow.C2D7D30E-F51F-489C-AB45-C098803A3AD0/_licensed/Redcarpet' "${HOME}/.Trash"

/usr/bin/gem install --install-dir '/Users/atanasjanackovski/Library/Application Support/Alfred 3/Alfred.alfredpreferences/workflows/user.workflow.C2D7D30E-F51F-489C-AB45-C098803A3AD0/_licensed/Redcarpet' --no-document redcarpet

The same caveat as before applies.

 

Since redcarpet seems to require rebuilding depending on the macOS version, I should integrate the fix into the Workflow.

 

Link to post
24 minutes ago, vitor said:

@xilopaint Are you on Catalina? I’m not and won’t be for a long while (likely ever, considering how buggy and problematic it is), so I won’t be able to debug it for now.

 

Yes. I guess Catalina is frowned upon because of the hard Beta program which was surrounded by a lot of criticism. Yet I haven't  been facing issues since the release of the first stable version, it's been really pretty stable for me.

Edited by xilopaint
Link to post
29 minutes ago, xilopaint said:

I guess Catalina is frowned upon because of the hard Beta program which was surrounded by a lot of criticism.

 

It was not just the beta period. I still find credible reports of issues—in both Catalina and iOS 13—including in first-party apps. On Homebrew Cask, it’s common to have problems reported that happen only in Catalina. Multiple casks required updates because of it. Had the problems been ironed out in the betas (they were not, which is why Apple is making more releases than usual), they wouldn’t have felt the need to revamp their own testing methods for future versions.

 

31 minutes ago, xilopaint said:

Yet I haven't  been facing issues since the release of the first stable version, it's been really pretty stable for me.

 

We’re having this conversation because you reported an issue that is likely to be caused by a mess up in Catalina.

Link to post
  • 3 months later...

Having the same issue on my new iMac (it's got Catalina :(). Wish I knew enough about Ruby to fix it.

 

I guess I'll have to dust off my old Pandoc-based Markdown->BBCode converter I used before you added a proper Markdown parser to this workflow, and add your much nicer styles to it.

Link to post
  • 4 weeks later...

Had a few ideas and did a bit of investigating, and the failure seems to be related to a macOS bug.


Can anyone try running:

/usr/bin/gem install --no-document --install-dir "${HOME}/Desktop/Redcarpet" redcarpet


That should place a Redcarpet directory on your Desktop. Does it? Does it give any errors?

Link to post
6 hours ago, vitor said:

Had a few ideas and did a bit of investigating, and the failure seems to be related to a macOS bug.


Can anyone try running:


/usr/bin/gem install --no-document --install-dir "${HOME}/Desktop/Redcarpet" redcarpet

 


That should place a Redcarpet directory on your Desktop. Does it? Does it give any errors?

 

The latest version of the workflow is working for me on Catalina.

Link to post
8 hours ago, xilopaint said:

The latest version of the workflow is working for me on Catalina.

 

Ah, yes, I forgot to mention that just before that comment I updated the Workflow’s dependencies. Though I was expecting it to still need further fixing for Catalina, but great that it’s working for you! Let’s see if it’s working for @deanishe as well.

Link to post

Yes, it works fine on Catalina for me.

 

Unfortunately, it doesn't work properly with Firefox :(  It adds a bunch of extra line breaks. (IIRC, you added them on purpose to fix the skanky behaviour of the forum editor in Safari & Chrome?)

 

But don't worry about me. I have my own MD -> BBCode converter workflow based on a Pandoc script I found (which I've messed around with to fix the skanky behaviour of the forum editor in Firefox).

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...