Jump to content

External Applescripts stopped working?

Recommended Posts

I have an Alfred workflow that opens an Applescript contained in a script file.  It used to work just fine.  As of today, it seems to have stopped working through Alfred - nothing at all happens when I run it.


This also happens with some scripts that I run from the Alfred command line.  I have "Run applescripts instead of opening" checked, but when I navigate to a script and open it, nothing happens.  Oddly, this happens only for some scripts, while others seem to work.  The scripts all work when I run them from Applescript Editor, or if I save them as applications and run the applications from Alfred.


The only change I've made in the last few days that might affect this is that I upgraded Mountain Lion from 10.8.4 to 10.8.5, and I upgraded to the latest MacBook Air firmware. 


Is anyone else experiencing this problem?


Link to comment

I've confirmed that this has nothing to do with the script - it happens even for a simple script I created that is nothing more than


tell application "Firefox"
end tell


This works when I run it from AppleScript Editor or save it as an application, but it does nothing when I run it in Alfred, whether through file navigation or through a "Launch Apps/Files" workflow action.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...