Jump to content
rice.shawn

Packal: Workflow and Theme Repository

Recommended Posts

We've been through this in detail before. And by that, I mean you asked exactly the same question and got a detailed answer.

 

my answer to any objections will always be the same - do you want to have workflows from ordinary Alfred users? Then move your lazy bones and/or do not create some water-tight community of Packals.

Water is wet, the sky is blue. Pointing out the obvious doesn't make it any easier to actually do it.

 

End of story.

Does that mean you won't post this exact same thing a third time?

Share this post


Link to post

Is something messed up with Packal's rss? I am subscribed to new workflows (via feedly) and find I am seeing the same post over and over, like 3-4 times a day.

Share this post


Link to post

Hello, 

I get this error when I try to update packages (Alfred 3). Any ideas about what the problem could be?

Starting debug for 'Packal Updater'

[2016-06-02 08:09:02][ERROR: input.scriptfilter] JSON error: JSON text did not start with array or object and option to allow fragments not set. in JSON:
Warning: simplexml_load_file(): ../user.workflow.D56D8375-D054-4975-BEEB-35F2134FB4DD/packal/package.xml:3: parser error : xmlParseEntityRef: no name in /Users/sdaza/Dropbox/Alfred/Alfred.alfredpreferences/workflows/user.workflow.0D9B6CF9-3CA9-41B1-8984-4B08D4AA14EB/script.php on line 156

Warning: simplexml_load_file():   <name>Files & Folders</name> in /Users/sdaza/Dropbox/Alfred/Alfred.alfredpreferences/workflows/user.workflow.0D9B6CF9-3CA9-41B1-8984-4B08D4AA14EB/script.php on line 156

Warning: simplexml_load_file():                ^ in /Users/sdaza/Dropbox/Alfred/Alfred.alfredpreferences/workflows/user.workflow.0D9B6CF9-3CA9-41B1-8984-4B08D4AA14EB/script.php on line 156
<?xml version="1.0"?>
<items><item uid="updates" arg="updates" valid="no" autocomplete="update"><arg>updates</arg><title>Updates available</title><subtitle>There are 12 updates pending.</subtitle><icon></icon></item><item arg="manifest-update" valid="yes"><arg>manifest-update</arg><title>The manifest is up to date.</title><subtitle>Last updated over a week ago.</subtitle><icon>assets/icons/task-complete.png</icon></item><item arg="" valid="no"><arg></arg><title>GUI Not Available'</title><subtitle>A GUI to configure and operate this workflow is available if you have OS X 10.9 or 10.10.</subtitle><icon>assets/icons/applications-education-miscellaneous.png</icon></item><item uid="blacklist" arg="blacklist" valid="no" autocomplete="blacklist"><arg>blacklist</arg><title>Manage Blacklist</title><subtitle>Configure which workflows Packal updates</subtitle><icon>assets/icons/flag-black.png</icon></item><item arg="" valid="no"><arg></arg><title>Informational</title><subtitle>There are 595 workflows in the manifest, of which, you have 101 installed, and you wrote 0 of those.</subtitle><icon>assets/icons/help-about.png</icon></item><item arg="setup" valid="no" autocomplete="setup"><arg>setup</arg><title>Configure</title><subtitle>Make this workflow work best for you.</subtitle><icon>assets/icons/applications-system.png</icon></item><item arg="install-cron-script" valid="yes"><arg>install-cron-script</arg><title>Install Alfred Cron Script</title><subtitle>Make Alfred Cron check for updates for you.</subtitle><icon>..//icons/timer.png</icon></item></items>
[2016-06-02 08:09:15][ERROR: input.scriptfilter] JSON error: JSON text did not start with array or object and option to allow fragments not set. in JSON:
Warning: simplexml_load_file(): ../user.workflow.D56D8375-D054-4975-BEEB-35F2134FB4DD/packal/package.xml:3: parser error : xmlParseEntityRef: no name in /Users/sdaza/Dropbox/Alfred/Alfred.alfredpreferences/workflows/user.workflow.0D9B6CF9-3CA9-41B1-8984-4B08D4AA14EB/script.php on line 156

Warning: simplexml_load_file():   <name>Files & Folders</name> in /Users/sdaza/Dropbox/Alfred/Alfred.alfredpreferences/workflows/user.workflow.0D9B6CF9-3CA9-41B1-8984-4B08D4AA14EB/script.php on line 156

Warning: simplexml_load_file():                ^ in /Users/sdaza/Dropbox/Alfred/Alfred.alfredpreferences/workflows/user.workflow.0D9B6CF9-3CA9-41B1-8984-4B08D4AA14EB/script.php on line 156
<?xml version="1.0"?>
<items><item uid="updates" arg="updates" valid="no" autocomplete="update"><arg>updates</arg><title>Updates available</title><subtitle>There are 12 updates pending.</subtitle><icon></icon></item><item arg="manifest-update" valid="yes"><arg>manifest-update</arg><title>The manifest is up to date.</title><subtitle>Last updated over a week ago.</subtitle><icon>assets/icons/task-complete.png</icon></item><item arg="" valid="no"><arg></arg><title>GUI Not Available'</title><subtitle>A GUI to configure and operate this workflow is available if you have OS X 10.9 or 10.10.</subtitle><icon>assets/icons/applications-education-miscellaneous.png</icon></item><item uid="blacklist" arg="blacklist" valid="no" autocomplete="blacklist"><arg>blacklist</arg><title>Manage Blacklist</title><subtitle>Configure which workflows Packal updates</subtitle><icon>assets/icons/flag-black.png</icon></item><item arg="" valid="no"><arg></arg><title>Informational</title><subtitle>There are 595 workflows in the manifest, of which, you have 101 installed, and you wrote 0 of those.</subtitle><icon>assets/icons/help-about.png</icon></item><item arg="setup" valid="no" autocomplete="setup"><arg>setup</arg><title>Configure</title><subtitle>Make this workflow work best for you.</subtitle><icon>assets/icons/applications-system.png</icon></item><item arg="install-cron-script" valid="yes"><arg>install-cron-script</arg><title>Install Alfred Cron Script</title><subtitle>Make Alfred Cron check for updates for you.</subtitle><icon>..//icons/timer.png</icon></item></items>
Edited by Sebastian Daza

Share this post


Link to post

Yo. That & there in <name>Files & Folders</name> is illegal XML.

 

Yep. I figured that's what it was. Amazing that this particular escaping issue hasn't come up until now, especially since it's been there since Sept 15.

Edited by Shawn Rice

Share this post


Link to post

Is there a way we can manually fix the XML for Alfred 3?

 

Invalid XML is invalid XML. It won't work with any software that requires valid input. If you want to massage it by hand, replace & with & (the XML escape for &), but the file will probably get overwritten by the software fairly soon.

Edited by deanishe

Share this post


Link to post
33 minutes ago, megaroeny said:

How can we submit a theme with Alfred 3 now? It's not accepting my URL: https://www.alfredapp.com/extras/theme/5SA1cvo4ej/. Thanks

 

That's the wrong type of URL.

 

If you read the instructions on Packal, it says right below the URL field that you enter the alfred:// URL. That is to say, this one:

alfred://theme/?t=eyJhbGZyZWR0aGVtZSI6eyJyZXN1bHQiOnsidGV4dFNwYWNpbmciOjgsInN1YnRleHQiOnsic2l6ZSI6MTEsImNvbG9yU2VsZWN0ZWQiOiIjQjBCRUM2RkYiLCJmb250IjoiU3lzdGVtIExpZ2h0IiwiY29sb3IiOiIjRUNFRkYyMzUifSwic2hvcnRjdXQiOnsic2l6ZSI6MTYsImNvbG9yU2VsZWN0ZWQiOiIjNzU3NTc1Q0UiLCJmb250IjoiU3lzdGVtIExpZ2h0IiwiY29sb3IiOiIjQTRBNEE0OUIifSwiYmFja2dyb3VuZFNlbGVjdGVkIjoiI0VDRUZGMjAwIiwidGV4dCI6eyJzaXplIjoxNiwiY29sb3JTZWxlY3RlZCI6IiNFQ0VGRjJGRiIsImZvbnQiOiJTeXN0ZW0iLCJjb2xvciI6IiNFQ0VGRjI2NiJ9LCJpY29uUGFkZGluZ0hvcml6b250YWwiOjUsInBhZGRpbmdWZXJ0aWNhbCI6OCwiaWNvblNpemUiOjQwfSwic2VhcmNoIjp7InBhZGRpbmdWZXJ0aWNhbCI6MiwiYmFja2dyb3VuZCI6IiMzNjQ2NEZGRiIsInNwYWNpbmciOjE2LCJ0ZXh0Ijp7InNpemUiOjM2LCJjb2xvclNlbGVjdGVkIjoiIzAwMDAwMEZGIiwiZm9udCI6IlN5c3RlbSBMaWdodCIsImNvbG9yIjoiI0VDRUZGMkZGIn0sImJhY2tncm91bmRTZWxlY3RlZCI6IiNGRkJBQjhGRiJ9LCJ3aW5kb3ciOnsiY29sb3IiOiIjMjUzMTM4RkYiLCJwYWRkaW5nSG9yaXpvbnRhbCI6MTYsIndpZHRoIjo1NjAsImJvcmRlclBhZGRpbmciOjEwLCJib3JkZXJDb2xvciI6IiMyNjMyMzkwMCIsImJsdXIiOjAsInJvdW5kbmVzcyI6MiwicGFkZGluZ1ZlcnRpY2FsIjoxNn0sImNyZWRpdCI6IlJlb255IFRvbm5leWNrIiwic2VwYXJhdG9yIjp7ImNvbG9yIjoiI0ZGRkZGRjAwIiwidGhpY2tuZXNzIjoxfSwic2Nyb2xsYmFyIjp7ImNvbG9yIjoiI0VDRUZGMjI2IiwidGhpY2tuZXNzIjoyfSwibmFtZSI6Ik1hdGVyaWFsIERlc2lnbiAoRGFyaykifX0=

 

Share this post


Link to post
20 minutes ago, deanishe said:

 

That's the wrong type of URL.

 

If you read the instructions on Packal, it says right below the URL field that you enter the alfred:// URL. That is to say, this one:


alfred://theme/?t=eyJhbGZyZWR0aGVtZSI6eyJyZXN1bHQiOnsidGV4dFNwYWNpbmciOjgsInN1YnRleHQiOnsic2l6ZSI6MTEsImNvbG9yU2VsZWN0ZWQiOiIjQjBCRUM2RkYiLCJmb250IjoiU3lzdGVtIExpZ2h0IiwiY29sb3IiOiIjRUNFRkYyMzUifSwic2hvcnRjdXQiOnsic2l6ZSI6MTYsImNvbG9yU2VsZWN0ZWQiOiIjNzU3NTc1Q0UiLCJmb250IjoiU3lzdGVtIExpZ2h0IiwiY29sb3IiOiIjQTRBNEE0OUIifSwiYmFja2dyb3VuZFNlbGVjdGVkIjoiI0VDRUZGMjAwIiwidGV4dCI6eyJzaXplIjoxNiwiY29sb3JTZWxlY3RlZCI6IiNFQ0VGRjJGRiIsImZvbnQiOiJTeXN0ZW0iLCJjb2xvciI6IiNFQ0VGRjI2NiJ9LCJpY29uUGFkZGluZ0hvcml6b250YWwiOjUsInBhZGRpbmdWZXJ0aWNhbCI6OCwiaWNvblNpemUiOjQwfSwic2VhcmNoIjp7InBhZGRpbmdWZXJ0aWNhbCI6MiwiYmFja2dyb3VuZCI6IiMzNjQ2NEZGRiIsInNwYWNpbmciOjE2LCJ0ZXh0Ijp7InNpemUiOjM2LCJjb2xvclNlbGVjdGVkIjoiIzAwMDAwMEZGIiwiZm9udCI6IlN5c3RlbSBMaWdodCIsImNvbG9yIjoiI0VDRUZGMkZGIn0sImJhY2tncm91bmRTZWxlY3RlZCI6IiNGRkJBQjhGRiJ9LCJ3aW5kb3ciOnsiY29sb3IiOiIjMjUzMTM4RkYiLCJwYWRkaW5nSG9yaXpvbnRhbCI6MTYsIndpZHRoIjo1NjAsImJvcmRlclBhZGRpbmciOjEwLCJib3JkZXJDb2xvciI6IiMyNjMyMzkwMCIsImJsdXIiOjAsInJvdW5kbmVzcyI6MiwicGFkZGluZ1ZlcnRpY2FsIjoxNn0sImNyZWRpdCI6IlJlb255IFRvbm5leWNrIiwic2VwYXJhdG9yIjp7ImNvbG9yIjoiI0ZGRkZGRjAwIiwidGhpY2tuZXNzIjoxfSwic2Nyb2xsYmFyIjp7ImNvbG9yIjoiI0VDRUZGMjI2IiwidGhpY2tuZXNzIjoyfSwibmFtZSI6Ik1hdGVyaWFsIERlc2lnbiAoRGFyaykifX0=

 

Yes I saw that, but thought the instructions were outdated... didn't see the alfred:// anywhere. I get it now! Had to hover on the Open theme in Alfred 3 button. Thanks!

Edited by megaroeny

Share this post


Link to post

Search is broken in Packal, when I try to search I get the following error:

 

Quote

Fatal error: Class name must be a valid object or a string in /www/sites/packal/includes/common.inc on line 8041

Also, the error page gives more details than it should (stacktrace and file locations), which is a security issue, you may want to look into that.

Share this post


Link to post

I have withdrawn my Alfred PDF Tools workflow from Packal because the upload of its `.alfredworkflow` file didn't complete in many attempts what I think has to do with the file size being larger than the 10 MB limit.

 

So I dug into the issue and found out this post by @rice.shawn where he points out:

 

Quote

The reason why it's hard to distribute workflows >10MB is because Github doesn't accept unrecognized filetypes >10MB (Packal uses GH as a backend, so it rejects everything over that)

 

Well, it's not the case of the latest release of my Alfred PDF Tools workflow in GitHub. As you can see it's a 11.3 MB `.alfredworkflow` file. I really would like adding my workflow to Packal again since many people find workflows on that database.

Edited by xilopaint

Share this post


Link to post

That's GitHub releases. The 10MB limit applies to files in the repo, which is where Packal stores its workflows.

 

Shawn and I figured out the limit together one night a few years ago. My memory is a bit hazy, but IIRC, the .alfredworkflow extension was also a factor: you could successfully download .zip files larger than 10MB from a repo, but not .alfredworkflow files (even though they are ZIP files, too).

 

It's also possible that the size limit has since been increased.

 

EDIT: I just realised that Shawn mentioned the whole unrecognised file business in the post you linked.

Edited by deanishe

Share this post


Link to post

The same file is in the repo.

 

According to GitHub Help page "Files that you add to a repository via a browser are limited to 25 MB per file. You can add larger files, up to 100 MB each, via the command line."

Edited by xilopaint

Share this post


Link to post

Again IIRC, it wasn't the uploading the files that was the problem, it was downloading them via "raw" HTTP links (i.e. not using git, but rather grabbing a file via the GitHub website and a raw.githubusercontent.com URL). It just didn't work with .alfredworkflow files >10MB.

 

I just tried to download your workflow directly from the repo, and it worked fine. It didn't when Packal was created, however.

 

At this point in time, I think it's unlikely that Shawn will increase the limit. Let me see if I can make your workflow a bit smaller…

Edited by deanishe

Share this post


Link to post
10 minutes ago, deanishe said:

Let me see if I can make your workflow a bit smaller…

 

No chance. As the k2pdfopt executable is already compressed, jacking up the zip compression to maximum only save a few hundred kB vs no compression at all. I thought deleting the .pyc files might help, but they're tiny, too, compared to k2pdfopt.

Share this post


Link to post

Yes. I know it works (as mentioned above, I already tried it).

 

But 10MB was the limit when Packal was built and Packal isn't being worked on anymore.

 

Even if Shawn could theoretically tweak a single setting to increase the limit, you don't mess with an important system unless you also have the time to fix it if you accidentally break it. I believe Shawn simply doesn't have that time at the moment.

 

That is to say, I'm 90% sure we're stuck with the 10MB limit.

 

Edited by deanishe

Share this post


Link to post

I have also read that one can get timeout issues while uploading workflows to Packal. Is there a possibility that I can't upload the .alfredworkflow file because of my slow internet connection (just 10 Mbit/s) and I am just timing out? I tell this because I have to wait some time until I can see the file was not uploaded. I mean that I don't get any instant warning saying the file can't be uploaded because of its size, I really have to wait some time as the upload seems in process until I can see it's not actually done and Packal doesn't return any reason.

Edited by xilopaint

Share this post


Link to post

I have absolutely no idea about that, I'm afraid. That depends entirely on how Shawn has the timeouts in nginx and PHP set up, which is information I don't have.

 

AFAIK, unless you're using new-fangled JavaScript to verify filesize before upload, size limits are enforced by PHP (or your webserver) simply refusing to accept more data once the limit is reached. So it will accept your upload, regardless of size, but throw an error the second the amount of data uploaded exceeds the maximum limit.

 

10 Mbit/s is not a slow connection. You should be able to upload your workflow in well under 20 seconds at that speed, and I'd be extremely surprised if Shawn had set a timeout below 30 seconds (which is PHP's default, AFAIK. No idea what nginx's default timeouts are.)

 

How long does the upload proceed until you get an error? My guess would be that Packal is throwing an error when your uploaded data exceeds 10MB, not because it's hitting a time limit.

 

Edited by deanishe

Share this post


Link to post
57 minutes ago, deanishe said:

10 Mbit/s is not a slow connection. You should be able to upload your workflow in well under 20 seconds at that speed, and I'd be extremely surprised if Shawn had set a timeout below 30 seconds (which is PHP's default, AFAIK. No idea what nginx's default timeouts are.)

 

How long does the upload proceed until you get an error? My guess would be that Packal is throwing an error when your uploaded data exceeds 10MB, not because it's hitting a time limit.

 

 

Well, I am from Brazil and you live in Germany. Here is widespread that our connection speed (as almost everything else) is generally crap and yours is great, so that was an assumption I made.

 

Until now I hadn't got any error message but I just tried to upload the file again and I finally got this dialog with a message:

 

cE4VuhJ.png

 

So it seems clear that the problem is the file size.

Share this post


Link to post
36 minutes ago, xilopaint said:

Here is widespread that our connection speed (as almost everything else) is generally crap and yours is great, so that was an assumption I made.

 

German internet isn't amazingly fast or anything. It doesn't get much over 10 Mbit/s up. My connection is 50/16 Mbit/s, but if I wanted to get 100 down, I'd have to drop to 8 up 'cos nobody offers fast up and down (at least where I live, which is in the middle of a big city).

 

As regards almost everything else being crap, I'd love to make a comment involving the numbers 7 and 1, but I only live in Germany and am actually English, so …

 

pricelessbanner_2956561b.jpg.3c5927d5ee7abb60c4d9aa66a1db7325.jpg 

Edited by deanishe

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...