Jump to content
palobo

Mail Actions Workflow [Updated v0.7]

Recommended Posts

I can't make it work on my machine. It just says "Generation Mailbox list" forever:

 

Screen%20Shot%202013-03-25%20at%2010.51.

Hi Vaff,

 

Do you have a very large list of mailboxes? If you right click on the workflow and choose to show in finder, there should be an error log. Does this have anything there?

Share this post


Link to post

I'm having the exact same problem ("Generating Mailbox List" forever), with about 300 mailboxes in three accounts.  If I look at ~/Library/Application Support/Alfred 2/Workflow Data/com.palobo.mailactions/mbCache.plist , it looks like it has a complete list of mailboxes and accounts.  But the "Generating Mailbox List" message doesn't go away, and I can't actually execute any actions.

Edited by dfay

Share this post


Link to post

I'm having the exact same problem ("Generating Mailbox List" forever), with about 300 mailboxes in three accounts.  If I look at ~/Library/Application Support/Alfred 2/Workflow Data/com.palobo.mailactions/mbCache.plist , it looks like it has a complete list of mailboxes and accounts.  But the "Generating Mailbox List" message doesn't go away, and I can't actually execute any actions.

WOW, that's an extreme case there. Since this workflow is all AppleScript, speed isn't that great unfortunately. I'll have a look as to how and what I can do to improve upon that and if you don't mind, I'll hound you for beta testing ;) since I have nowhere near that amount of mailboxes.

Share this post


Link to post

Hi Pedro,

 

Your workflow looks fantastic, but I also have the same problem (generating mailbox list" that does not go away). Yet, I don't have more that 100 mailboxes. When I look at the error as you suggested earlier, it says : 

 

 

2013-04-03 15:10:38.234 osascript[9871:707] Error loading /Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types:  dlopen(/Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types, 262): no suitable image found.  Did find:
/Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types: no matching architecture in universal wrapper
osascript: OpenScripting.framework - scripting addition "/Library/ScriptingAdditions/Adobe Unit Types.osax" declares no loadable handlers.
 
Any idea ?
 
Thank you again.
 
Edwin.

Share this post


Link to post

Hi Pedro,

 

Your workflow looks fantastic, but I also have the same problem (generating mailbox list" that does not go away). Yet, I don't have more that 100 mailboxes. When I look at the error as you suggested earlier, it says : 

 

 

2013-04-03 15:10:38.234 osascript[9871:707] Error loading /Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types:  dlopen(/Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types, 262): no suitable image found.  Did find:
/Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types: no matching architecture in universal wrapper
osascript: OpenScripting.framework - scripting addition "/Library/ScriptingAdditions/Adobe Unit Types.osax" declares no loadable handlers.
 
Any idea ?
 
Thank you again.
 
Edwin.

 

Hi Edwin, 

 

Seems as though you have some sort of trouble with a Scrippting addition. Could you try something simple for me please so we can test to see if it bugs out with a simple script too.

 

1. Open AppleScript Editor and write this small script:

 

 

on run argv
tell application "AppleScript Runner"
display dialog (item 1 of argv)
end tell
end run

 

 

2. Save that as test.scpt file and then from terminal run:

 

 

osascript test.scpt "hello wolrd"

 

Does that work or do you get a similar error?

Edited by Pedro Lobo

Share this post


Link to post

I'm having the exact same problem ("Generating Mailbox List" forever), with about 300 mailboxes in three accounts.  If I look at ~/Library/Application Support/Alfred 2/Workflow Data/com.palobo.mailactions/mbCache.plist , it looks like it has a complete list of mailboxes and accounts.  But the "Generating Mailbox List" message doesn't go away, and I can't actually execute any actions.

 

Hi dfay,

 

Can you please check your error log as Edwin did. Tell me if there something logged.

 

Cheers,

PL

Share this post


Link to post

Hi again.

 

First, thank you for your prompt answer. I tried your step by step protocole. 

 

In the Terminal window, I have the following message :" osascript: test.scpt: No such file or directory"

 

In the error.log, I have the following message (which looks like the first one) : 2013-04-03 18:10:34.860 osascript[14007:707] Error loading /Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types:  dlopen(/Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types, 262): no suitable image found.  Did find:

/Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types: no matching architecture in universal wrapper
osascript: OpenScripting.framework - scripting addition "/Library/ScriptingAdditions/Adobe Unit Types.osax" declares no loadable handlers.
 
I tried to save the script at different places (desktop, download folder...) but I have the same message.
 
I don't know if this can be useful to you, but I also installed the Evernote 3.5 workflow (by Carlos Alberto Sztoltz) which uses scripts, and it seems to work ok.
 
Thank you again.
 
Best.
 
Edwin.

Share this post


Link to post

Hi dfay,

 

Can you please check your error log as Edwin did. Tell me if there something logged.

 

Cheers,

PL

Thanks for following up.  error.log is Zero bytes and empty.

 

300 mailboxes are probably an artifact of the old days before rapid full-text searching, when anything that wasn't filed could get lost... - just checked and the oldest message is from 1997 :)

Share this post


Link to post

Hi again.

 

First, thank you for your prompt answer. I tried your step by step protocole. 

 

In the Terminal window, I have the following message :" osascript: test.scpt: No such file or directory"

 

In the error.log, I have the following message (which looks like the first one) : 2013-04-03 18:10:34.860 osascript[14007:707] Error loading /Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types:  dlopen(/Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types, 262): no suitable image found.  Did find:

/Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types: no matching architecture in universal wrapper
osascript: OpenScripting.framework - scripting addition "/Library/ScriptingAdditions/Adobe Unit Types.osax" declares no loadable handlers.
 
I tried to save the script at different places (desktop, download folder...) but I have the same message.
 
I don't know if this can be useful to you, but I also installed the Evernote 3.5 workflow (by Carlos Alberto Sztoltz) which uses scripts, and it seems to work ok.
 
Thank you again.
 
Best.
 
Edwin.

I'm a little stressed for time currently, but as soon as possible I'll dissect Carlos' workflow and try figure out what could be wrong. When running the osascript command, don't forget to cd to the directory.

 

If you're uncomfortable with the terminal, then try save the test.scpt on your desktop and type osascript ~/Desktop/test.scpt "hello"

Share this post


Link to post

Thanks for following up.  error.log is Zero bytes and empty.

 

300 mailboxes are probably an artifact of the old days before rapid full-text searching, when anything that wasn't filed could get lost... - just checked and the oldest message is from 1997 :)

WOW, 1997... Speechless :)

 

I'll try and have a look at what could be going wrong here. Like I said, there is much room for improvement in terms of speed, just have to figure out the best way and do it ;)

Share this post


Link to post

I'm a little stressed for time currently, but as soon as possible I'll dissect Carlos' workflow and try figure out what could be wrong. When running the osascript command, don't forget to cd to the directory.

 

If you're uncomfortable with the terminal, then try save the test.scpt on your desktop and type osascript ~/Desktop/test.scpt "hello"

Hi Pedro,

 

Thank you again for your time. You obviously understood that I am far from being comfortable with the terminal !

 

I did what you recommended with the script and saw a dialog box saying Hello ! The terminal says : 2013-04-04 19:32:50.471 osascript[27217:707] Error loading /Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types:  dlopen(/Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types, 262): no suitable image found.  Did find:

/Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types: no matching architecture in universal wrapper
osascript: OpenScripting.framework - scripting addition "/Library/ScriptingAdditions/Adobe Unit Types.osax" declares no loadable handlers.
«class bhit»:OK
 
Best.
 
Edwin

Share this post


Link to post

Hi Pedro,

 

Thank you again for your time. You obviously understood that I am far from being comfortable with the terminal !

 

I did what you recommended with the script and saw a dialog box saying Hello ! The terminal says : 2013-04-04 19:32:50.471 osascript[27217:707] Error loading /Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types:  dlopen(/Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types, 262): no suitable image found.  Did find:

/Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types: no matching architecture in universal wrapper
osascript: OpenScripting.framework - scripting addition "/Library/ScriptingAdditions/Adobe Unit Types.osax" declares no loadable handlers.
«class bhit»:OK
 
Best.
 
Edwin

Thanks Edwin,

 

It's now clear that this may be a similar problem to what plagues dray. I'll be lookng into it as soon as I get a change so hang tight and watch this space. I'll update when I get a more optimal version running.

Share this post


Link to post

Hi Vaff,

 

Do you have a very large list of mailboxes? If you right click on the workflow and choose to show in finder, there should be an error log. Does this have anything there?

Hi Pedro sorry I've been away from the forums for some time :)

I still have the issue, but I have no errors. error.log is being generated, but it's empty. I do have alot of mailboxes ... exactually how many I don't know ... some of them are nested so it's hard to figure out without counting them manually. They span across 2 accounts.

Share this post


Link to post

HI Pedro I have the same product as above would love to use the MoveMessage (mm) but its never worked for me. I did the Applescript and got the window with Hello World and my error.log is empty

Share this post


Link to post

This is one of my favorites workflows and I think Pedro knows it. :)

 

I had some issues too but I changed some lines of the script and got it working here.

 

I wrote Pedro about it.

Share this post


Link to post

Hi Pedro

I've been playing with Mail Act-On a bit, but don't like the interface, so I'm hoping for this workflow....

 

I tried running getList.scpt in Applescript Editor (uncommenting the line ' --set Opt to "bill" ') and the result was correctly formed XML with the relevant matching mailboxes correctly.  And as I mentioned before the file ~/Library/Application Support/Alfred 2/Workflow Data/com.palobo.mailactions/ looks like it has a complete list of my mailboxes.

 

Likewise if I run getUnread.scpt in Applescript Editor.  It returns an XML formatted list of my mailboxes with unread messages successfully, no errors.

 

Also

the minfo script doesn't work for me either.  I get the two options, but selecting either one just dismisses Alfred without anything else happening.

 

Let me know if I can help with anything - hope this helps.

Derick

Share this post


Link to post

Hey everybody,

 

sorry for being a little absent lately, but I've been swamped at work.

 

Carlos-SZ has stepped up though and has made some great improvements. I'll post a link with his corrections ASAP. Please everybody test it and confirm the speed boost. I'll be dedicating some more time to this workflow in the coming weeks, looking to improve a little more and add a few more features.

 

One I've currently got in a test is Envelope Index Vacuum to speed things up a little. Any more ideas please send them my way.

 

Cheers,

PL

Share this post


Link to post

This is one of my favorites workflows and I think Pedro knows it. :)

 

I had some issues too but I changed some lines of the script and got it working here.

 

I wrote Pedro about it.

Much thanks for stepping up when I dropped the ball. Indeed it's much faster for me too. ;)

 

Cheers,

PL

Share this post


Link to post

Updated, please everybody check and see if it now works.

 

Big thanks to Carlos-SZ ;)

Hi Pedro,

 

Thanks for this update. I did a quick test and it seems to work !! 

 

I will have to use your workflow a little bit more before being 100% enthusiastic. I am only 99.9% yet !

 

Thank you again.

 

Edwin.

Share this post


Link to post

Hi Pedro,

 

Thanks for this update. I did a quick test and it seems to work !! 

 

I will have to use your workflow a little bit more before being 100% enthusiastic. I am only 99.9% yet !

 

Thank you again.

 

Edwin.

Hi Edwin,

 

I'm glad to hear it works for you now. all credits for the fix go to Carlos-Sz though ;)

Share this post


Link to post

Hi Pedro.

 

I have now used your workflow during the last couple of days and here are three comments:

1-It is VERY useful and I used it with a great pleasure.

2-It is a little bit too slow. (I think that I could go sometimes faster using the mouse)

3-It would be great if the last mailbox found would appear again when Alfred is call again. This could save time.

 

I hope that this is clear (and useful).

 

Thank you again.

 

Best.

 

Ed. 

Share this post


Link to post

Hi Pedro.

 

I have now used your workflow during the last couple of days and here are three comments:

1-It is VERY useful and I used it with a great pleasure.

2-It is a little bit too slow. (I think that I could go sometimes faster using the mouse)

3-It would be great if the last mailbox found would appear again when Alfred is call again. This could save time.

 

I hope that this is clear (and useful).

 

Thank you again.

 

Best.

 

Ed. 

Hi Edwin

 

Thanks for your comments. A few of the improvements I want to work on are:

 

  1. SPEED!!! Carlos-Sz has made some great strides in this but I still think it can get better;
  2. History, I'm thinking of maybe having it remember the last 3-5 maiboxes that were used. That way you could summon it up and action the results with ⌘+1-5. If however you start typing then it will filter mailboxes;
  3. Favourites, maybe rather than history I could implement a favourites for quick access, though I think history will be more useful;
  4. Other features such as export to evernote, create a task in TaskPaper, Things etc. this one I'm still not sure should go into MailActions or separate workflows as I have it now.

Any ideas are very much welcome.

 

Cheers,

PL

Share this post


Link to post

This update has fixed my problem - it gives me the full list of mailboxes.  Thanks for continued work on this.  I think the improvements you propose are right on track.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...