Jump to content
dnk

eject commands not working

Recommended Posts

Has anyone run into the issue that when issuing the eject command (located in "system" under "features") that they just never show even though they are enabled? I have 3 drives mounted, but the eject command is just not showing at all.

Share this post


Link to post

Has anyone run into the issue that when issuing the eject command (located in "system" under "features") that they just never show even though they are enabled? I have 3 drives mounted, but the eject command is just not showing at all.

 

Try changing the eject scope to "Local Mounted Volumes" instead of "Removable Media" under the Eject prefs. It may just be that the drives you have mounted are not treated as ejectable by OS X.

 

Cheers,

Andrew

Share this post


Link to post

I have the same problem.  The "eject" command is not recognised at all and instead displays the default "Search Google for 'eject'" response.  The "eject" command is enabled in "Features > System" and I have tried all three eject scopes.

 

Screenshot%202014-02-09%2010.23.16.png

 

Screenshot%202014-02-09%2010.25.54.png

 

I'm using the latest build of Alfred [v2.1.1 (227)] on Mavericks 10.9.1.

Share this post


Link to post

I have the same problem.  The "eject" command is not recognised at all and instead displays the default "Search Google for 'eject'" response.  The "eject" command is enabled in "Features > System" and I have tried all three eject scopes.

 

I'm using the latest build of Alfred [v2.1.1 (227)] on Mavericks 10.9.1.

 

What type of drive are you trying to eject? If the two lower options aren't working, try Mounts in /Volumes :)

Share this post


Link to post

Tried all three. :)  None of them are working, I'm afraid.  I'm trying to eject an external USB drive.  The drive shows up in Disk Utility as ejectable.

 

The thing that surprises me the most is not that it is not able to eject the drive, but that Alfred does not seem to recognise the "eject" command at all.  It is the same when I enable the "ejectall" command--that command is not recognised either.  I even tried changing the "eject" command to some other string, but that is not working either.

 

Just to add--this is the first time I have tried the "eject" command.  I had not been using it so far, so it is not something that used to work and suddenly stopped working.

Share this post


Link to post

Tried all three. :)  None of them are working, I'm afraid.  I'm trying to eject an external USB drive.  The drive shows up in Disk Utility as ejectable.

 

The thing that surprises me the most is not that it is not able to eject the drive, but that Alfred does not seem to recognise the "eject" command at all.  It is the same when I enable the "ejectall" command--that command is not recognised either.  I even tried changing the "eject" command to some other string, but that is not working either.

 

Just to add--this is the first time I have tried the "eject" command.  I had not been using it so far, so it is not something that used to work and suddenly stopped working.

These are all the exact same symptoms I am having. All I am trying to do is eject USB drives. It used to work fine on my system (Mavericks) up until I did a fresh reload. And now it no longer works.

Share this post


Link to post

I'm quite embarrassed. Disk Utility did show the disk as ejectable, but it turns out the disk had already been unmounted--by Carbon Copy Cloner after it had finished its backup. Was confused by the fact that the "Eject" button was not greyed out in "Disk Utility", and because the light on the USB drive was on, but I found that there was no mount under /Volumes.  With the drive explicitly mounted, I can see both the "Eject" and "Eject All" commands in Alfred.

 

"Removable Media" still does not show this, but an eject scope of "Local Mounted Volumes" works perfectly.

 

Sorry about the false alarm.  And thanks for Alfred.  It is easily my favourite piece of software on my Mac. :)

Share this post


Link to post

I'm quite embarrassed. Disk Utility did show the disk as ejectable, but it turns out the disk had already been unmounted--by Carbon Copy Cloner after it had finished its backup. Was confused by the fact that the "Eject" button was not greyed out in "Disk Utility", and because the light on the USB drive was on, but I found that there was no mount under /Volumes.  With the drive explicitly mounted, I can see both the "Eject" and "Eject All" commands in Alfred.

 

"Removable Media" still does not show this, but an eject scope of "Local Mounted Volumes" works perfectly.

 

Sorry about the false alarm.  And thanks for Alfred.  It is easily my favourite piece of software on my Mac. :)

 

Glad you were able to work it out and thanks for reporting back :)

Share this post


Link to post

Still, if no removable media was mounted one expect the 'eject' command to show up with a 'nothing to eject' instead of getting the default google search list.

Share this post


Link to post

I'm not sure what the proper etiquette is here, some forums are rather sensitive about thread highjacking, so apologies in advance. My problem is similar enough to original post that continuing the discussion here seems easiest.

 

I'm seeing similar issues in both Alfred 2.4 (279) and 2.5 (295) beta. It appears the detect removable volumes logic isn't working or I don't understand the intent (small thumbdrives only perhaps?).

 

One or more USB drives attached and mounted. Displayed in Finder sidebar as ejectable. Alfred eject command finds no volumes and fallback to files/folders/etc with eject with "Removable Media" selected in the system eject command preference.

 

Changing eject scope to "Local Volumes" will work but lists non-system internal volumes  which is not ideal. I would prefer this be spouse proof and my wife would be lost if she accidentally ejected her internal Data SSD.

 

Is the feature "working as designed" and I need a workflow for my use case? 

 

Thanks.

Share this post


Link to post

I'm not sure what the proper etiquette is here, some forums are rather sensitive about thread highjacking, so apologies in advance. My problem is similar enough to original post that continuing the discussion here seems easiest.

 

I'm seeing similar issues in both Alfred 2.4 (279) and 2.5 (295) beta. It appears the detect removable volumes logic isn't working or I don't understand the intent (small thumbdrives only perhaps?).

 

One or more USB drives attached and mounted. Displayed in Finder sidebar as ejectable. Alfred eject command finds no volumes and fallback to files/folders/etc with eject with "Removable Media" selected in the system eject command preference.

 

Changing eject scope to "Local Volumes" will work but lists non-system internal volumes  which is not ideal. I would prefer this be spouse proof and my wife would be lost if she accidentally ejected her internal Data SSD.

 

Is the feature "working as designed" and I need a workflow for my use case? 

 

Thanks.

 

You can add drives to the "Blacklist" to avoid them showing up in the list of ejectable drives, to avoid exactly the issue you're describing. 

 

Under Features > System, you'll see a Blacklist box on the right. Add drives by exact names and those will no longer appear as ejectable to avoid mistakes :)

Share this post


Link to post

Did some quick testing and it appears the Removable Media setting is designed for thumbsticks and not USB hard drives. Also selecting the non-system internal drive produces an error dialog that the volume is busy. While not elegant it may meet the WAF (wife acceptance factor). 

Share this post


Link to post

You can add drives to the "Blacklist" to avoid them showing up in the list of ejectable drives, to avoid exactly the issue you're describing. 

 

Under Features > System, you'll see a Blacklist box on the right. Add drives by exact names and those will no longer appear as ejectable to avoid mistakes :)

 

DOH! I looked right at that and then forgot all about it as I focused on my expected behavior of the Removable Media vs Local Volumes.

 

Thanks.

 

I knew I needed more coffee today.

Edited by mmcduffie

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...