Jump to content

Smart Quotes should be turned off for Terminal Command dialog in Workflow [Fixed 2.3 b262]


patimen
 Share

Recommended Posts

1. Create a new Workflow

2. Add a new Terminal Command

3. Type quotes in the dialog box for the script

 

RESULT:

The quotes ("") are made into smart quotes, if your system is set to use them. Bash does not like smart quotes, and your script will fail.

EXPECTED: 

This dialog should disable smart quotes, dashes and the like, as they are not appropriate for Bash scripts.

 

Alfred Version: 2.2

OS X Version: 10.9.2

Link to comment
Share on other sites

1. Create a new Workflow

2. Add a new Terminal Command

3. Type quotes in the dialog box for the script

 

RESULT:

The quotes ("") are made into smart quotes, if your system is set to use them. Bash does not like smart quotes, and your script will fail.

EXPECTED: 

This dialog should disable smart quotes, dashes and the like, as they are not appropriate for Bash scripts.

 

Alfred Version: 2.2

OS X Version: 10.9.2

 

Ah yep, I see this! I'll get this fixed in 2.3, cheers! :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...