Jump to content

Contacts - "Use spotlight data" not working for Email to


mikedvzo
 Share

Recommended Posts

When I use the file "Email to" option I am seeing duplicate contacts because it is displaying my Exchange contacts as well as my iCloud Contacts.  I have solved the problem for my Contact workflow and default results in Alfred by enabling the option under contacts to "Use Spotlight metadata for searching Contacts" and excluding the Exchange Contacts directory from Spotlight.

 

 I do this because I duplicate my contacts for Exchange in iCloud since syncing between and iPhone with pictures and fields works much better with iCloud than Exchange.  The only reason I even have Exchange Contacts enabled under the Exchange account is so that I can gain access to my Global Corporate Directory in Contacts and Mail.  In addition I need contacts in Exchange for when I use Outlook on rare occasions.  

 

I would think that the option I have selected would apply to all of Alfred results including the "Email to" option and not just the default search results.  

 

 

Link to comment
Share on other sites

When I use the file "Email to" option I am seeing duplicate contacts because it is displaying my Exchange contacts as well as my iCloud Contacts.  I have solved the problem for my Contact workflow and default results in Alfred by enabling the option under contacts to "Use Spotlight metadata for searching Contacts" and excluding the Exchange Contacts directory from Spotlight.

 

 I do this because I duplicate my contacts for Exchange in iCloud since syncing between and iPhone with pictures and fields works much better with iCloud than Exchange.  The only reason I even have Exchange Contacts enabled under the Exchange account is so that I can gain access to my Global Corporate Directory in Contacts and Mail.  In addition I need contacts in Exchange for when I use Outlook on rare occasions.  

 

I would think that the option I have selected would apply to all of Alfred results including the "Email to" option and not just the default search results.  

 

You are indeed correct, it looks like the email keyword doesn't respect this option. I've added a ticket to look into this for a future release, but for now, just ignore the email keyword... type a user's name to open the contact viewer, then just press return on the email address to email them.

 

Cheers,

Andrew

Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...