Jump to content

Different result running applescript in Alfred than in Applescript Editor

Recommended Posts

If I run the script below in Applescript Editor when VLC is not running, nothing happens, this is the result that I expect.


However when I run the same script as part of a workflow in Alfred, VLC Launches.


Any suggestions as to why the result is different in the two applications and what I need to do to get the desired result in Alfred?

--set q to "{query}"
set q to 300
set vlcrunning to ""

tell application "System Events"
if (get name of processes) contains "VLC" then
set vlcrunning to true
end if
end tell

if vlcrunning is true then
tell application "VLC"
--set audio volume to 512
set audio volume to q
end tell
end if

Thanks in advance for your help.



Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...