Jump to content
jmjeong

alfred-pinboard version2.3 (alfred3 support)

Recommended Posts

Thank you for a wonderful workflow!

On Pinboard, "tags are not case-sensitive, but they will display the way you entered them". Yet, your workflow seems to be case-sensitive (differentiating results for my bookmarks tagged 'Reference' from those tagged 'reference'. Is there a way to restore the Pinboard default setting?

Thank you very much!

Share this post


Link to post

Thank you for a wonderful workflow!

On Pinboard, "tags are not case-sensitive, but they will display the way you entered them". Yet, your workflow seems to be case-sensitive (differentiating results for my bookmarks tagged 'Reference' from those tagged 'reference'. Is there a way to restore the Pinboard default setting?

Thank you very much!

 

All search of alfred-pinboard is case-insensitive. I tested it just ago, but I can't find any problem. Could you test again?

Share this post


Link to post

Thanks for the fast reply! I should have been more precise. A picture is worth a thousand words: 

 

https://www.dropbox.com/s/t600649i0drhzbi/Screenshot%202015-02-12%2010.14.41.png?dl=0

 

 

Because alfred-pinboard search is case-insensitive, 'Reference', 'reference', and 'reference-data' are searched. 

 

If it it case-sensitive, only 'Reference' will be searched. May I miss something?

 

p.s. Do you want that 'Reference' and 'reference' category are merged in one category?

Edited by jmjeong

Share this post


Link to post

After all, it appears that both Reference and reference are searched, whichever of the two I select, so workflow works as it should. Sorry for the false alarm, I was confused by Reference and reference appearing as separate entries. It would indeed be great if they could be merged in one, but it's not important as long as both are searched. Thank you once again!

Share this post


Link to post

I installed this excellent workflow in a second account on my Mac today and had problems getting it working. The pbauth command wasn't working. After looking at the debug console for the workflow I noticed that the workflow was trying to write to the file '/private/var/tmp/alfred.pinboard.log' and was getting "Permission Denied". After changing permissions on that file to rw-rw-rw- (666) I was able to get pbauth to work from the second user account.

 

You may want to create that file with these permissions, if possible, to avoid this problem.

Share this post


Link to post

I installed this excellent workflow in a second account on my Mac today and had problems getting it working. The pbauth command wasn't working. After looking at the debug console for the workflow I noticed that the workflow was trying to write to the file '/private/var/tmp/alfred.pinboard.log' and was getting "Permission Denied". After changing permissions on that file to rw-rw-rw- (666) I was able to get pbauth to work from the second user account.

 

You may want to create that file with these permissions, if possible, to avoid this problem.

 

 

Thank you for the reporting. This log is for debugging in development and may be excluded in release version.

 

'/var/tmp/alfred.pinboard.log' is used for debug log. In your case, there seems be symbolic link in this directory. 

 

---

 

<2015-08-05 Wed> I encountered this problem in my new MacBook Air. I have released v2.27 version to fix this problem. 

Edited by jmjeong

Share this post


Link to post

First: Thank you for this awesome workflow! 

 

I have two little questions:

- Is it possible to add Vivaldi to the supported browsers?

and 

- pset browser don`t work for me. Have tried to reinstall the entire workflow, but without any changes.

 

Cheers, 
 

Alex 

Share this post


Link to post

First: Thank you for this awesome workflow! 

 

I have two little questions:

- Is it possible to add Vivaldi to the supported browsers?

and 

- pset browser don`t work for me. Have tried to reinstall the entire workflow, but without any changes.

 

Cheers, 
 

Alex 

 

I am afraid but you seem to post this comment to the wrong topic.  alfred-pinboard do not have 'pset' command.

Share this post


Link to post

I'm having issues getting the workflow to work correctly. I've entered my api key, but I'm getting the following output in the debug log when trying to reload the bookmarks.

[2016-07-30 14:46:16][ERROR: action.script] Traceback (most recent call last):
  File "reload.py", line 67, in <module>
    notes_server = note_list_server(user,token)
  File "reload.py", line 32, in note_list_server
    return json.load(data)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/json/__init__.py", line 290, in load
    **kw)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/json/__init__.py", line 338, in loads
    return _default_decoder.decode(s)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/json/decoder.py", line 366, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/json/decoder.py", line 384, in raw_decode
    raise ValueError("No JSON object could be decoded")
ValueError: No JSON object could be decoded
[2016-07-30 14:46:16][action.script] Processing output of 'output.notification' with arg ''

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...