Jump to content

Recommended Posts

Shawn,

 

Many thanks for the guidance,

 

Best,

 

 

Yep. I grabbed the idea from Cheaters. It's actually an Automator application with a single action that is something like view web page in pop-up.

Just open the application in Automator, and you can see how to alter it.

A few notes: usually the action is follows some sort of "specify a URL" that uses the URL as a variable. The viewer one that I created doesn't have that, but, instead it opens the viewer with a terminal command that specifies the URL.

If you want to serve code locally and use something dynamic (PHP, Rails, Python), then the file to open needs to be in your webserver root. For this workflow, I'm launching a PHP test server that's part of PHP 5.4 and pointing the URL to that (and killing the webserver after a certain time of idleness). You can look more into the code to see how I do that.

 

Share this post


Link to post

Has it been telling you to do that for long or just a couple of minutes? And when did you last update the manifest?

 

The reason for the first question is that the manifest gets "healed" on the server about once an hour, and that problem happens when a workflow author submits an update on Packal without updating the `version` number itself the first time and then goes back to change it.

 

Try to force-update the manifest, and let me know if the problem is still there.

Share this post


Link to post

Okay, good. For now that problem will appear randomly but go away within not too much time.

 

I can't remember exactly what I meant for "up-to-date" in the workflow. It's either that it has been updated within the last seven days or 24 hours (I remember switching it back and forth). For future reference, the easiest way to update the manifest is from the GUI. Just open that thing and press "(update)" next to the message that indicates when the manifest was last updated.

 

If that doesn't work, then there are some more forceful instructions written up about 1.5 to .5 pages back in this thread that involve opening up the internals of the workflow and forcing an update from the command line.

 

Glad it fixed itself.

Share this post


Link to post

I can't update any workflow, get always this error on a Mac and Mac Book.

 

packal%20error.png

 

 I use the newest Mavericks, Alfred and Packal Version. Also deleted once the Alfred Bundler. Any suggestions?

Thanks!
Edited by Davide

Share this post


Link to post

@Davide: Can you do me a favor to grab some more error information?

 

Follow these steps:

 

1) Open the workflow folder in Terminal (or iTerm).

  a ) to find the workflow folder, open Alfred's Preferences; select `Packal Updater`; ctl+click -> show in finder

  b ) grab that crazy looking directory path, and `cd` to it

2) Type this command from the workflow root:

php cli/packal.php doUpdate com.targumanu.imdbsearch

There is a chance that it'll say :

Error: Cannot verify signature for imdb_search.alfredworkflow from com.targumanu.imdbsearch.

If that's the case, then I'll at least be able to verify the bug. Then I'll just have to track down whether or not it comes from the server, a post-processing script, or the client side. But it gives me a much better place to look.

 

 

Edit: why did this change an outline item into an emoticon?

Edit: forgot the cli/ part of the path

Edited by Shawn Rice

Share this post


Link to post

Hi Shawn,

thanks for your help. Terminal tells me 

Davides-Mac-mini:~ Davides_Mac$ cd /Users/Davides_Mac/ownCloud/Apps/Alfred/Alfred.alfredpreferences/workflows/user.workflow.61A33C75-A8B1-49E6-9BBF-04F8798BB2A3 
Davides-Mac-mini:user.workflow.61A33C75-A8B1-49E6-9BBF-04F8798BB2A3 Davides_Mac$ php packal.php doUpdate com.targumanu.imdbsearch
Could not open input file: packal.php

Could the problem be that I sync the Alfred preferences on a "own cloud" server?

Share this post


Link to post

I've been getting the same update error recently.

 

I just followed your diagnostics instructions and got the following message:

Error: Cannot verify signature for pocket-for-alfred.alfredworkflow from com.fniephaus.pocket.

(I'm on Yosemite public beta)

Share this post


Link to post

Quick apology: I know what the bug is, but I need to get my head back into the codebase before I can take care of it.

 

Right now, I'm bogged down in finishing the new version of the bundler (which will also make this workflow more stable and faster and better), and so I'm living in that API that we've created and jumping between Bash, PHP, and Ruby, so my head is in a weird space. I'll fix this soon.

Share this post


Link to post

Okay, this should have been fixed. Let me know if it doesn't work now (it seems to be working on my end).

 

Also, I had to re-queue a bunch of workflows to be re-processed, so those will all appear as updates even though they're the same version. Also, if you're a workflow author and are wondering why you just got another confirmation email from Packal about a workflow... well, I had to re-queue yours. Apologies.

Share this post


Link to post

I have the latest version of Spotifious workflow and Packal Updater suggests me a downgrade:

 

Image%202014-12-26%20at%201.02.23%20PM.p

 

That was a temporary glitch. Basically, the metadata hadn't caught up to the update notification. The server does a corrective on the metadata every few hours to make sure that it was entered properly; if you happen to look for updates during the middle of that, then it will send out the wrong metadata, so it was actually trying to upgrade you from 0.11.2 => 0.11.2.

 

It's sorted out by now, right?

Share this post


Link to post

Hm. Can you check a few things for me?

 

(1)

 

Open the GUI for the Packal updater and manually update the manifest. Then, select the update menu in that GUI and tell me if the update is still pending. If so, then...

 

(2) Open the workflow preferences and select "Spotifious"; then ctrl+click on it and select "Show in Finder"; then open the "packal" folder, and then open "package.xml" What are the values there for "version" and "updated"?

Share this post


Link to post

The first step fixed the problem. I didn't know this GUI for Packal Updater. Thank you, Shawn!

 

Whew. Glad that worked because that was the easiest fix. The GUI is pretty nice, and it makes it much easier to use the updater if you're like me and have installed way too many workflows.

Share this post


Link to post

Hello,

 

Sorry if this question has been posted before, but how do I make the transition between non packal workflows and packal workflows ?

Do I have to delete all the old ones and redownload them from Packal ?

 

Thanks.

Share this post


Link to post

Hello Shawn,

 

I found that I cannot launch Packal Updater, but I can use the Packal Search workflow. Weird. :(

 

TszWZ8t.png

Anyone can help?

 

Thanks in advance.

Share this post


Link to post

Can you try to launch the Packal "GUI"?

 

Just try that without the "packal setup" and the regular argument "packal" with no subargument. It should be the first option, and it will work as long as you're running either Mavericks or Yosemite.

 

Let me know what happens.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...