Jump to content

File Search has an issue in search chinese name folder


wellsnake
 Share

Recommended Posts

I am a chinese Alfred user,

 

The issue I'm having is that when I search a chinese name folder "上海美吉",  I use '美' to search this folder is succeed,but when I use '美吉' is failed.

 

When I search again it has the same issue.

05af9b4d21b6403a8721df9327ed4fdf.png.cf960411c76673ae7bf13d78d18effb9.png

 

53e7171595704e378f3773196905c0db.png.079fbaa9783f7f85380175671e8e3767.png

The Alfred version & build number is:v2.3(264)

OS X version: 10.9.4 chinese language

Edited by wellsnake
Link to comment
Share on other sites

I am a chinese Alfred user,

 

The issue I'm having is that when I search a chinese name folder "上海美吉",  I use '美' to search this folder is succeed,but when I use '美吉' is failed.

 

When I search again it has the same issue.

 

bug_%E5%B1%8F%E5%B9%95%E5%BF%AB%E7%85%A7

bug_%E5%B1%8F%E5%B9%95%E5%BF%AB%E7%85%A7

The Alfred version & build number is:v2.3(264)

OS X version: 10.9.4 chinese language

 

Hi there,

 

Alfred uses word boundaries when searching for folders / files and how word boundaries are treated is controlled by OS X's metadata server. It looks like the behaviour you describe also affects Spotlight, so if the word boundaries are being treated incorrectly, this could be an issue outside of Alfred's control.

 

I'm going to move this to noted in case the behaviour changes in OS X, then I will check if Alfred is still affected.

 

Cheers,

Andrew

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...