Jump to content

"open terminal here" doesn't escape pipe symbol [Fixed 2.4 b274]


cvpeck
 Share

Recommended Posts

Hi,

Using the "open terminal here" shortcut from the Alfred file options menu fails if the filename has pipe symbols in it. More worrying is that the filename parts then get executed as commands. (Alfred 2.3 264)

 

cd /Users/me/Movies/Photoshop\ |\ Photoshop\ For\ Printing\ |\ Richard\ Riley\ |\ Kelby\ Media\ Group\ |\ 2010/
MacBook-Pro:~ me$ cd /Users/me/Movies/Photoshop\ |\ Photoshop\ For\ Printing\ |\ Richard\ Riley\ |\ Kelby\ Media\ Group\ |\ 2010/
-bash:  2010/: No such file or directory
-bash: cd: /Users/me/Movies/Photoshop : No such file or directory
-bash:  Kelby Media Group : command not found
-bash:  Photoshop For Printing : command not found
-bash:  Richard Riley : command not found
Link to comment
Share on other sites

 

Hi,

Using the "open terminal here" shortcut from the Alfred file options menu fails if the filename has pipe symbols in it. More worrying is that the filename parts then get executed as commands. (Alfred 2.3 264)

 

cd /Users/me/Movies/Photoshop\ |\ Photoshop\ For\ Printing\ |\ Richard\ Riley\ |\ Kelby\ Media\ Group\ |\ 2010/
MacBook-Pro:~ me$ cd /Users/me/Movies/Photoshop\ |\ Photoshop\ For\ Printing\ |\ Richard\ Riley\ |\ Kelby\ Media\ Group\ |\ 2010/
-bash:  2010/: No such file or directory
-bash: cd: /Users/me/Movies/Photoshop : No such file or directory
-bash:  Kelby Media Group : command not found
-bash:  Photoshop For Printing : command not found
-bash:  Richard Riley : command not found

 

 

Well spotted, I'll get this sorted for 2.4, thanks! :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...