Jump to content

Recommended Posts

Hey Justin,

 

Thanks for the workflow, iv'e been missing it since the mailbox app came out :)

 

I cant get it to work properly though; it works perfectly fine when MB already is on my desk, it doesn't have to be active either. But when minimized i just get a "thump"-sound and nothing happens. I looked at the script (not knowing much about theese things) and it seems like the "tell application x to activate" might need to be preceeded by a "tell application x to maximize" or something first? If you got the time, i'd sure appreciate if you took a look at it.

 

Thanks,

Rickard

Share this post


Link to post

Thanks for the note Rickard!


 


What version of MB are you on? I tried replicating the error but no luck yet…


 


Also, are you getting the thumping error when you simply open MB using Alfred? Or is it only occurring when you use the workflows (compose, search, later)?


 


~justin


Share this post


Link to post

Hey Justin, sorry I haven't got back to you, thought I'd get a notification from the forum of some sort if you'd replied. Guess it's in the settings. Anyways:

 

I took a closer look, and it turns out all of the scripts works fine if MB is either active or hidden. The problem occur if it's minimized,

 

I'm on a Macbook Pro mid 2014, specs below. Running  Mavericks 10.9.4 and latest build of MB. 

 

Hope you can figure it out, thanks a lot / Rickard 

 

Model Name: MacBook Pro

Model Identifier: MacBookPro11,3

Processor Name: Intel Core i7

Processor Speed: 2,5 GHz

Number of Processors: 1

Total Number of Cores: 4

L2 Cache (per Core): 256 KB

L3 Cache: 6 MB

Memory: 16 GB

Boot ROM Version: MBP112.0138.B07

SMC Version (system): 2.19f7

Share this post


Link to post

edit: opening/activating Mailbox in Alfred by just typing the app name works fine, even if minimized

 

 

Same thing for me (search not working when minimized). 

 

Workflow works great if the app is active though! :) 

Share this post


Link to post

Actually, fixed it. 

 

add the line 

 

tell application "Mailbox (Beta)" to reopen

 

between the first and second lines of the applescript chunks. :) 

Share this post


Link to post

It has been a while, and Mailbox is version 0.7.4 right now, but I believe the Workflow isn't working anymore. I'm a doing something wrong, or is an update required from the Workflow side?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...