Jump to content
getthething

Certain Applications Aren't Found In Results

Recommended Posts

Perhaps this doesn't qualify as a bug but I'm running B100 and Mac 10.8.2 and when I search for certain apps it won't find them. I can't seem to find a common thread between them but so far I've notice it won't find:

 

Chrome

Safari

iTunes

Preview

 

It won't find them using the 'find' or 'open' commands either. They are found by Spotlight so it doesn't seem to be an indexing issue.

Share this post


Link to post

Try two things and let me know the outcome please.

 

1. Pop up Alfred and type Reload and press enter to reload the Application Cache.

2. If the above doesn't work, even though Spotlight finds them, try reindexing.

 

Let me know if this clears up your issue.

Share this post


Link to post
Try two things and let me know the outcome please.

 

1. Pop up Alfred and type Reload and press enter to reload the Application Cache.

2. If the above doesn't work, even though Spotlight finds them, try reindexing.

 

Let me know if this clears up your issue.

 

Ok. I reloaded and reindexed spotlight. It will find Chrome, Safari and Preview now. It still won't find iTunes however. 

Share this post


Link to post
Ok. I reloaded and reindexed spotlight. It will find Chrome, Safari and Preview now. It still won't find iTunes however. 

 

Try "Get Info" on iTunes and renaming it. Wait a moment then rename it back to iTunes. This will force Spotlight to reindex the data about that app.

 

I'm moving this to "Discussion" as this isn't a beta bug and I'd like to keep this forum as clear as possible to just v2 bugs.

Share this post


Link to post

I spoke too soon. It doesn't find Chrome. It only found Chrome because it was running I guess. 

 

Edit: Now it find iTunes for some reason. It's not running. It's acting very strange. Finding things, then not finding them, then finding them again. 

Share this post


Link to post
Try "Get Info" on iTunes and renaming it. Wait a moment then rename it back to iTunes. This will force Spotlight to reindex the data about that app.

 

I'm moving this to "Discussion" as this isn't a beta bug and I'd like to keep this forum as clear as possible to just v2 bugs.

 

I am unable to rename iTunes either through the Finder or the Get Info window. I don't know if this helps but my startup disk is on a solid state and my User directory is on a different drive. Alfred 1 can still find all of these things normally. 

Share this post


Link to post

I thought I was having a similar issue but found the cause for me. First the way I fix it is by going into Alfred's Advanced tab and clicked "Clear Cache" all my missing apps are then found. 

 

The reason this happened to me is because I use MacCleanse. It's default cache cleaning mode includes the System - User Cache data. When this is cleared Alfred still seems to find files but Applications completely disappear until I go and manually click "Clear Cache" for some reason using the "Reload Alfred Cache" keyword command doesn't fix this. It's only when I go in and click the "Clear Cache" button.

 

Hopefully this helps.

Share this post


Link to post

John,

Glad you were able to resolve your issue. The method you're suggesting is also the same method I suggested previously in this thread. The ''reload" command clears the app cache without having to visit the Alfred preferences first

Share this post


Link to post

Hi all,

 

I'm having the same problems with Alfred 2, I've done everything that everyone has suggested above but I'm still have some issues where Alfred 1 is finding loads more applications than Alfred 2.

 

for example, if I'm trying to run the application 'Parsley is Atomically Delicious'.

 

In Alfred 1, if I start typing 'pars' then it comes up first on the list, yet on Alfred 2 I'm getting some other files not even related to it and it's not even in the list, admittedly Spotlight cannot find it either and that's after a reindex.

 

Megan

Share this post


Link to post

Megan-- I have had the same thing happen a time or two with different apps. Even a Spotight reindex did not fix it for me either. I ended up deleting the app, then reinstalling it and for whatever reason Spotlight picked it up after that. Last time was with the cookbook app Paprika. I have no idea why this happens, but a delete and reinstall fixed it.

Share this post


Link to post

Guys, I spent hours reloading my  index, etc. I found this little thing. Hope it helps: http://hints.macworld.com/article.php?story=20111103045420308

 

I wasn't able to do everything it said, but I moved the culprits to a different folder and then changed the info to shared (I did it also after I moved it back just in case) and now it works perfectly!

Edited by minsanity

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...