Jump to content
Sign in to follow this  
shadowfax1

No apps whatsoever in alfred search

Recommended Posts

I upgraded to Yosemite yesterday on my MBP. I'm running Alfred 2.5.1 (306).

 

At first it was working just fine, but I noticed it wasn't finding 1password 5 as I type commands into the Alfred window. I usually would get 1password to show up as soon as I typed "1" or "1p", but the only thing it was showing is "1Password Bookmark...". It would never show the app itself, which I wanted to launch as opposed to looking up a bookmark.

 

So I went to Alfred preferences, and cleared the Application Cache under the Advanced tab. Didn't help. So I rebuilt the OS X Metadata index, deleting the Spotlight index in the process. It ran for hours yesterday evening, all night, and hours more this morning and it still didn't fix it.

 

Oddly enough, it I use Spotlight to try and find applications, it's not finding those either. So I'm thinking it's not Alfred, but I can't be sure since I have never one used spotlight since I first installed Alfred a couple versions ago.

 

Any thoughts?

Share this post


Link to post

I upgraded to Yosemite yesterday on my MBP. I'm running Alfred 2.5.1 (306).

 

At first it was working just fine, but I noticed it wasn't finding 1password 5 as I type commands into the Alfred window. I usually would get 1password to show up as soon as I typed "1" or "1p", but the only thing it was showing is "1Password Bookmark...". It would never show the app itself, which I wanted to launch as opposed to looking up a bookmark.

 

So I went to Alfred preferences, and cleared the Application Cache under the Advanced tab. Didn't help. So I rebuilt the OS X Metadata index, deleting the Spotlight index in the process. It ran for hours yesterday evening, all night, and hours more this morning and it still didn't fix it.

 

Oddly enough, it I use Spotlight to try and find applications, it's not finding those either. So I'm thinking it's not Alfred, but I can't be sure since I have never one used spotlight since I first installed Alfred a couple versions ago.

 

Any thoughts?

 

It sounds like Spotlight's metadata index is broken as this shouldn't take more than an hour.

 

When you run the rebuild shortcut in Alfred's advanced preferences, did you select to delete the V100 folder... if not, it might be worth doing so as this fully resets the index.

 

Also, are any errors showing in the Terminal window when starting the rebuild?

Share this post


Link to post

Hello,

I 've the same problem since I installed Yosemite and I already built up the index from scratch... :-(

 

Never thought it would be so hard to use my Mac without Alfred's 1P functionality... 

 

Regards,

 

Gordon

Share this post


Link to post

I have a problem with 1Password 5 too after upgrading to Yosemite. I get the "unable to find 1 Password data" error and can't get 1Password bookmarks in Alfred. I tried everything to make it work:

 

1) Checked/unchecked Enable 1Password bookmarks

2) Checked/unchecked Discover Automatically

3) I even put the path to the 1Password JSON file in the Library manually

4) I checked/unchecked Enable 3rd party integration in 1Password

 

So, I did all of these things, restarting Alfred after each one of them, but still nothing. When I type "1p", I get two items, the application itself, and "1Password mini" (the mini item wasn't there before in Lion). I can't get Alfred to show me the 1Password bookmarks any more. This was probably the shortcut that I use most every day, opening 1P bookmarks in Alfred.

 

In case it helps, 1Password is synced with iCloud, and Alfred's preferences are synced with Dropbox between my desktop and laptop computers. 

 

Could you please tell me what I need to do to fix this, because otherwise I am loosing a feature that I use most on Alfred? Thanks!

Share this post


Link to post

I have a problem with 1Password 5 too after upgrading to Yosemite. I get the "unable to find 1 Password data" error and can't get 1Password bookmarks in Alfred. I tried everything to make it work:

 

1) Checked/unchecked Enable 1Password bookmarks

2) Checked/unchecked Discover Automatically

3) I even put the path to the 1Password JSON file in the Library manually

4) I checked/unchecked Enable 3rd party integration in 1Password

 

So, I did all of these things, restarting Alfred after each one of them, but still nothing. When I type "1p", I get two items, the application itself, and "1Password mini" (the mini item wasn't there before in Lion). I can't get Alfred to show me the 1Password bookmarks any more. This was probably the shortcut that I use most every day, opening 1P bookmarks in Alfred.

 

In case it helps, 1Password is synced with iCloud, and Alfred's preferences are synced with Dropbox between my desktop and laptop computers. 

 

Could you please tell me what I need to do to fix this, because otherwise I am loosing a feature that I use most on Alfred? Thanks!

 

If you've updated to 1Password 5, you'll need to download Alfred v2.5.1, which you can get by going to Alfred's Updated preferences, choosing "Pre-releases" from the bottom dropdown and updating. This pre-release provides support for 1Password 5.

 
You can then return to the regular updates if you're not interested in future pre-releases :)

Share this post


Link to post

 

If you've updated to 1Password 5, you'll need to download Alfred v2.5.1, which you can get by going to Alfred's Updated preferences, choosing "Pre-releases" from the bottom dropdown and updating. This pre-release provides support for 1Password 5.

 
You can then return to the regular updates if you're not interested in future pre-releases :)

 

 

Thanks, that did the trick! :) 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  
×
×
  • Create New...