Jump to content

Unable to set keyboard shortcut to command-space


ahecht
 Share

Recommended Posts

On Yosemite, I'm having trouble with all kinds of preferences not sticking or not being able to be set.

 

- I'm not able to set my keyboard shortcut to Command-Space. I have the Spotlight keyboard shortcuts turned off (and also set to something else just in case).

- When I set the appearance to something other than the default, it reverts back after quitting and relaunching Alfred Preferences. For example, I switched the theme to OS X Yosemite Light, turned off the hat and the cog and then quit the Preferences app. When I go to preferences again, it's back to Alfred Light.

- None of my custom searches are being loaded.

 

Using v2.5.1 on Yosemite 10.0.

 

I've tried re-installing Alfred, deleting all preference, cache, and application support files, and no change.

 

Link to comment
Share on other sites

On Yosemite, I'm having trouble with all kinds of preferences not sticking or not being able to be set.

 

- I'm not able to set my keyboard shortcut to Command-Space. I have the Spotlight keyboard shortcuts turned off (and also set to something else just in case).

- When I set the appearance to something other than the default, it reverts back after quitting and relaunching Alfred Preferences. For example, I switched the theme to OS X Yosemite Light, turned off the hat and the cog and then quit the Preferences app. When I go to preferences again, it's back to Alfred Light.

- None of my custom searches are being loaded.

 

Using v2.5.1 on Yosemite 10.0.

 

I've tried re-installing Alfred, deleting all preference, cache, and application support files, and no change.

 

It not saving the theme sounds like a permissions problem. Could you try repairing your disk permissions in Disk Utility? If that doesn't resolve  the issue and you currently use Alfred's syncing feature, could you try setting the sync folder to somewhere else temporarily? Perhaps within ~/Documents. Try those things and report back please

Link to comment
Share on other sites

Ok, I repaired permissions, that didn't change anything.

 

Switched sync to a different folder, and that did resolve the appearance issue.

 

I'm still unable to set the hotkey to Command-Space, though. My muscle-memory on that one is very strong!

 

I've lost my custom searches too, hopefully I'll be able to recreate those from a different computer.

Link to comment
Share on other sites

I'm still unable to set the hotkey to Command-Space, though. My muscle-memory on that one is very strong!

 

The only reason you wouldn't be able to set the hotkey to Cmd + Space is if OS X is reserving it for another purpose. Take a look at the instructions relating to using multiple keyboard input sources (multiple languages) on your Mac:

http://support.alfredapp.com/kb:cmd-space

Link to comment
Share on other sites

Hmm..  So confusing.

 

I've followed all these instructions, and here's what's happening:

- One my laptop, the Alfred window is triggered by Cmd + Space. But in Preferences, the hotkey shows as Option + Space.

- The *actual* appearance of the Alfred window is Yosemite Light with the hat and cog hidden. But in Preferences, the Theme is shown as Light, with hat and cog not hidden.

 

It will work this way until I quit the app. If I quit Alfred (the actual app, not just the Preferences), it all reverts back to the way the preferences say, i.e. default Light theme, showing hat and cog, and triggered by Option + Space instead of Cmd + Space.

 

If I set the syncing to a different folder, it seems to fix it locally for this machine only, but as soon as I set another computer to sync to the same location, everything is haywire again.

 

I'll keep investigating... getting quite frustrating..

Link to comment
Share on other sites

 

If I set the syncing to a different folder, it seems to fix it locally for this machine only, but as soon as I set another computer to sync to the same location, everything is haywire again.

 

Where are your settings synced? If you're using Dropbox, please make sure you're not using the ~/Dropbox/Apps/ folder, as many users have reported issues with preferences saving correctly in that folder:

http://support.alfredapp.com/kb:dropbox-apps-folder

 

Could you also launch Activity Monitor and check you don't simply have two instances of Alfred running? It's possible for Alfred v1 and v2 to run side by side, which could explain why settings appear to be changing.

Link to comment
Share on other sites

FYI, I think I got this solved. I'm using Dropbox, and the only way I could get this to work was to start syncing to an entirely new folder within my Dropbox. Whenever I tried to sync with an existing folder, whether or not I had ever synced my Alfred preferences to that folder before, I had these symptoms. Creating a brand-new folder and syncing there (after first making sure Alfred was not running on all machines except one) got it to start working again.

 

Weird, but at least solved for now.

 

Thanks!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...