Jump to content

Yet Another Weather Workflow


Recommended Posts

  • Replies 64
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I couldn't find any forecast workflows that were quite to my liking, so I whipped one up that gets a forecast from forecast.io:     Note: requires at least Mavericks. Not tested on

Just FYI, since forecast.io is becoming darksky.net, I've changed forecast.alfredworkflow accordingly to dark-sky.alfredworkflow:   https://github.com/kejadlen/dark-sky.alfredworkflow h

Yes it does.  When I begin to write config-forecast into alfred it shows the config item - but if I hit return, it completes the title in alfred and then lists search engines underneath.  Same if I type the whole string (config-forecast)  - as soon as I type the last "t" it immediately gets rid of the config-forecast item below the entry box and just lists search engines.

 

I tried deleting the workflow and re-downloading the one from the link you provided and get the same result.

Link to post

It gave an error.  here is the gist of it:

 

[ERROR: alfred.workflow.input.scriptfilter] Code 1: /Users/adamfrank/Library/Application Support/Alfred 2/Alfred.alfredpreferences/workflows/user.workflow.6D4896F1-26C2-4E79-9DF2-F3D68D7F0A89/vendor/bundle/ruby/2.0.0/gems/alphred-1.1.0/lib/alphred/config.rb:20:in `initialize': No such file or directory - /Users/adamfrank/Library/Application Support/Alfred 2/Workflow Data/com.kejadlen.forecast/config.json (Errno::ENOENT)

Link to post

Thank you.  The Config part now works.  However I have entered the api code, but when I type forecast, it again gives me the default search engines.  Not sure if I am missing something or not.  I got the api from the forecast.io link and entered it into the config.  I also tried the google api as well, and that did not work either.

Link to post

Here is what I get:

 

[ERROR: alfred.workflow.input.scriptfilter] Code 1: /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/open-uri.rb:353:in `open_http': 400 Bad Request (OpenURI::HTTPError)

from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/open-uri.rb:709:in `buffer_open'

from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/open-uri.rb:210:in `block in open_loop'

from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/open-uri.rb:208:in `catch'

from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/open-uri.rb:208:in `open_loop'

from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/open-uri.rb:149:in `open_uri'

from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/open-uri.rb:689:in `open'

from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/open-uri.rb:34:in `open'

from /Users/adamfrank/Library/Application Support/Alfred 2/Alfred.alfredpreferences/workflows/user.workflow.CF5444F0-A77A-4022-8010-679B9CE17075/forecaster.rb:21:in `forecast'

from /Users/adamfrank/Library/Application Support/Alfred 2/Alfred.alfredpreferences/workflows/user.workflow.CF5444F0-A77A-4022-8010-679B9CE17075/forecaster.rb:8:in `forecast'

from forecast.rb:60:in `<main>'

Link to post

Hey. Noticed you updated the workflow to fix the missing config file. Great! Packal seems to be out of date still. I downloaded from there and had to debug to see the config file was missing.

 

Great work otherwise.

 

Also your friend up there probably forgot to set all the keys after he updated.

Link to post
  • 4 months later...

FYI, I also have forecast-config and when I type that I get options to unset everything even though I haven't set the API keys yet. 

 

Screenshot: https://i.imgur.com/t5ncqnx.png

 

Error message: Starting debug for 'Forecast'

 

[ERROR: alfred.workflow.input.scriptfilter] Code 1: /Users/dgalloway/Dropbox/alfredBackup/Alfred.alfredpreferences/workflows/user.workflow.58484AF6-AC64-4E44-B750-7926730F7D66/geocoder.rb:24:in `geocode': undefined method `[]' for nil:NilClass (NoMethodError)

from /Users/dgalloway/Dropbox/alfredBackup/Alfred.alfredpreferences/workflows/user.workflow.58484AF6-AC64-4E44-B750-7926730F7D66/geocoder.rb:9:in `geocode'

from /Users/dgalloway/Dropbox/alfredBackup/Alfred.alfredpreferences/workflows/user.workflow.58484AF6-AC64-4E44-B750-7926730F7D66/location.rb:13:in `geocode!'

from /Users/dgalloway/Dropbox/alfredBackup/Alfred.alfredpreferences/workflows/user.workflow.58484AF6-AC64-4E44-B750-7926730F7D66/location.rb:9:in `initialize'

from forecast.rb:51:in `new'

from forecast.rb:51:in `<main>'

Link to post

Well, that was pretty silly of me. I'll put the version somewhere in the next release. The latest versions of this workflow should have "config-forecast" instead of "forecast-config". If you're still seeing the latter, can you try deleting the workflow and installing the latest one?

Link to post
  • 2 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...