Jump to content

Restart wi Alfred prevents other apps opening on launch


mbbcam
 Share

Recommended Posts

I seem to have come across a strange interaction between Alfred, TextExpander and Cookie. 

 

If I shut down or restart via Alfred, TextExpander Helper fails to launch with error 10810 (set to launch at login via its own preferences), and Cookie does not launch (it is set via its own preferences to launch and hide). 

 

If I shut down or restart via the item on the Apple menu, both applications behave normally at system start. 

 

I have tried this about six or seven times in succession, and it has happened both before and after update to OS 10.10.1. 

 

OS 10.10.1

MacBook Air (13-inch, Late 2010

 

Alfred 2.5.1 (308)

 

Cheers, 

Martin BB. 

Link to comment
Share on other sites

I seem to have come across a strange interaction between Alfred, TextExpander and Cookie. 

 

Hi Martin, this seems like a very odd behaviour - and not one that's been reported before.  I've had a look online and error -10810 is due to a LaunchServices error, which is unlikely to be related to Alfred but may be due to the way Yosemite restarts.

 

Could you please try rebuilding permissions on your Mac? You can do this by launching Disk Utility, selecting your drive and clicking "Repair disk permissions"

 

Generally, it seems users are reporting that either the above or a restart of their Mac solved the issue. If you're still encountering the issue, it may be worth resetting your preferences on these apps in case corrupted preferences are playing a part in the crash. (Back them up first)

 

Let me know how you get on :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...