Jump to content

Deleting workflows doesn't work


alexh2
 Share

Recommended Posts

I was trying to delete some workflows, but when I closed and opened the preferences window again, all the "deleted" workflows were back. I tried to delete them a couple of times, but they kept coming back.

 

Alfred version: v2.5.1 (308)

OS X version: 10.10.1 Yosemite

Link to comment
Share on other sites

I was trying to delete some workflows, but when I closed and opened the preferences window again, all the "deleted" workflows were back. I tried to delete them a couple of times, but they kept coming back.

 

Alfred version: v2.5.1 (308)

OS X version: 10.10.1 Yosemite

 

Hi Alex, 

 

Are you syncing your settings? If workflows aren't being deleted, it's possible that you have a permissions issue on your Mac, meaning that Alfred can't delete files in your Dropbox folder.

 

Pop up Alfred's preferences to the Workflows tab, right-click on your workflow and choose "Show in Finder". Then manually delete the workflow from Finder. It should then disappear from Alfred a few seconds later. :)

 

Cheers,

Vero

Link to comment
Share on other sites

Hi Alex, 

 

Are you syncing your settings? If workflows aren't being deleted, it's possible that you have a permissions issue on your Mac, meaning that Alfred can't delete files in your Dropbox folder.

 

Pop up Alfred's preferences to the Workflows tab, right-click on your workflow and choose "Show in Finder". Then manually delete the workflow from Finder. It should then disappear from Alfred a few seconds later. :)

 

Cheers,

Vero

That works. And I just checked if I was syncing my settings, but I'm not. I thought I did have a folder set in Dropbox for sync, but I don't.

Link to comment
Share on other sites

That works. And I just checked if I was syncing my settings, but I'm not. I thought I did have a folder set in Dropbox for sync, but I don't.

 

There may be a permissions issue preventing Alfred from deleting the workflows, perhaps pasting the following (bold things) in Terminal.app:

 

Firstly, go to the Alfred 2 folder (this is the folder if you don't have Syncing setup):

cd Library/Application\ Support/Alfred\ 2/

 

Next, remove any extended attributes on Alfred's prefs:

xattr -rc Alfred.alfredpreferences

 
Finally, reset the permissions on Alfred's prefs:
chmod -R u+rwX,go+rX Alfred.alfredpreferences
 
Things should now work as expected :)
 
Cheers,
Andrew
Link to comment
Share on other sites

 

There may be a permissions issue preventing Alfred from deleting the workflows, perhaps pasting the following (bold things) in Terminal.app:

 

Firstly, go to the Alfred 2 folder (this is the folder if you don't have Syncing setup):

cd Library/Application\ Support/Alfred\ 2/

 

Next, remove any extended attributes on Alfred's prefs:

xattr -rc Alfred.alfredpreferences

 
Finally, reset the permissions on Alfred's prefs:
chmod -R u+rwX,go+rX Alfred.alfredpreferences
 
Things should now work as expected :)
 
Cheers,
Andrew

 

Sorry for the late reply. I have my settings synced to Dropbox again. Is there still a way to fix the permissions?

Link to comment
Share on other sites

Sorry for the late reply. I have my settings synced to Dropbox again. Is there still a way to fix the permissions?

 

Yes indeed, it will be the same commands as above but the first one you'll need to cd to the location of Alfred.alfredpreferences in your Dropbox. Mine is stored in ~/Dropbox/Alfred so I would type:

 

cd ~/Dropbox/Alfred

 

then run the xattr and chmod commands. Where have you set your sync folder to exactly and I can help you get to the correct folder in terminal.

 

Cheers,

Andrew

Link to comment
Share on other sites

Yes indeed, it will be the same commands as above but the first one you'll need to cd to the location of Alfred.alfredpreferences in your Dropbox. Mine is stored in ~/Dropbox/Alfred so I would type:

 

cd ~/Dropbox/Alfred

 

then run the xattr and chmod commands. Where have you set your sync folder to exactly and I can help you get to the correct folder in terminal.

 

Cheers,

Andrew

Mine is also set to ~/Dropbox/Alfred. But when i use the xattr and chmod commands, terminal keeps saying that the operations are not permitted.

Link to comment
Share on other sites

Mine is also set to ~/Dropbox/Alfred. But when i use the xattr and chmod commands, terminal keeps saying that the operations are not permitted.

 

Could you paste the response to the following two commands in Terminal:

 

cd ~/Dropbox/Alfred

ls -la

 

Thanks,

Andrew

Link to comment
Share on other sites

 Share

×
×
  • Create New...