Jump to content

File name containing dashes


Recommended Posts

Hello,

 

I noticed that if I have a file names word1-word2.txt, Alfred will not find it when I type “word1 word2”. If I replace the dash with an underline, it works. How can I convince Alfred to look at dashes like word separators?

 

I have fuzzy matching turned on, but I believe this only have an impact for .app files anyway.

 

Any idea? I unfortunately get a lot of pdf named-like-this, and renaming each one is annoying...

 

Cheers,

Link to post

Hello,

 

I noticed that if I have a file names word1-word2.txt, Alfred will not find it when I type “word1 word2”. If I replace the dash with an underline, it works. How can I convince Alfred to look at dashes like word separators?

 

I have fuzzy matching turned on, but I believe this only have an impact for .app files anyway.

 

Any idea? I unfortunately get a lot of pdf named-like-this, and renaming each one is annoying...

 

Cheers,

 

Alfred should be perfectly happy with this... are you using the file search mode (open keyword, or prefixing your search with [spacebar]?)...

 

split%20search.png

Cheers,

Andrew

Link to post
  • 2 weeks later...

I can do with or without leading space, same result. Dashes somehow are not recognised as word separators...

 

A few people have reported this since updating to 10.10.2, so I wonder if Apple have changed (broken) something with word matching in the metadata server as it has only affected a couple of people.

 

First, if you could try reindexing OS X from Alfred's advanced prefs. If that doesn't seem to help, you could always replace the built in open filter with a workflow which doesn't do word based matching... here is one to get you started with keyword 'o':

 

https://dl.dropboxusercontent.com/u/6749767/Alfred/Workflows/Replacement%20File%20Filter.alfredworkflow

 

Let me know how you get on :)

 

Cheers,

Andrew

Link to post

It seems you are right, this is a spotlight issue. Spotlight also can't find my pdf called “123-guide.pdf” (without quotes of course) when I type “123 guide” without quote in spotlight's search field. I re-indexed spotlight from Alfred (even deleted the .Spotlight-V100 file), but no luck, that didn't change anything.

 

It works with the workflow though, pretty nice. Thanks!

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...