Jump to content

Duplicate text pasted when using "Copy to clipboard" block


cdh3988
 Share

Recommended Posts

Able to replicate: Yes, every time
Alfred Version: Version 2.7.1, April 15, 2015
OS X Version: Version 10.10.4

 

 

Steps to reproduce:

1. Create a new workflow by clicking the "+" button

2. Templates->Clipboard->Paste text clip from hotkey

3. Assign a hotkey

4. Open the block "Copy to clipboard"

    Enter any text you want to be pasted when invoking the hotkey

    Check "Automatically paste to front most app"

5. Save

6. Go to any text area or text app and invoke the hotkey

7. The text is copied in twice

8. Uncheck "Automatically paste to from most app"

9. Nothing is pasted, so I'm assuming there is no other script running which my account for the duplication

 

You can see the steps to reproduce the issue here https://www.dropbox.com/s/3y3sexj02jir16r/Duplicate%20pasting.pdf?dl=0

 

 

Thanks so much for your help!

 

  Most appreciatively,

 

     -- Chad

 

 

 

Link to comment
Share on other sites

Able to replicate: Yes, every time

Alfred Version: Version 2.7.1, April 15, 2015

OS X Version: Version 10.10.4

 

 

Steps to reproduce:

1. Create a new workflow by clicking the "+" button

2. Templates->Clipboard->Paste text clip from hotkey

3. Assign a hotkey

4. Open the block "Copy to clipboard"

    Enter any text you want to be pasted when invoking the hotkey

    Check "Automatically paste to front most app"

5. Save

6. Go to any text area or text app and invoke the hotkey

7. The text is copied in twice

8. Uncheck "Automatically paste to from most app"

9. Nothing is pasted, so I'm assuming there is no other script running which my account for the duplication

 

You can see the steps to reproduce the issue here https://www.dropbox.com/s/3y3sexj02jir16r/Duplicate%20pasting.pdf?dl=0

 

 

Thanks so much for your help!

 

  Most appreciatively,

 

     -- Chad

 

Hi Chad,

 

I've tried to replicate this behaviour by creating the same workflow and can't see the issue. Are you using any other clipboard-related applications that may be interfering? (PopClip comes to mind but there are many others out there)

 

If the hotkey itself isn't triggering a paste, it's likely that the Cmd + V action performed by the workflow is triggering another script/workflow/app. As you said, your workflow itself hasn't changed so there'll be an external factor causing this. As such, it'll be worth temporarily deactivating other workflows or apps that could be clashing until you find the right one :)

 

Let me know how you get on!

 

Cheers,

Vero

Link to comment
Share on other sites

  • 2 weeks later...

[update: Oops, I corrected the link to the video demo]

 

Vero,

 

  Thanks so much for your response and experiment!  Sorry for the long delay, I was traveling abroad.

 

If the hotkey itself isn't triggering a paste, it's likely that the Cmd + V action performed by the workflow is triggering another script/workflow/app.

 

That's what I thought as well.  Please take a peek at my own experiment.  I've prepared a short video exploring this possibility.  It has three steps.

 

(1) Set the flow to "Automatically paste to front most app”, then invoke the hotkey in Pages

     Result: Double-pasted text

 

(2) Just use Cmd + V itself to see if that causes the problem, or invokes another flow or app

    Result: Correctly pasted text with no duplication

​    The text was already on the clipboard from Step 1.  No other flow or app seems to be being invoked by Cmd + V

 

(3) Edit the flow and uncheck  "Automatically paste to front most app”, then invoke the hotkey in Pages

   Result: Nothing at all is copied.

 

It does not seem to be another workflow or application based on the results.  What are your thoughts?

 

Please click here to see the video.

 

 

 Appreciatively,

 

      -- Chad

Edited by cdh3988
Link to comment
Share on other sites

 Share

×
×
  • Create New...