Jump to content

Search Omnifocus: free text search your Omnifocus data


Recommended Posts

@rhydFirst off thank you for building this and taking the time to reply. 

 

When I copy and paste that line into terminal, it doesn't return anything.  I'm not sure what I'm doing wrong.  I use Omnisync, their server for synchronizing between devices if that matters.

 

If I go into Omnifocus, then the file dropdown menu and hold alt, it gives me the option to "Show "Omnifocus.ofocus" in Finder" - when I choose that option it takes me to /Users/rlow/Library/Containers/com.omnigroup.OmniFocus3/Data/Library/Application Support/OmniFocus

Edited by rlow
Link to comment
On 8/31/2020 at 4:16 PM, rlow said:

@rhydFirst off thank you for building this and taking the time to reply. 

 

When I copy and paste that line into terminal, it doesn't return anything.  I'm not sure what I'm doing wrong.  I use Omnisync, their server for synchronizing between devices if that matters.

 

If I go into Omnifocus, then the file dropdown menu and hold alt, it gives me the option to "Show "Omnifocus.ofocus" in Finder" - when I choose that option it takes me to /Users/rlow/Library/Containers/com.omnigroup.OmniFocus3/Data/Library/Application Support/OmniFocus

 

No worries. Can you:

 

1) open the folder below in the Finder (open a Finder window, press ⌘-⇧-G and paste the location below into the "Go to the folder" dialog)

/Users/rlow/Library/Containers/com.omnigroup.OmniFocus3/Data/Library/Application Support/

2) open the OmniFocus Caches folder and check if you can see a file called OmniFocusDatabase?

Link to comment

@rhyd - There was no Caches folder in the path you pointed me to, but when I searched for OmniFocusDatabase I found OmniFocusDatabase.db at the following path:

 

/Users/rlow/Library/Group Containers/34YW5XSRB7.com.omnigroup.OmniFocus/com.omnigroup.OmniFocus3/com.omnigroup.OmniFocusModel

Link to comment
On 9/8/2020 at 4:51 PM, rlow said:

@rhyd - There was no Caches folder in the path you pointed me to, but when I searched for OmniFocusDatabase I found OmniFocusDatabase.db at the following path:

 

/Users/rlow/Library/Group Containers/34YW5XSRB7.com.omnigroup.OmniFocus/com.omnigroup.OmniFocus3/com.omnigroup.OmniFocusModel

 

Ok, spotted the problem. The workflow is using the wrong location to find the database because you're using an out of date version of the workflow. Can you download and install v2.1.2? I should've spotted that earlier 🤦‍♂️...

 

Download v2.1.2

 

Cheers,
Rhyd

Link to comment
  • 3 months later...

Hello, I've just installed v2.1.2 for Omnifocus 3.4.6, but it seems it can't locate the db.

This is a part of the log

 

17:08:12 search.py:185 DEBUG    OmniFocus db not found at /Users/me/Library/Group Containers/34YW5XSRB7.com.omnigroup.OmniFocus/com.omnigroup.OmniFocus3/com.omnigroup.OmniFocusModel/OmniFocusDatabase.db; using /Users/me/Library/Group Containers/34YW5XSRB7.com.omnigroup.OmniFocus/com.omnigroup.OmniFocus3.MacAppStore/com.omnigroup.OmniFocusModel/OmniFocusDatabase.db instead
17:08:12 search.py:195 DEBUG    /Users/me/Library/Group Containers/34YW5XSRB7.com.omnigroup.OmniFocus/com.omnigroup.OmniFocus3.MacAppStore/com.omnigroup.OmniFocusModel/OmniFocusDatabase.db

 

Thank you very much

Link to comment
On 12/29/2020 at 4:24 PM, Manaus said:

Hello, I've just installed v2.1.2 for Omnifocus 3.4.6, but it seems it can't locate the db.

This is a part of the log

 

17:08:12 search.py:185 DEBUG    OmniFocus db not found at /Users/me/Library/Group Containers/34YW5XSRB7.com.omnigroup.OmniFocus/com.omnigroup.OmniFocus3/com.omnigroup.OmniFocusModel/OmniFocusDatabase.db; using /Users/me/Library/Group Containers/34YW5XSRB7.com.omnigroup.OmniFocus/com.omnigroup.OmniFocus3.MacAppStore/com.omnigroup.OmniFocusModel/OmniFocusDatabase.db instead
17:08:12 search.py:195 DEBUG    /Users/me/Library/Group Containers/34YW5XSRB7.com.omnigroup.OmniFocus/com.omnigroup.OmniFocus3.MacAppStore/com.omnigroup.OmniFocusModel/OmniFocusDatabase.db

 

Thank you very much

 

@Manaus Looks like Omnifocus 3.4.6 is almost a year old. If you upgrade to the latest version the problem above should be resolved. If you can't upgrade, then you could try installing v2.1.0 of the workflow to see if that solves the problem.

Link to comment
  • 3 weeks later...
  • 4 months later...

This is one of my most frequently used workflows, thanks a lot for creating and supporting it, it's been very stable over several years. The thing I miss the most is a possibility to search within completed tasks, any chance to add such a feature?

Edited by cands
Link to comment
14 hours ago, cands said:

This is one of my most frequently used workflows, thanks a lot for creating and supporting it, it's been very stable over several years. The thing I miss the most is a possibility to search within completed tasks, any chance to add such a feature?

 

Thanks for the feedback. Searching completed tasks should be ok. I'll have a look and add into a future release.

Link to comment
On 6/23/2021 at 8:59 PM, cands said:

This is one of my most frequently used workflows, thanks a lot for creating and supporting it, it's been very stable over several years. The thing I miss the most is a possibility to search within completed tasks, any chance to add such a feature?

 

@cands See v2.1.3

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...