Jump to content
tomtabruyn

Outlook 15: email as attachment is put in Drafts [Accepted, workaround available]

Recommended Posts

Alfred: v2.7.1 (387)

Outlook: v15.11.1

OSX: Yosemite 10.10.4

 

Procedure:

 

Find a file in Alfred --> (go to Actions) --> Email To... --> (choose recipient)

 

Result:

 

the mail gets created in the Drafts folder instead of being opened / foremost on the screen.

 

Alternatives:

 

If I use a link of the form "mailto:tom@hotmail.com" in safari, it opens up Outlook with the mail message just fine

If I use "email" from Alfred, and set a recipient from my contact list, it also opens Outlook correctly with the mail message to the front

Share this post


Link to post
Share on other sites

I have had this issue with Applescript as well. You might want to look at your Outlook notifications for an account permissions flag. That ended up being my problem...and one that Microsoft/Apple still has not corrected.

Share this post


Link to post
Share on other sites

Alfred: v2.7.1 (387)

Outlook: v15.11.1

OSX: Yosemite 10.10.4

 

Procedure:

 

Find a file in Alfred --> (go to Actions) --> Email To... --> (choose recipient)

 

Result:

 

the mail gets created in the Drafts folder instead of being opened / foremost on the screen.

 

Alternatives:

 

If I use a link of the form "mailto:tom@hotmail.com" in safari, it opens up Outlook with the mail message just fine

If I use "email" from Alfred, and set a recipient from my contact list, it also opens Outlook correctly with the mail message to the front

 

 

I have had this issue with Applescript as well. You might want to look at your Outlook notifications for an account permissions flag. That ended up being my problem...and one that Microsoft/Apple still has not corrected.

 

Are either of you comfortable modifying some applescript to try a fix for this? It's been a weird issue but I think the fix may be simple but I'd like to have someone else try it and see if it resolves their issue.

Share this post


Link to post
Share on other sites

I've downgraded from Outlook 15 to 14 (Outlook for Mac 2011), as both were available in my Office365 subscription at the time. Now only 15 remains on the download page, so I'm a bit hesitant to install it and not be able to go back to 14 afterwards.

 

So if anyone else can help test, I'd prefer that. But if no-one else rises to the occasion, let me know.

Edited by tomtabruyn

Share this post


Link to post
Share on other sites

I've downgraded from Outlook 15 to 14 (Outlook for Mac 2011), as both were available in my Office365 subscription at the time. Now only 15 remains on the download page, so I'm a bit hesitant to install it and not be able to go back to 14 afterwards.

 

So if anyone else can help test, I'd prefer that. But if no-one else rises to the occasion, let me know.

 

Hi there,

 

Sorry it's taken a little while to get back to you - I'll prompt David to share the script as soon as possible, which you'll be able to pop into Alfred's plugins folder. :)

 

Cheers,

Vero

Share this post


Link to post
Share on other sites

I've downgraded from Outlook 15 to 14 (Outlook for Mac 2011), as both were available in my Office365 subscription at the time. Now only 15 remains on the download page, so I'm a bit hesitant to install it and not be able to go back to 14 afterwards.

 

So if anyone else can help test, I'd prefer that. But if no-one else rises to the occasion, let me know.

 

Hey I've been trying to get some more testing done with this but I can go ahead and share the script I have for now which should get the latest Outlook for Mac working for you. Download the script linked here and drop it in this folder: ~/Library/Application Support/Alfred 2/Plugins/Email

 

That should get the latest version working. I'm still trying to get it tested to see if that breaks Outlook support in older versions. Let me know if you have any issues with this please

Share this post


Link to post
Share on other sites

Hey I've been trying to get some more testing done with this but I can go ahead and share the script I have for now which should get the latest Outlook for Mac working for you. Download the script linked here and drop it in this folder: ~/Library/Application Support/Alfred 2/Plugins/Email

 

That should get the latest version working. I'm still trying to get it tested to see if that breaks Outlook support in older versions. Let me know if you have any issues with this please

Hi

Sorry to dig up an old thread, but I have run into the same problem as detailed above when emailing from Outlook 15.

Any chance I could get hold of the script that David posted above as the fix?

(The link above is no longer working)

Many thanks

Share this post


Link to post
Share on other sites

×
×
  • Create New...